iOS 10.3.3 のセキュリティコンテンツについて

iOS 10.3.3 のセキュリティコンテンツについて説明します。

Apple セキュリティアップデートについて

Apple では、ユーザ保護の観点から、調査が終了してパッチやリリースが公開されるまでは、セキュリティ上の問題を公開、説明、または是認いたしません。最近のリリースについては、「Apple セキュリティアップデート」ページに一覧形式でまとめています。

セキュリティについて詳しくは、Apple 製品のセキュリティに関するページを参照してください。Apple との通信は、Apple Product Security PGP キーで暗号化できます。

Apple のセキュリティ関連の文書では、可能な場合、脆弱性の CVE-ID に言及しています。

iOS 10.3.3

2017 年 7 月 19 日リリース

連絡先

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:リモートの攻撃者により、アプリケーションを突然終了されたり、任意のコードを実行されたりする可能性がある。

説明:メモリ処理を強化し、バッファオーバーフローの脆弱性に対処しました。

CVE-2017-7062:Shashank 氏 (@cyberboyIndia)

CoreAudio

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:悪意を持って作成されたムービーファイルを処理すると、任意のコードが実行される可能性がある。

説明:配列境界チェック機能を改善することで、メモリ破損の脆弱性に対処しました。

CVE-2017-7008:Qihoo 360 Qex Team の Yangkang 氏 (@dnpushme)

EventKitUI

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:リモートの攻撃者が原因で、アプリケーションが突然終了する場合がある。

説明:入力検証を強化し、リソース枯渇の問題に対処しました。

CVE-2017-7007:Sapsi Consultores の José Antonio Esteban 氏 (@Erratum_)

IOUSBFamily

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:アプリケーションにカーネル権限を取得され、任意のコードを実行される可能性がある。

説明:メモリ処理を強化し、メモリ破損の脆弱性に対処しました。

CVE-2017-7009:Qihoo 360 Nirvan Team の shrek_wzw 氏

カーネル

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:アプリケーションにシステム権限を取得され、任意のコードを実行される可能性がある。

説明:メモリ処理を強化し、メモリ破損の脆弱性に対処しました。

CVE-2017-7022:匿名の研究者

CVE-2017-7024:匿名の研究者

CVE-2017-7026:匿名の研究者

カーネル

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:アプリケーションにカーネル権限を取得され、任意のコードを実行される可能性がある。

説明:メモリ処理を強化し、メモリ破損の脆弱性に対処しました。

CVE-2017-7023:匿名の研究者

CVE-2017-7025:匿名の研究者

CVE-2017-7027:匿名の研究者

CVE-2017-7069:Qihoo 360 Nirvan Team の Proteas 氏

カーネル

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:アプリケーションが、制限されたメモリを読み取れる可能性がある。

説明:入力のサニタイズ処理を強化し、検証の脆弱性に対処しました。

CVE-2017-7028:匿名の研究者

CVE-2017-7029:匿名の研究者

libarchive

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:悪意を持って作成されたアーカイブを解凍すると、任意のコードが実行される可能性がある。

説明:配列境界チェック機能を改善することで、バッファオーバーフローに対処しました。

CVE-2017-7068:OSS-Fuzz により検出

libxml2

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:悪意を持って作成された XML ドキュメントを解析すると、ユーザ情報が漏洩する可能性がある。

説明:配列境界チェック機能を改善することで、領域外読み込みに対処しました。

CVE-2017-7010:Apple

CVE-2017-7013:OSS-Fuzz により検出

libxpc

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:アプリケーションにシステム権限を取得され、任意のコードを実行される可能性がある。

説明:メモリ処理を強化し、メモリ破損の脆弱性に対処しました。

CVE-2017-7047:Google Project Zero の Ian Beer 氏

メッセージ

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:リモートの攻撃者が原因で、アプリケーションが突然終了する場合がある。

説明:メモリ処理を強化し、メモリ消費の脆弱性に対処しました。

CVE-2017-7063:Shashank 氏 (@cyberboyIndia)

通知

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:通知が、無効にしているのにロック画面に表示される場合がある。

説明:ステート管理を改善し、ロック画面の脆弱性に対処しました。

CVE-2017-7058:Süleyman Demirel Üniversitesi の Beyza Sevinç 氏

2017 年 7 月 28 日に更新

Safari

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:悪意のある Web サイトにアクセスすると、アドレスバーを偽装される可能性がある。

説明:ステート管理を改善し、ユーザインターフェイス不一致の脆弱性に対処しました。

CVE-2017-2517:Tencent の Xuanwu Lab (tencent.com) の xisigr 氏

Safari のプリント機能

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:悪意を持って作成された Web コンテンツを処理すると、無数のプリントダイアログが表示される場合がある。

説明:悪意のある Web サイトや不正利用された Web サイトが、無限個のプリントダイアログを表示して、ブラウザがロックされたとユーザに信じ込ませることができる脆弱性が存在します。この問題は、プリントダイアログを制限することで解決されました。

CVE-2017-7060:インディアナ州ミシャワカ市の Travis Kelley 氏

Telephony

対象となるデバイス:iPhone 5 以降、Wi-Fi + Cellular モデルの iPad (第 4 世代) 以降

影響:ネットワーク上で特権的な地位を悪用した攻撃者により、任意のコードを実行される可能性がある。

説明:メモリ処理を強化し、メモリ破損の脆弱性に対処しました。

CVE-2017-8248

WebKit

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:悪意のある Web サイトに、データをクロスオリジンで取得される可能性がある。

説明:悪意を持って作成された Web コンテンツを処理すると、SVG フィルタを使ったタイミングサイドチャネル攻撃が実行され、クロスオリジンデータが流出してしまう場合があります。この問題は、クロスオリジンバッファを、フィルタの対象となるフレームにはペイントしないようにすることで解決されました。

CVE-2017-7006:匿名の研究者、カリフォルニア大学サンディエゴ校の David Kohlbrenner 氏

WebKit

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:悪意のある Web サイトにアクセスすると、アドレスバーを偽装される可能性がある。

説明:フレーム処理を改善し、ステート管理の脆弱性に対処しました。

CVE-2017-7011:Tencent の Xuanwu Lab (tencent.com) の xisigr 氏

WebKit

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:悪意を持って作成された Web コンテンツを処理すると、任意のコードを実行される可能性がある。

説明:メモリ処理を強化し、複数のメモリ破損の脆弱性に対処しました。

CVE-2017-7018:Google Project Zero の lokihardt 氏

CVE-2017-7020:Baidu Security Lab の likemeng 氏

CVE-2017-7030:Ant-financial Light-Year Security Lab (蚂蚁金服巴斯光年安全实验室) の chenqin 氏

CVE-2017-7034:Ant-financial Light-Year Security Lab (蚂蚁金服巴斯光年安全实验室) の chenqin 氏

CVE-2017-7037:Google Project Zero の lokihardt 氏

CVE-2017-7039:Google Project Zero の Ivan Fratric 氏

CVE-2017-7040:Google Project Zero の Ivan Fratric 氏

CVE-2017-7041:Google Project Zero の Ivan Fratric 氏

CVE-2017-7042:Google Project Zero の Ivan Fratric 氏

CVE-2017-7043:Google Project Zero の Ivan Fratric 氏

CVE-2017-7046:Google Project Zero の Ivan Fratric 氏

CVE-2017-7048:Google Project Zero の Ivan Fratric 氏

CVE-2017-7052:Trend Micro の Zero Day Initiative に協力する cc 氏

CVE-2017-7055:英国の National Cyber Security Centre (NCSC)

CVE-2017-7056:Google Project Zero の lokihardt 氏

CVE-2017-7061:Google Project Zero の lokihardt 氏

WebKit

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:悪意を持って作成された Web コンテンツを DOMParser で処理すると、クロスサイトスクリプティング攻撃につながるおそれがある。

説明:DOMParser の処理におけるロジックに問題がありました。この問題は、ステート管理を改善することで解決されました。

CVE-2017-7038:Digital Security の Egor Karbutov 氏 (@ShikariSenpai)、Digital Security の Egor Saltykov 氏 (@ansjdnakjdnajkd)、FastMail Pty Ltd の Neil Jenkins 氏

CVE-2017-7059:Cure53 の Masato Kinugawa 氏および Mario Heiderich 氏

2017 年 7 月 28 日に更新

WebKit

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:悪意を持って作成された Web コンテンツを処理すると、任意のコードを実行される可能性がある。

説明:メモリ処理を強化し、複数のメモリ破損の脆弱性に対処しました。

CVE-2017-7049:Google Project Zero の Ivan Fratric 氏

WebKit

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:アプリケーションが、制限されたメモリを読み取れる可能性がある。

説明:メモリ処理を強化し、メモリ初期化の脆弱性に対処しました。

CVE-2017-7064:Google Project Zero の lokihardt 氏

WebKit ページの読み込み

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:悪意を持って作成された Web コンテンツを処理すると、任意のコードを実行される可能性がある。

説明:メモリ処理を強化し、複数のメモリ破損の脆弱性に対処しました。

CVE-2017-7019:Tencent Security Platform Department の Zhiyang Zeng 氏

WebKit Web インスペクタ

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:悪意を持って作成された Web コンテンツを処理すると、任意のコードを実行される可能性がある。

説明:メモリ処理を強化し、複数のメモリ破損の脆弱性に対処しました。

CVE-2017-7012:Apple

Wi-Fi

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:通信範囲内にいる攻撃者から、Wi-Fi チップに対して任意のコードを実行される可能性がある。

説明:メモリ処理を強化し、メモリ破損の脆弱性に対処しました。

CVE-2017-7065:Google Project Zero の Gal Beniamini 氏

2017 年 9 月 25 日に追加

Wi-Fi

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:Wi-Fi の通信範囲内にいる攻撃者から、Wi-Fi チップに対してサービス運用妨害を仕掛けられる可能性がある。

説明:検証を強化し、メモリ破損の脆弱性に対処しました。

CVE-2017-7066:Google Project Zero の Gal Beniamini 氏

2017 年 9 月 26 日に追加

Wi-Fi

対象となるデバイス:iPhone 5 以降、iPad (第 4 世代) 以降、iPod touch (第 6 世代)

影響:通信範囲内にいる攻撃者から、Wi-Fi チップに対して任意のコードを実行される可能性がある。

説明:メモリ処理を強化し、メモリ破損の脆弱性に対処しました。

CVE-2017-9417:Exodus Intelligence の Nitay Artenstein 氏

Apple 製以外の製品に関する情報や、Apple が管理または検証していない個々の Web サイトは、推奨や承認なしで提供されています。Apple は他社の Web サイトや製品の選定、性能、使用については一切責任を負いません。Apple は他社の Web サイトの正確性や信頼性については一切明言いたしません。インターネットの使用にはリスクがつきものです。詳しくは各社にお問い合わせください。その他の会社名や製品名は、それぞれの所有者の商標である場合があります。

公開日: