À propos des correctifs de sécurité de Xcode 4.4

Ce document décrit les correctifs de sécurité de Xcode 4.4.

Dans un souci de protection de ses clients, Apple s’interdit de divulguer, d’aborder ou de confirmer l’existence de failles de sécurité tant qu’une enquête approfondie n’a pas été effectuée et que des correctifs ou mises à jour ne sont pas disponibles. Pour obtenir des informations supplémentaires sur la sécurité produit d’Apple, consultez le site Web Sécurité produit d’Apple.

Pour en savoir plus sur la clé PGP du groupe de sécurité produit d’Apple, consultez l’article Comment utiliser la clé PGP du groupe de sécurité produit d’Apple.

Des références CVE sont utilisées, le cas échéant, pour répertorier les vulnérabilités et fournir des informations supplémentaires.

Pour obtenir des informations sur les autres mises à jour de sécurité, consultez l’article Mises à jour de sécurité Apple.
 

Xcode 4.4

  • neon

    Disponible pour : OS X Lion v10.7.4 et versions ultérieures

    Conséquence : un attaquant peut être en mesure de déchiffrer des données protégées par le protocole SSL.

    Description : la confidentialité des protocoles SSL 3.0 et TLS 1.0 est sujette à des attaques lorsqu’une suite de chiffrement utilise un chiffrement de bloc en mode d’enchaînement des blocs. La bibliothèque neon (utilisée par Subversion) a désactivé la contre-mesure « fragment vide » qui permettait d’empêcher ces attaques d’aboutir. Ce problème est résolu par l’activation des contre-mesures.

    Référence CVE

    CVE-2011-3389

  • Xcode

    Disponible pour : OS X Lion v10.7.4 et versions ultérieures

    Impact : les outils d’aide intégrés à Xcode permettent à toute application de l’App Store de lire ses entrées de trousseau.

    Description : tous les programmes signés contiennent un prérequis désigné qui indique, du point de vue du développeur du programme, les contraintes qu’un programme doit satisfaire afin d’être considéré comme une instance de ce programme. Lorsque l’identifiant d’un développeur a été utilisé avec Xcode pour signer un produit qui n’était associé à aucun identifiant de paquet, comme un outil de ligne de commande ou un outil d’aide intégré, le prérequis désigné généré pour le produit ne contenait pas l’identifiant du développeur dans le composant qui s’applique aux apps signées par l’App Store. En conséquence, il est possible que n’importe quelle app de l’App Store ait pu accéder aux éléments du trousseau créés par le produit. Ce problème peut être résolu en générant un prérequis désigné amélioré. Les produits concernés doivent être signés de nouveau avec cette version de Xcode pour intégrer la configuration désignée améliorée.

    Référence CVE

    CVE-2012-3698

Les informations se rapportant à des produits non fabriqués par Apple, ou à des sites Web indépendants qui ne sont ni contrôlés ni testés par Apple, sont fournies uniquement à titre indicatif et ne constituent aucune recommandation. Apple ne saurait être tenu pour responsable de tout problème lié à l’utilisation de tels sites ou produits tiers, ou à leurs performances. Apple ne garantit en aucune façon la fiabilité d’un site Web, ou l’exactitude des informations que ce dernier propose. L’utilisation d’Internet induit en effet des risques. Contactez le fournisseur pour obtenir des informations supplémentaires. Les autres noms de société et de produit peuvent constituer des marques déposées de leurs détenteurs respectifs.

Dernière modification:
Avez-vous trouvé cet article utile ?

Informations supplémentaires relatives à l’assistance produit

France (Français)