À propos des correctifs de sécurité de Swift 5.1.1 pour Ubuntu

Ce document décrit les correctifs de sécurité de Swift 5.1.1 pour Ubuntu.

À propos des mises à jour de sécurité Apple

Dans un souci de protection de ses clients, Apple s’abstient de divulguer, d’aborder ou de confirmer l’existence de failles de sécurité tant qu’une enquête n’a pas été effectuée et que des correctifs ou mises à jour ne sont pas disponibles. Les mises à jour récentes sont répertoriées à la page Mises à jour de sécurité Apple.

Les documents de sécurité Apple répertorient les vulnérabilités par référence CVE dans la mesure du possible.

Pour obtenir plus d’informations en matière de sécurité, consultez la page consacrée à la sécurité des produits Apple.

Swift 5.1.1 pour Ubuntu

Publié le 11 octobre 2019

Foundation

Disponible pour : Ubuntu 14.04, 16.04 et 18.04

Conséquence : une mauvaise gestion des descripteurs de fichiers dans URLSession pouvait conduire à une divulgation involontaire de données.

Description : ce problème a été résolu en mettant à jour la logique incorrecte de gestion des descripteurs de fichiers dans URLSession pour refléter Swift 5.0.

CVE-2019-8790 : Apple

Les renseignements sur les produits qui ne sont pas fabriqués par Apple ou sur les sites Web indépendants qui ne sont pas gérés ou vérifiés par Apple sont fournis sans recommandation ni approbation de la part d’Apple. Apple se dégage de toute responsabilité quant à la sélection, au bon fonctionnement ou à l’utilisation de sites Web ou de produits de tiers. Apple ne fait aucune déclaration et n’offre aucune garantie quant à l’exactitude ou à la fiabilité de ces sites Web de tiers. Communiquez avec le vendeur pour de plus amples renseignements.

Date de publication: