À propos des correctifs de sécurité d’iOS 10.3

Ce document décrit les correctifs de sécurité d’iOS 10.3.

À propos des mises à jour de sécurité Apple

Dans un souci de protection de ses clients, Apple s’interdit de divulguer, d’aborder ou de confirmer l’existence de failles de sécurité tant qu’une enquête n’a pas été effectuée et que des correctifs ou mises à jour ne sont pas disponibles. Les mises à jour récentes sont répertoriées sur la page Mises à jour de sécurité Apple.

Pour obtenir plus d’informations en matière de sécurité, consultez la page consacrée à la sécurité des produits Apple. Vous pouvez chiffrer les communications avec Apple à l’aide de la Clé PGP du groupe de sécurité produit d’Apple.

Les documents de sécurité Apple répertorient les vulnérabilités par référence CVE dans la mesure du possible.

iOS 10.3

Lancé le 27 mars 2017

Comptes

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : un utilisateur peut afficher un identifiant Apple depuis l’écran de verrouillage.

Description : un problème de gestion des invites a été résolu par la suppression des invites d’authentification iCloud de l’écran de verrouillage.

CVE-2017-2397 : Suprovici Vadim de l’équipe UniApps, un chercheur anonyme

Audio

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un fichier audio malveillant peut entraîner l’exécution arbitraire de code.

Description : un problème de corruption de la mémoire a été résolu par une meilleure validation des entrées.

CVE-2017-2430 : un chercheur anonyme en collaboration avec le programme Zero Day Initiative de Trend Micro

CVE-2017-2462 : un chercheur anonyme en collaboration avec le programme Zero Day Initiative de Trend Micro

Carbon

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un fichier .dfont malveillant peut entraîner l’exécution arbitraire de code.

Description : la gestion des fichiers de police présentait un problème de dépassement de la mémoire tampon. Ce problème a été résolu par une meilleure vérification des limites.

CVE-2017-2379 : John Villamil, Doyensec, riusksk (泉哥) de Tencent Security Platform Department

CoreGraphics

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’une image malveillante peut entraîner un déni de service.

Description : une récursion infinie a été résolue par une meilleure gestion des états.

CVE-2017-2417 : riusksk (泉哥) de Tencent Security Platform Department

CoreGraphics

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut entraîner l’exécution arbitraire de code.

Description : plusieurs problèmes de corruption de la mémoire ont été résolus par une meilleure validation des entrées.

CVE-2017-2444 : Mei Wang de 360 GearTeam

CoreText

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un fichier de polices malveillant peut entraîner l’exécution arbitraire de code.

Description : un problème de corruption de la mémoire a été résolu par une meilleure validation des entrées.

CVE-2017-2435 : John Villamil, Doyensec

CoreText

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’une police malveillante peut entraîner la divulgation du contenu de la mémoire de traitement.

Description : un problème de lecture hors limites a été résolu par une meilleure validation des entrées.

CVE-2017-2450 : John Villamil, Doyensec

CoreText

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un message texte malveillant peut entraîner un déni de service d’application.

Description : un problème d’épuisement des ressources a été résolu par une meilleure validation des entrées.

CVE-2017-2461 : Isaac Archambault d’IDAoADI, un chercheur anonyme

DataAccess

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : la configuration d’un compte Exchange comportant une erreur de saisie de l’adresse e-mail peut entraîner une résolution vers un serveur inattendu.

Description : la gestion des adresses e-mail Exchange présentait un problème de validation des entrées. Ce problème a été résolu par une meilleure validation des entrées.

CVE-2017-2414 : Ilya Nesterov et Maxim Goncharov

FontParser

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un fichier de polices malveillant peut entraîner l’exécution arbitraire de code.

Description : plusieurs problèmes de corruption de la mémoire ont été résolus par une meilleure validation des entrées.

CVE-2017-2487 : riusksk (泉哥) de Tencent Security Platform Department

CVE-2017-2406 : riusksk (泉哥) de Tencent Security Platform Department

FontParser

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : l’analyse d’un fichier de polices malveillant peut entraîner la fermeture inopinée d’une application ou l’exécution arbitraire de code.

Description : plusieurs problèmes de corruption de la mémoire ont été résolus par une meilleure validation des entrées.

CVE-2017-2407 : riusksk (泉哥) de Tencent Security Platform Department

FontParser

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’une police malveillante peut entraîner la divulgation du contenu de la mémoire de traitement.

Description : un problème de lecture hors limites a été résolu par une meilleure validation des entrées.

CVE-2017-2439 : John Villamil, Doyensec

HomeKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : la fonction Maison peut s’afficher de manière inopinée dans le centre de contrôle.

Description : la gestion de la fonction Maison présentait un problème d’état. Il a été résolu par une meilleure validation.

CVE-2017-2434 : Suyash Narain (Inde)

HTTPProtocol

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : un serveur HTTP/2 malveillant peut provoquer un comportement non défini.

Description : plusieurs vulnérabilités affectaient les versions de nghttp2 antérieures à la version 1.17.0. Elles ont été corrigées par une mise à jour de nghttp2 vers la version 1.17.0.

CVE-2017-2428

Entrée mise à jour le 28 mars 2017

ImageIO

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’une image malveillante peut entraîner l’exécution arbitraire de code.

Description : un problème de corruption de la mémoire a été résolu par une meilleure validation des entrées.

CVE-2017-2416 : Qidan He (何淇丹, @flanker_hqd) de KeenLab, Tencent

ImageIO

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : l’affichage d’un fichier JPEG malveillant peut entraîner l’exécution arbitraire de code.

Description : un problème de corruption de la mémoire a été résolu par une meilleure validation des entrées.

CVE-2017-2432 : un chercheur anonyme en collaboration avec le programme Zero Day Initiative de Trend Micro

ImageIO

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un fichier malveillant peut entraîner la fermeture inopinée d’une application ou l’exécution arbitraire de code.

Description : un problème de corruption de la mémoire a été résolu par une meilleure validation des entrées.

CVE-2017-2467

ImageIO

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’une image malveillante peut entraîner la fermeture inopinée d’une application.

Description : un problème de lecture hors limites affectait les versions de LibTIFF antérieures à la version 4.0.7. Il a été corrigé par une mise à jour de LibTIFF dans ImageIO vers la version 4.0.7.

CVE-2016-3619

iTunes Store

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : un assaillant bénéficiant d’une position privilégiée sur le réseau peut manipuler le trafic réseau d’iTunes.

Description : les demandes aux services Web de sandbox d’iTunes étaient envoyées en texte clair. Ce problème a été résolu par l’activation du protocole HTTPS.

CVE-2017-2412 : Richard Shupak (linkedin.com/in/rshupak)

JavaScriptCore

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut entraîner l’exécution arbitraire de code.

Description : un problème d’utilisation de mémoire libérée a été résolu par une meilleure gestion de la mémoire.

CVE-2017-2491 : Apple

Entrée ajoutée le 2 mai 2017

JavaScriptCore

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’une page Web malveillante peut provoquer un scriptage intersite (cross-site scripting) universel.

Description : un problème de prototype a été résolu par une meilleure logique.

CVE-2017-2492 : lokihardt de Google Project Zero

Entrée mise à jour le 24 avril 2017

Noyau

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : une application peut exécuter un code arbitraire avec des privilèges liés au noyau.

Description : un problème de corruption de la mémoire a été résolu par une meilleure validation des entrées.

CVE-2017-2398 : Lufeng Li de la Qihoo 360 Vulcan Team

CVE-2017-2401 : Lufeng Li de la Qihoo 360 Vulcan Team

Noyau

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : une application peut exécuter un code arbitraire avec des privilèges liés au noyau.

Description : un problème de dépassement d’entier a été résolu par une meilleure validation des entrées.

CVE-2017-2440 : un chercheur anonyme

Noyau

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : une application malveillante peut exécuter un code arbitraire avec des privilèges racine.

Description : un problème de concurrence a été résolu par une meilleure gestion de la mémoire.

CVE-2017-2456 : lokihardt de Google Project Zero

Noyau

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : une application peut exécuter un code arbitraire avec des privilèges liés au noyau.

Description : un problème d’utilisation de mémoire libérée a été résolu par une meilleure gestion de la mémoire.

CVE-2017-2472 : Ian Beer de Google Project Zero

Noyau

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : une application malveillante peut exécuter un code arbitraire avec des privilèges liés au noyau.

Description : un problème de corruption de la mémoire a été résolu par une meilleure validation des entrées.

CVE-2017-2473 : Ian Beer de Google Project Zero

Noyau

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : une application peut exécuter un code arbitraire avec des privilèges liés au noyau.

Description : un problème de dépassement de la mémoire tampon d’un seul octet a été résolu par une meilleure vérification des limites.

CVE-2017-2474 : Ian Beer de Google Project Zero

Noyau

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : une application peut exécuter un code arbitraire avec des privilèges liés au noyau.

Description : un problème de concurrence a été résolu par un meilleur verrouillage.

CVE-2017-2478 : Ian Beer de Google Project Zero

Noyau

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : une application peut exécuter un code arbitraire avec des privilèges liés au noyau.

Description : un problème de dépassement de la mémoire tampon a été résolu par une meilleure gestion de la mémoire.

CVE-2017-2482 : Ian Beer de Google Project Zero

CVE-2017-2483 : Ian Beer de Google Project Zero

Noyau

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : une application peut exécuter un code arbitraire avec des privilèges élevés.

Description : un problème de corruption de la mémoire a été résolu par une meilleure gestion de celle-ci.

CVE-2017-2490 : Ian Beer de Google Project Zero, le centre national de cybersécurité du Royaume-Uni (NCSC)

Entrée ajoutée le 31 mars 2017

Claviers

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : une application peut exécuter un code arbitraire.

Description : un problème de dépassement de la mémoire tampon a été résolu par une meilleure vérification des limites.

CVE-2017-2458 : Shashank (@cyberboyIndia)

Trousseau

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : un assaillant capable d’intercepter les connexions TLS peut être en mesure de lire des secrets protégés par le trousseau iCloud.

Description : dans certains cas, le trousseau iCloud ne parvenait pas à valider l’authenticité des paquets OTR. Il a été résolu par une meilleure validation.

CVE-2017-2448 : Alex Radocea de Longterm Security, Inc.

Entrée mise à jour le 30 mars 2017

libarchive

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : un assaillant local peut modifier les autorisations du système de fichiers sur des répertoires arbitraires.

Description : le traitement des liens symboliques présentait un problème de validation. Ce problème a été résolu par une meilleure validation des liens symboliques.

CVE-2017-2390 : Omer Medan de enSilo Ltd

libc++abi

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le décodage des noms d’une application C++ malveillante peut entraîner l’exécution arbitraire de code.

Description : un problème d’utilisation de mémoire libérée a été résolu par une meilleure gestion de la mémoire.

CVE-2017-2441

libxslt

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : libxslt présentait plusieurs vulnérabilités.

Description : plusieurs problèmes de corruption de la mémoire ont été résolus par une meilleure gestion de celle-ci.

CVE-2017-5029 : Holger Fuhrmannek

Entrée ajoutée le 28 mars 2017

Presse-papiers

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : une personne disposant d’un accès physique à un appareil iOS peut lire le contenu du presse-papiers.

Description : le presse-papiers était chiffré à l’aide d’une clé protégée uniquement par l’UID matériel. Ce problème a été résolu par le chiffrement du presse-papiers à l’aide d’une clé protégée par l’UID matériel et par le code de l’utilisateur.

CVE-2017-2399

Téléphone

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : une app tierce peut émettre un appel téléphonique sans interaction de l’utilisateur.

Description : iOS présentait un problème permettant d’émettre automatiquement les appels, sans confirmation préalable.  Ce problème a été résolu en invitant l’utilisateur à confirmer l’appel.

CVE-2017-2484

Profils

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : un assaillant peut exploiter les faiblesses de l’algorithme de chiffrement DES.

Description : la prise en charge de l’algorithme de chiffrement 3DES a été ajoutée au client SCEP et l’algorithme DES a été abandonné.

CVE-2017-2380 : un chercheur anonyme

Coup d’œil

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : toucher un lien comportant un numéro de téléphone dans un document PDF peut déclencher un appel sans en avertir l’utilisateur.

Description : la vérification de l’URL d’un numéro de téléphone avant de passer un appel présentait un problème. Ce problème a été résolu par l’affichage d’un message de confirmation supplémentaire.

CVE-2017-2404 : Tuan Anh Ngo (Melbourne, Australie), Christoph Nehring

Safari

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : la consultation d’un site Web malveillant peut entraîner une utilisation détournée de la barre d’adresse.

Description : un problème de gestion des états a été résolu en désactivant la saisie de texte jusqu’au chargement de la page de destination.

CVE-2017-2376 : un chercheur anonyme, Michal Zalewski de Google Inc, Muneaki Nishimura (nishimunea) de Recruit Technologies Co., Ltd., Chris Hlady de Google Inc, un chercheur anonyme, Yuyang Zhou de Tencent Security Platform Department (security.tencent.com)

Safari

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : un utilisateur local peut découvrir les sites Web consultés par un tiers en mode de navigation privée.

Description : la suppression de SQLite présentait un problème. Ce problème a été résolu par un meilleur nettoyage de SQLite.

CVE-2017-2384

Safari

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut présenter des feuilles d’authentification sur des sites Web arbitraires.

Description : la gestion de l’authentification HTTP présentait un problème d’usurpation et de déni de service. Ce problème a été résolu en rendant les feuilles d’authentification HTTP non modales.

CVE-2017-2389 : ShenYeYinJiu de Tencent Security Response Center, TSRC

Safari

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquences : la consultation d’un site Web malveillant, ouvert après avoir cliqué sur un lien, peut entraîner une utilisation détournée de l’interface utilisateur.

Description : la gestion des invites FaceTime présentait un problème d’usurpation. Ce problème a été résolu par une meilleure validation des entrées.

CVE-2017-2453 : xisigr du Xuanwu Lab de Tencent (tencent.com)

Lecteur Safari

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : l’activation de la fonctionnalité Lecteur Safari sur une page Web malveillante peut provoquer un scriptage intersite universel.

Description : plusieurs problèmes de validation ont été résolus par un meilleur nettoyage des entrées.

CVE-2017-2393 : Erling Ellingsen

SafariViewController

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : l’état du cache n’est pas correctement synchronisé entre Safari et SafariViewController lorsqu’un utilisateur efface le cache de Safari.

Description : l’effacement des informations du cache de Safari depuis SafariViewController présentait un problème.  Ce problème a été résolu par une meilleure gestion de l’état du cache.

CVE-2017-2400 : Abhinav Bansal de Zscaler Inc.

Profils de sandbox

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, et iPod touch 6e génération.

Conséquence : une application malveillante est susceptible d’accéder à l’historique iCloud d’un utilisateur connecté.

Description : un problème d’accès a été résolu au moyen de restrictions sandbox supplémentaires sur les applications tierces.

CVE-2017-6976 : George Dan (@theninjaprawn)

Entrée ajoutée le 1er août 2017

Sécurité

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : la validation de signatures vides avec SecKeyRawVerify() peut réussir de manière inopinée.

Description : les appels API cryptographiques présentaient un problème de validation. Ce problème a été résolu par une meilleure validation des paramètres.

CVE-2017-2423 : un chercheur anonyme

Sécurité

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : une application peut exécuter un code arbitraire avec des privilèges racine.

Description : un problème de dépassement de la mémoire tampon a été résolu par une meilleure vérification des limites.

CVE-2017-2451 : Alex Radocea de Longterm Security, Inc.

Sécurité

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un certificat x509 malveillant peut entraîner l’exécution arbitraire de code.

Description : l’analyse des certificats présentait un problème de corruption de la mémoire. Ce problème a été résolu par une meilleure validation des entrées.

CVE-2017-2485 : Aleksandar Nikolic de Cisco Talos

Siri

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : Siri peut afficher le contenu des SMS lorsque l’appareil est verrouillé.

Description : un problème de verrouillage insuffisant a été résolu par une meilleure gestion des états.

CVE-2017-2452 : Hunter Byrnes

WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : faire glisser et déposer un lien malveillant peut entraîner une utilisation détournée des signets ou l’exécution arbitraire de code.

Description : la création de signets présentait un problème de validation. Ce problème a été résolu par une meilleure validation des entrées.

CVE-2017-2378 : xisigr du Xuanwu Lab de Tencent (tencent.com)

WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : la consultation d’un site Web malveillant peut entraîner une utilisation détournée de la barre d’adresse.

Description : un problème d’incohérence de l’interface utilisateur a été résolu par une meilleure gestion des états.

CVE-2017-2486 : redrain de light4freedom

WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut extraire des données provenant d’origines multiples.

Description : un problème d’accès au prototype a été résolu par une meilleure gestion des exceptions.

CVE-2017-2386 : André Bargull

WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut entraîner l’exécution arbitraire de code.

Description : plusieurs problèmes de corruption de la mémoire ont été résolus par une meilleure validation des entrées.

CVE-2017-2394 : Apple

CVE-2017-2396 : Apple

CVE-2016-9642 : Gustavo Grieco

WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut entraîner l’exécution arbitraire de code.

Description : plusieurs problèmes de corruption de la mémoire ont été résolus par une meilleure gestion de celle-ci.

CVE-2017-2395 : Apple

CVE-2017-2454 : Ivan Fratric de Google Project Zero, Zheng Huang du Baidu Security Lab en collaboration avec le programme Zero Day Initiative de Trend Micro

CVE-2017-2455 : Ivan Fratric de Google Project Zero

CVE-2017-2457 : lokihardt de Google Project Zero

CVE-2017-2459 : Ivan Fratric de Google Project Zero

CVE-2017-2460 : Ivan Fratric de Google Project Zero

CVE-2017-2464 : Jeonghoon Shin, Natalie Silvanovich de Google Project Zero

CVE-2017-2465 : Zheng Huang et Wei Yuan de Baidu Security Lab

CVE-2017-2466 : Ivan Fratric de Google Project Zero

CVE-2017-2468 : lokihardt de Google Project Zero

CVE-2017-2469 : lokihardt de Google Project Zero

CVE-2017-2470 : lokihardt de Google Project Zero

CVE-2017-2476 : Ivan Fratric de Google Project Zero

CVE-2017-2481 : 0011 en collaboration avec le programme Zero Day Initiative de Trend Micro

Entrée mise à jour le 20 juin 2017

WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut entraîner l’exécution arbitraire de code.

Description : un problème de confusion liée aux types a été résolu par une meilleure gestion de la mémoire.

CVE-2017-2415 : Kai Kang du Xuanwu Lab de Tencent (tentcent.com)

WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut entraîner la non-application inattendue de la politique de sécurité du contenu (CSP).

Description : la politique de sécurité du contenu présentait un problème d’accès.  Ce problème a été résolu par un meilleur contrôle des restrictions d’accès.

CVE-2017-2419 : Nicolai Grødum de Cisco Systems

WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut entraîner une utilisation importante de la mémoire.

Description : un problème d’utilisation non contrôlée de ressources a été résolu par un meilleur traitement des expressions régulières.

CVE-2016-9643 : Gustavo Grieco

WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut entraîner la divulgation du contenu de la mémoire de traitement.

Description : le traitement des shaders OpenGL présentait un problème de divulgation d’informations. Ce problème a été résolu par une meilleure gestion de la mémoire.

CVE-2017-2424 : Paul Thomson (via l’outil GLFuzz) du Multicore Programming Group, Imperial College London

WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut entraîner l’exécution arbitraire de code.

Description : un problème de corruption de la mémoire a été résolu par une meilleure validation des entrées.

CVE-2017-2433 : Apple

WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut extraire des données provenant d’origines multiples.

Description : la gestion du chargement des pages présentait plusieurs problèmes de validation. Ces problèmes ont été résolus par une meilleure logique.

CVE-2017-2364 : lokihardt de Google Project Zero

WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : un site Web malveillant peut extraire des données provenant d’origines multiples.

Description : la gestion du chargement des pages présentait un problème de validation. Ces problèmes ont été résolus par une meilleure logique.

CVE-2017-2367 : lokihardt de Google Project Zero

WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut provoquer un scriptage intersite (cross-site scripting) universel.

Description : la gestion des objets de cadre présentait un problème de logique. Ce problème a été résolu par une meilleure gestion des états.

CVE-2017-2445 : lokihardt de Google Project Zero

WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut entraîner l’exécution arbitraire de code.

Description : la gestion des fonctions du mode strict présentait un problème de logique. Ce problème a été résolu par une meilleure gestion des états.

CVE-2017-2446 : Natalie Silvanovich de Google Project Zero

WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : la consultation d’un site Web malveillant peut compromettre des informations utilisateur.

Description : un problème de corruption de la mémoire a été résolu par une meilleure gestion de celle-ci.

CVE-2017-2447 : Natalie Silvanovich de Google Project Zero

WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut entraîner l’exécution arbitraire de code.

Description : plusieurs problèmes de corruption de la mémoire ont été résolus par une meilleure gestion de celle-ci.

CVE-2017-2463 : Kai Kang (4B5F5F4B) du Xuanwu Lab de Tencent (tencent.com) en collaboration avec le programme Zero Day Initiative de Trend Micro

Entrée ajoutée le 28 mars 2017

WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut entraîner l’exécution arbitraire de code.

Description : un problème d’utilisation de mémoire libérée a été résolu par une meilleure gestion de la mémoire.

CVE-2017-2471 : Ivan Fratric de Google Project Zero

WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut provoquer un scriptage intersite (cross-site scripting) universel.

Description : la gestion des cadres présentait un problème de logique. Ce problème a été résolu par une meilleure gestion des états.

CVE-2017-2475 : lokihardt de Google Project Zero

WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut extraire des données provenant d’origines multiples.

Description : la gestion des éléments présentait un problème de validation. Il a été résolu par une meilleure validation.

CVE-2017-2479 : lokihardt de Google Project Zero

Entrée ajoutée le 28 mars 2017

WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut extraire des données provenant d’origines multiples.

Description : la gestion des éléments présentait un problème de validation. Il a été résolu par une meilleure validation.

CVE-2017-2480 : lokihardt de Google Project Zero

CVE-2017-2493 : lokihardt de Google Project Zero

Entrée mise à jour le 24 avril 2017

Associations JavaScript WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut extraire des données provenant d’origines multiples.

Description : la gestion du chargement des pages présentait plusieurs problèmes de validation. Ces problèmes ont été résolus par une meilleure logique.

CVE-2017-2442 : lokihardt de Google Project Zero

Inspecteur Web WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : la fermeture d’une fenêtre lors d’une pause dans le débogueur peut entraîner la fermeture inopinée d’une application.

Description : un problème de corruption de la mémoire a été résolu par une meilleure validation des entrées.

CVE-2017-2377 : Vicki Pfau

Inspecteur Web WebKit

Disponible pour : iPhone 5 et modèles ultérieurs, iPad 4e génération et modèles ultérieurs, iPod touch 6e génération et modèles ultérieurs.

Conséquence : le traitement d’un contenu Web malveillant peut entraîner l’exécution arbitraire de code.

Description : un problème de corruption de la mémoire a été résolu par une meilleure validation des entrées.

CVE-2017-2405 : Apple

Remerciements supplémentaires

XNU

Nous souhaiterions remercier Lufeng Li de la Qihoo 360 Vulcan Team pour son aide.

WebKit

Nous souhaiterions remercier Yosuke Hasegawa de Secure Sky Technology Inc. pour son aide.

Safari

Nous souhaiterions remercier Flyin9 (ZhenHui Lee) pour son aide.

Réglages

Nous souhaiterions remercier Adi Sharabani et Yair Amit de Skycure pour leur aide.

Les informations se rapportant à des produits non fabriqués par Apple, ou à des sites Web indépendants qui ne sont ni contrôlés ni testés par Apple, sont fournies uniquement à titre indicatif et ne constituent aucune recommandation. Apple ne saurait être tenu pour responsable de tout problème lié à l’utilisation de tels sites ou produits tiers, ou à leurs performances. Apple ne garantit en aucune façon la fiabilité d’un site Web, ou l’exactitude des informations que ce dernier propose. L’utilisation d’Internet induit en effet des risques. Contactez le fournisseur pour obtenir des informations supplémentaires. Les autres noms de société et de produit peuvent constituer des marques déposées de leurs détenteurs respectifs.

Date de publication: