Acerca del contenido de seguridad de Xcode 7.0

Este documento describe el contenido de seguridad de Xcode 7.0.

Con el fin de proteger a nuestros clientes, Apple no revelará, discutirá ni confirmará problemas de seguridad hasta que se haya llevado a cabo una investigación exhaustiva y estén disponibles las correcciones o versiones necesarias. Para obtener más información acerca de la seguridad de los productos de Apple, consulta el sitio web Seguridad de los productos de Apple.

Para obtener información acerca de la clave PGP de seguridad de los productos de Apple, consulta Cómo utilizar la clave PGP de seguridad de los productos de Apple.

A fin de proporcionar más información, siempre que sea posible, se usan identificadores CVE para hacer referencia a las vulnerabilidades.

Para obtener información acerca de las actualizaciones de seguridad, consulta Actualizaciones de seguridad de Apple.

Xcode 7.0

  • DevTools

    Disponible para: OS X Yosemite v10.10.4 o posterior

    Impacto: Un atacante podría eludir las restricciones de acceso

    Descripción: existía un problema API en la configuración de Apache. Este problema se solucionó al actualizar archivos de encabezados para utilizar la versión más reciente.

    ID CVE

    CVE-2015-3185 : Branko Äibej de Apache Software Foundation

  • IDE Xcode Server

    Disponible para: OS X Yosemite v10.10.4 o posterior

    Impacto: un atacante podría acceder a partes restringidas del sistema de archivos

    Descripción: existía un problema de comparación en el módulo de envío node.js anterior a la versión 0.8.4. Este problema se solucionó al actualizar a la versión 0.12.3.

    ID CVE

    CVE-2014-6394 : Ilya Kantor

  • IDE Xcode Server

    Disponible para: OS X Yosemite v10.10.4 o posterior

    Impacto: varias vulnerabilidades en OpenSSL.

    Descripción: existían varias vulnerabilidades en el módulo node.js de OpenSSL anterior a la versión 1.0.1j. Estos problemas se solucionaron actualizando OpenSSL a la versión 1.0.1j.

    ID CVE

    CVE-2014-3513

    CVE-2014-3566

    CVE-2014-3567

    CVE-2014-3568

  • IDE Xcode Server

    Disponible para: OS X Yosemite v10.10.4 o posterior

    Impacto: un atacante con una posición de red privilegiada podría inspeccionar el tráfico a Xcode Server

    Descripción: es posible que las conexiones a Xcode Server se hayan realizado sin encriptación. Este problema se resolvió mediante una lógica de conexión de red mejorada.

    ID CVE

    CVE-2015-5910: un investigador anónimo

  • IDE Xcode Server

    Disponible para: OS X Yosemite v10.10.4 o posterior

    Impacto: es posible que se envíen notificaciones de compilación a destinatarios no deseados

    Descripción: existía un problema de acceso en el manejo de listas de repositorios de correo electrónico. Para solucionar este problema, se mejoró la validación.

    ID CVE

    CVE-2015-5909 : Daniel Tomlinson de Rocket Apps, David Gatwood de Anchorfree

  • Subversion

    Disponible para: OS X Yosemite v10.10.4 o posterior

    Impacto: existían varias vulnerabilidades en versiones svn previas a 1.7.19

    Descripción: existían varias vulnerabilidades en las versiones svn previas a 1.7.19. Se solucionaron mediante la actualización de svn a la versión 1.7.20.

    ID CVE

    CVE-2015-0248

    CVE-2015-0251

La información acerca de los productos no fabricados por Apple o la de los sitios web independientes no controlados o probados por Apple se ofrece sin ninguna recomendación o aprobación. Apple no asume ninguna responsabilidad respecto a la selección, el rendimiento o el uso de los sitios web o productos de otros fabricantes. Apple no ofrece ninguna representación con relación a la precisión o fiabilidad de los sitios web de terceros. El uso de Internet conlleva riesgos inherentes. Comunícate con el proveedor para obtener información adicional. Otros nombres de compañías y productos mencionados pueden ser marcas registradas de sus respectivos propietarios.

Fecha de publicación: