Resolve an issue in MainStage 3

Learn how to isolate, troubleshoot, and fix issues in MainStage 3.

Follow the recommendations below in the order in which they're listed until you've isolated or fixed your issue. Before proceeding, make sure to back up the MainStage application.

1. Make sure MainStage is up to date

Make sure you're using the latest version of MainStage 3. Choose Apple menu () > App Store, then click Updates in the toolbar. If an update is available, click the Update button to download and install it.

2. Check device or software compatibility

If you're using an external audio interface, MIDI interface, storage system, or plug-in not made by Apple, make sure it's compatible with the latest version of MainStage 3. Contact the manufacturer for support. If an update is available, follow the manufacturer's instructions to update the device or software. 

3. Check documentation

Check MainStage 3 Help to make sure MainStage is working as expected. You can search help for key terms shown in alerts or error messages.

4. Test using built-in audio

Sometimes an incompatible or malfunctioning external audio interface can cause issues with MainStage. If you're using an external audio interface, try using the built-in audio on your Mac instead of the interface.

To use built-in audio with MainStage:

  1. Unplug your external audio interface from your Mac.
  2. Open MainStage, then choose MainStage > Preferences > Audio.
  3. Choose Built-in Output from the Audio Output pop-up menu.
  4. Choose Built-in Microphone (or Built-in Input, depending on your computer) from the Audio Input pop-up menu.
  5. Test using a concert, set, or patch you've had issues with.

If using built-in audio resolves your issue, you might need to update or service your audio interface. Contact the manufacturer for support.

5. Create a new concert

Sometimes concert files can become unusable, causing unexpected behavior in MainStage.

To create and test a new project:

  1. Open MainStage and choose File > New.
  2. Choose the devices you want to use for audio input and output from the Audio Input and Audio Output pop-up menus in the dialog.
  3. Click an instrument category on the left, then select the template you want to use.
  4. Click Choose.
  5. Test to see if the issue occurs in the new concert. If the issue doesn't occur in the new concert, the concert you're having issues with might be damaged. You can try to rebuild the concert file.

Rebuild a damaged concert file

When you rebuild a concert, you export the layout, sets, and patches from your concert, then import them into a new concert.

  1. Open the concert you're having issues with.
  2. To export your layout, click Layout, click the gear icon at the top of the Layout section, then choose Export Layout from the menu. Choose a location in which to save the layout, then click Export.
  3. To export your sets and patches, click Edit, click in the Patch List, then press Command–A (or choose Edit > Select All) to select all sets and patches in the Patch List. Drag them to the desktop or a folder.
  4. Close the concert.
  5. Create a new concert from any template.
  6. Click Layout, press Command–A (or choose Edit > Select All) to select all elements in the Layout section, then press Delete to remove them.
  7. To import the layout from the original concert, click the gear icon at the top of the Layout section, then choose Import Layout from the menu. Select the layout, then click Import.
  8. Click Edit, select all the sets and patches in the Patch List, then press Delete to remove all the existing patches.
  9. Drag the patches from the original concert into the Patch List. You might need to reorder sets and patches after dragging them into the patch list.
  10. Test the new concert to see if the issue still exists.

6. Try a different user account

Open MainStage in another user account on your Mac. Logging in as another user can help you figure out if unexpected behavior is related to a specific user's settings or files.

7. Reset preferences

Resetting MainStage preferences doesn't affect your project files, presets, or patches. However, you do lose any custom preference settings you might have made.

Before resetting preferences, choose MainStage > Preferences and note any specific settings you've made. That way, after resetting preferences, you can go back and reapply your custom settings. For information on different preferences, see Preferences overview in MainStage Help.

To reset your MainStage preferences:

  1. Quit MainStage if it's open.
  2. In the Finder, hold the Option key, then choose Go > Library.
  3. Remove the com.apple.mainstage3.plist file from the Preferences folder.
  4. Restart your Mac.

After your Mac restarts, open MainStage and try to reproduce the issue you were experiencing. If the issue no longer occurs, open MainStage preferences and reapply your custom settings.

8. Reinstall MainStage

If the issue persists, remove and reinstall MainStage. Your existing MainStage concerts won't be deleted, and can be opened after reinstallation.

  1. In the Finder, choose Go > Applications.
  2. Locate MainStage 3 and drag it to the Trash.
  3. Reinstall MainStage from the App Store, or restore it from a backup. When restoring a copy of the MainStage application from a backup, you can either drag it from its storage location to your Applications folder, or you can restore it from a Time Machine backup.

Information about products not manufactured by Apple, or independent websites not controlled or tested by Apple, is provided without recommendation or endorsement. Apple assumes no responsibility with regard to the selection, performance, or use of third-party websites or products. Apple makes no representations regarding third-party website accuracy or reliability. Risks are inherent in the use of the Internet. Contact the vendor for additional information. Other company and product names may be trademarks of their respective owners.

Published Date: