Import, export, and print notes on Mac
You can import text files into Notes, export notes as PDF or Markdown files, or copy notes as Markdown. You can also print your notes.
Tip: If you keep notes in internet accounts—for example, iCloud, Google, Yahoo, or AOL—you can add those accounts to Notes on your Mac to access all your notes in one place without importing each note one by one. See Add or remove accounts in Notes.
Import text files into Notes
If you use upgraded iCloud notes or notes stored on your Mac, you can import text files into Notes as individual notes. You can import files in Markdown, TXT, RTF, RTFD, HTML, or Evernote XML Export (ENEX) format.
If you have macOS 13 or later, you can also import tags from Evernote (ENEX) files.
Go to the Notes app
on your Mac.
In the sidebar, click a folder in the iCloud or On My Mac account you want to import files into.
Do any of the following:
Choose File > Import to Notes.
Choose File > Import Markdown.
Select one or more files, or select a folder to import all the text files in it.
If you select a folder, click “Preserve folder structure on import” to keep the imported notes organized the way they were in the folder. (If you don’t see this option, click Options.)
Click Import.
Your new notes (and folders, if you imported any) appear in an Imported Notes folder. You can now move or rename the notes and folders as usual. See About accounts and folders.
Tip: You can also export all your notes from the Stickies app into Notes. They appear in the Imported Notes folder, with a subfolder for each color of note. See the Stickies User Guide.
Export a note as a PDF or Markdown file
You can export notes as PDF or Markdown files.
Go to the Notes app
on your Mac.
Click the note you want to export, choose File > Export To, then choose an option.
You can type a new name and add tags that you can search for in Finder.
Click Save.
Copy a note as Markdown
You can copy content from a note as Markdown to integrate your notes into writing, content, and other workflows that support Markdown.
Go to the Notes app
on your Mac.
In the body of a note, select the content you want to copy.
Choose Edit > Copy as Markdown.
Tip: You can also paste Markdown into Notes. It appears as formatted headings, lists, and more.
Print your notes
Go to the Notes app
on your Mac.
Click the note you want to print, then choose File > Print.