View 3D files in Preview on Mac
You can view 3D files in Preview and change how they appear in the viewport, the viewing area where you can view, navigate, and interact with them. A 3D file can contain a scene or an object. When you view a scene, it’s as if you’re standing in it and can look around. When you view an object, you can rotate it in any direction.
Note: Some 3D viewing and editing features aren’t available for SceneKit (.scn) and Collada (.dae) files.
Open a 3D file
Go to the Preview app
on your Mac.
Choose File > Open.
Navigate to the folder that contains the file, then double-click it.
Note: USD files can be self-contained but often refer to other files needed to display the scene or asset. Don’t move a USD file out of its original folder, or you may not be able to view the scene. A folder may also contain more than one USD file.
Explore a 3D scene
You can navigate around a scene by orbiting, panning, and zooming.
Go to the Preview app
on your Mac.
Open a 3D file, then do any of the following:
Orbit: Drag anywhere in the viewport to move around the scene.
Pan: Drag with two fingers on a trackpad, or drag with the middle mouse button.
Zoom: Pinch with two fingers on a trackpad, scroll with a mouse, or drag with the right mouse button.
Zoom to selection: Choose View > Zoom to Selection, or press Shift-Command-8. If nothing is selected, Preview fits the entire scene in the viewport instead.
To permanently reorient or resize the scene instead of just changing your view of it, see “Adjust the stage” in Edit a 3D file in Preview on Mac.
Browse objects in the scene
3D scenes are made up of prims, which represent objects such as shapes, lights, cameras, and materials and are arranged in a hierarchy. You can browse the prims in your 3D scene in the Object Hierarchy pane.
Go to the Preview app
on your Mac.
Open a 3D file, then choose View > Object Hierarchy.
Do any of the following:
Select a group or prim: Click its name, or press the Up Arrow or Down Arrow key.
Expand or collapse a group: Click
or
, or press the Right Arrow or Left Arrow key.
Hide or show a group or prim: Click
next to its name.
Mark a prim as the file reference root: Control-click the prim, then choose File Reference Root. A star appears next to its name. The file reference root is the prim other files use by default when they reference this file, and it’s also where Preview adds new prims when nothing is selected.
Look through a camera
You can view the scene from the perspective of any camera defined in the 3D file, or from Perspective, the default view, which always appears first in the Cameras pane.
Go to the Preview app
on your Mac.
Open a 3D file, then choose View > Cameras.
In the Cameras pane, click a camera’s thumbnail to view the scene from its perspective.
Thumbnails are live previews that show where each camera points, and the camera you’re currently looking through is highlighted. To return to the default view, click Perspective.
To lock or unlock the selected camera, click
.
Locking stops you from orbiting, panning, or zooming while looking through that camera, but you can still move a prim using its transform handles or edit a camera’s properties in Object Properties. The lock status isn’t saved with the file, and you can’t unlock a camera that has animated movement. Camera locking isn’t available for Perspective, which you can always navigate freely.
Choose a rendering style
Go to the Preview app
on your Mac.
Open a 3D file, then choose View > 3D Rendering.
Do any of the following:
Show how content appears on Apple platforms: Choose RealityKit (it’s selected by default).
Use a general renderer for broad USD compatibility: Choose OpenUSD Storm.
Get high-quality, physically based rendering: Choose Raytracer.
Render the scene with realistic lighting and materials so it looks like a photograph: Choose Photoreal Rendering. You can also click
, then click
While Photoreal Rendering is on, the Renderer and Environment controls are unavailable. If the scene has no lights, a dialog appears—click Enable Anyway to continue, or click Cancel. To add a light, see Add a prim.
Choose a lighting environment: Below Environment, choose Studio, Overcast, Sunny, Dusk, Night, City Night, or Office Interior. You can also click
, click
, then choose an option. Environment controls aren’t available when Photoreal Rendering is turned on.
To change the default renderer, choose Preview > Settings, click 3D, then choose a new renderer from the Default Renderer pop-up menu.
Adjust the viewport appearance
You can adjust shadow distance, exposure, and gamma to change how the scene looks in the viewport.
Go to the Preview app
on your Mac.
Open a 3D file, then click
.
Click
in the toolbar.
Do any of the following:
Control how far shadows are cast in the scene: With Raytracer selected as the rendering style and Photoreal Rendering off, drag the Shadow Distance slider or enter a value.
Brighten or darken the scene: Drag the Exposure slider or enter a value.
Adjust the tonal range of the scene: Drag the Gamma slider or enter a value.
Reset Shadow Distance, Exposure, and Gamma to their defaults: Click Reset All.
Play animations
If a 3D file contains animation, you can play it using the playback controls. Animations play in a loop by default.
Go to the Preview app
on your Mac.
Open a 3D file, then move the pointer to the bottom of the view to show the playback controls, or press the Space bar.
Do any of the following:
Play or pause: Click
or
in the playback controls, or press the Space bar.
Play an animation once instead of looping: Option-click
.
Skip back or forward five units: Click
or
.
Switch measurement units: Click the current measurement to switch between frames (the default) and minutes:seconds.
Go to a specific frame: Drag the scrubber in the playback bar.
Note: During playback, you can’t select or move objects, add or edit annotations, or use tools in the toolbar. You can still change properties, add or delete a prim, and undo, though.
View file information
You can view information about a 3D file in the Inspector sidebar, such as filename, file size, creation date, modification date, objects, materials, and lights.
Go to the Preview app
on your Mac.
Open a 3D file, then click
in the toolbar.
You can also use Apple Vision Pro to view USD files, images, and PDFs that are saved on your Mac. See View content from your Mac on Apple Vision Pro.