Informationen zum Sicherheitsinhalt von Sicherheitsupdate 2018-001 Swift 4.1.1 für Ubuntu 14.04

In diesem Dokument ist der Sicherheitsinhalt von Sicherheitsupdate 2018-001 Swift 4.1.1 für Ubuntu 14.04 beschrieben.

Informationen zu Apple-Sicherheitsupdates

Zum Schutz unserer Kunden werden Sicherheitsprobleme von Apple erst dann bekannt gegeben, diskutiert und bestätigt, wenn eine vollständige Untersuchung stattgefunden hat und alle erforderlichen Patches oder Programmversionen verfügbar sind. Die neuesten Programmversionen finden Sie auf der Seite Apple-Sicherheitsupdates.

Weitere Informationen zur Sicherheit finden Sie auf der Seite zur Apple-Produktsicherheit. Ihre Kommunikation mit Apple können Sie mit dem PGP-Schlüssel für die Apple-Produktsicherheit verschlüsseln.

Nach Möglichkeit werden in Sicherheitsdokumenten von Apple zur Bezugnahme auf Schwachstellen CVE-IDs verwendet.

Sicherheitsupdate 2018-001 Swift 4.1.1 für Ubuntu 14.04

Veröffentlicht am 4. Mai 2018

Swift für Ubuntu

Verfügbar für: Ubuntu 14.04

Nicht betroffen: Ubuntu 16.04 und 16.10

Auswirkung: Ein Prozess kann Administratorrechte erlangen und willkürlichen Code ausführen.

Beschreibung: In bestimmten Versionen von Swift unter Ubuntu 14.04 bestand ein Problem, das dazu führte, dass Bibliotheken mit Berechtigungen zum Schreiben und Ausführen geladen wurden. Dieses Problem wurde durch verbesserte Berechtigungen behoben.

CVE-2018-4220: Apple

Informationen zu nicht von Apple hergestellten Produkten oder nicht von Apple kontrollierten oder geprüften unabhängigen Websites stellen keine Empfehlung oder Billigung dar. Apple übernimmt keine Verantwortung für die Auswahl, Leistung oder Nutzung von Websites und Produkten Dritter. Apple gibt keine Zusicherungen bezüglich der Genauigkeit oder Zuverlässigkeit der Websites Dritter ab. Kontaktiere den Anbieter, um zusätzliche Informationen zu erhalten.

Veröffentlichungsdatum: