Informationen zum Sicherheitsinhalt des iOS 5.1.1-Software-Updates

Dieses Dokument beschreibt den Sicherheitsinhalt des iOS 5.1.1-Software-Updates.

Das iOS 5.1.1-Software-Update kann über iTunes geladen und installiert werden.

Zum Schutz unserer Kunden werden Sicherheitsprobleme von Apple erst dann bekannt gegeben, diskutiert und bestätigt, wenn eine vollständige Untersuchung stattgefunden hat und alle erforderlichen Patches oder Programmversionen verfügbar sind. Nähere Informationen zur Apple-Produktsicherheit finden Sie auf der Website Apple-Produktsicherheit.

Informationen zum Apple PGP-Schlüssel für die Produktsicherheit finden Sie unter "Verwenden des PGP-Schlüssels für die Apple-Produktsicherheit".

Nach Möglichkeit werden zur vereinfachten Bezugnahme auf die Schwachstellen CVE-IDs verwendet.

Informationen zu weiteren Sicherheitsupdates finden Sie unter "Apple-Sicherheitsupdates".

iOS 5.1.1-Software-Update

  • Safari

    Verfügbar für: iPhone 3GS, iPhone 4, iPhone 4s, iPod touch (3. Generation) und neuer, iPad, iPad 2

    Symptom: Eine in böser Absicht erstellte Website könnte die Adresse in der Adressleiste vortäuschen.

    Beschreibung: In Safari bestand ein URL-Spoofing-Problem. Dies könnte in einer schädlichen Website verwendet werden, um den Benutzer auf eine gefälschte Site zu leiten, die auf den ersten Blick eine legitime Domain aufzuweisen scheint. Dieses Problem wurde durch eine verbesserte URL-Verarbeitung behoben. Das Problem betrifft keine OS X-Systeme.

    CVE-ID

    CVE-2012-0674: David Vieira-Kurz von MajorSecurity (majorsecurity.net)

  • WebKit

    Verfügbar für: iPhone 3GS, iPhone 4, iPhone 4s, iPod touch (3. Generation) und neuer, iPad, iPad 2

    Auswirkung: Der Besuch einer in böswilliger Absicht erstellten Website kann zu Cross-Site-Scripting-Angriffen führen.

    Beschreibung: In WebKit kam es zu mehreren Cross-Site-Scripting-Fehlern.

    CVE-ID

    CVE-2011-3046: Sergey Glazunov in Zusammenarbeit mit dem Pwnium Contest von Google

    CVE-2011-3056: Sergey Glazunov

  • WebKit

    Verfügbar für: iPhone 3GS, iPhone 4, iPhone 4s, iPod touch (3. Generation) und neuer, iPad, iPad 2

    Auswirkung: Der Besuch einer in böswilliger Absicht erstellten Website kann zu einem unerwarteten Programmabbruch oder zur Ausführung willkürlichen Codes führen.

    Beschreibung: In WebKit kam es zu Speicherfehlern.

    CVE-ID

    CVE-2012-0672: Adam Barth und Abhishek Arya vom Google Chrome-Sicherheitsteam

Informationen zu nicht von Apple gefertigten Produkten sowie nicht von Apple gesteuerte oder geprüfte unabhängige Websites werden ohne Empfehlung und Unterstützung zur Verfügung gestellt. Apple übernimmt keine Verantwortung für die Auswahl, Leistung oder Nutzung von Websites und Produkten Dritter. Apple übernimmt keine Garantie für die Richtigkeit und Zuverlässigkeit von Drittanbieter-Websites. Die Nutzung des Internets birgt Risiken. Kontaktieren Sie den Hersteller, um zusätzliche Informationen zu erhalten. Andere Produkt- und Firmennamen sind möglicherweise Marken ihrer jeweiligen Eigentümer.

Veröffentlichungsdatum: