Om sikkerhedsindholdet i iOS 6.0.1-softwareopdateringen

I dette dokument beskrives sikkerhedsindholdet i iOS 6.0.1-softwareopdateringen, som kan hentes og installeres ved hjælp af iTunes.

For at beskytte vores kunder videregiver, drøfter eller bekræfter Apple ikke sikkerhedsanliggender, før en fuldstændig undersøgelse har fundet sted, og der foreligger relevante programrettelser eller versioner. Hvis du vil læse mere om Apple-produktsikkerhed, kan du gå ind på webstedet Apple-produktsikkerhed.

Yderligere oplysninger om PGP-nøglen til Apple-produktsikkerhed kan ses i artiklen "Sådan bruges PGP-nøglen til Apple Produktsikkerhed".

Hvor det er muligt, anvendes der CVE-id'er til at henvise til yderligere oplysninger om sikkerhedsproblemer.

Du kan finde oplysninger om andre sikkerhedsopdateringer i artiklen Apple-sikkerhedsopdateringer.

iOS 6.0.1

  • Kernel

    Fås til: iPhone 3GS og nyere versioner, iPod touch (4. generation) og nyere versioner, iPad 2 og nyere versioner

    Effekt: iOS-programmer, som der er foretaget skadelige ændringer i, kan finde frem til kernens adresse

    Beskrivelse: Der var et problem med afsløring af oplysninger ved behandling af API'er, der har forbindelse til kerneudvidelser. Svar indeholdende en OSBundleMachOHeaders-nøgle kan have medtaget kerneadresser, som kan medvirke til at omgå beskyttelse af randomisering af adressemellemrumslayout. Problemet er løst ved at sikre adresserne, før de returneres.

    CVE-id

    CVE-2012-3749: Mark Dowd fra Azimuth Security, Eric Monti fra Square og andre anonyme udviklere

  • Lås med kode

    Fås til: iPhone 3GS og nyere versioner, iPod touch (4. generation) og nyere versioner, iPad 2 og nyere versioner

    Effekt: En person med fysisk adgang til enheden kan få adgang til Passbook-pas uden at indtaste en adgangskode

    Beskrivelse: Der var et administrationsproblem ved behandlingen af Passbook-pas på en låst skærm. Problemet er løst ved forbedret behandling af Passbook-pas.

    CVE-id

    CVE-2012-3750: Anton Tsviatkou

  • WebKit

    Fås til: iPhone 3GS og nyere versioner, iPod touch (4. generation) og nyere versioner, iPad 2 og nyere versioner

    Effekt: Et besøg på et skadeligt websted kan medføre pludselig programlukning eller kørsel af vilkårlig kode

    Beskrivelse: Der var et problem med "tid fra kontrol til tid for brug" ved håndteringen af JavaScript-arrays. Problemet er løst ved yderligere godkendelse af JavaScript-arrays.

    CVE-id

    CVE-2012-3748: Joost Pol og Daan Keuper fra Certified Secure, der arbejder med HP TippingPoints Zero Day Initiative

  • WebKit

    Fås til: iPhone 3GS og nyere versioner, iPod touch (4. generation) og nyere versioner, iPad 2 og nyere versioner

    Effekt: Et besøg på et skadeligt websted kan medføre pludselig programlukning eller kørsel af vilkårlig kode

    Beskrivelse: Der var et problem med "use after free" i håndteringen af SVG-billeder. Problemet er løst ved forbedret behandling af hukommelse.

    CVE-id

    CVE-2012-5112: Pinkie Pie, der arbejder med Googles Pwnium 2-konkurrence

Oplysninger om produkter, der ikke er fremstillet af Apple, eller selvstændige websteder, der ikke er styret eller testet af Apple, er ikke udtryk for anbefalinger eller godkendelser fra Apples side. Apple påtager sig intet ansvar med hensyn til udvalget af disse produkter, produkternes funktionsevne eller brugen af produkterne. Apple giver ingen garanti for, at indholdet på websteder, som Apple ikke står bag, er pålideligt og præcist. Det er forbundet med en naturlig risiko at bruge internettet. Kontakt producenten for at få yderligere oplysninger. Andre virksomheds- og produktnavne kan være varemærker tilhørende de respektive ejere.

Udgivelsesdato: