نبذة حول محتوى أمان Xcode 8.1

يتناول هذا المستند محتوى أمان Xcode 8.1.

معلومات حول تحديثات الأمان من Apple

في سبيل حماية عملائنا، تحرص Apple على عدم الإفصاح عن مشكلات الأمان أو طرحها للنقاش أو تأكيدها حتى يتم تقصي الأمر وتوفير تصحيحات أو إصدارات جديدة. يتمّ إدراج أحدث الإصدارات في صفحة تحديثات أمان Apple.

للحصول على مزيد من المعلومات حول الأمان، يمكنك الاطلاع على صفحة أمان منتجات Apple. يمكنك تشفير اتصالاتك مع Apple باستخدام مفتاح PGP لأمان منتجات Apple.

عند اللزوم، تشير مستندات الأمان في Apple إلى الثغرات الأمنية من خلال CVE-ID.

Xcode 8.1

صدر في 27 أكتوبر 2016

IDE Xcode Server

متوفر لما يلي: الإصدار 10.11.5 والإصدارات الأحدث من نظام التشغيل OS X El Capitan

التأثير: يمكن أن يتسبب مخترق عن بُعد في إنهاء غير متوقع للتطبيق أو تنفيذ تعليمة برمجية عشوائية

الوصف: توجد مشكلات متعددة في Node.js بـ Xcode Server. تمت معالجة هذه المشكلات من خلال التحديث إلى الإصدار 4.5.0 من Node.js.

CVE-2016-1669

CVE-2016-0705

CVE-2016-0797

CVE-2016-0702

CVE-2016-2086

CVE-2016-2216

CVE-2015-8027

CVE-2015-3193

CVE-2015-3194

CVE-2015-6764

يتمّ تقديم المعلومات حول المنتجات التي لم تُصنّعها شركة Apple أو مواقع الويب المستقلة التي لا تخضع للمراقبة أو الاختبار من جانب Apple بدون توصيات أو موافقة. ولا تتحمّل Apple أية مسؤولية فيما يتعلق باختيار مواقع الويب والمنتجات التابعة لجهات خارجية أو أدائها أو استخدامها. ولا تُقدّم شركة Apple أية ضمانات فيما يتعلق بدقة أو موثوقية مواقع الويب التابعة لجهات خارجية. المخاطر ملازمة لاستخدام الإنترنت. للحصول على مزيد من المعلومات، يُمكنك الاتصال بالبائع. قد تكون أسماء الشركات والمنتجات الأخرى علامات تجارية لمالكيها المعنيين.

تاريخ النشر: