نبذة حول محتوى أمان Xcode 7.1

يتناول هذا المستند محتوى أمان Xcode 7.1.

لحماية عملائنا، لا تفصح Apple عن مشكلات الأمان أو تناقشها أو تؤكدها لحين إجراء استقصاء كامل، مع توفّر أية برامج تصحيح أو إصدارات ضرورية. لمعرفة المزيد بشأن أمان منتجات Apple، راجع موقع أمان منتجات Apple على الويب.

للحصول على معلومات حول مفتاح PGP لأمان منتجات Apple، انظر كيفية استخدام مفتاح PGP لأمان منتجات Apple.

وحيثما أمكن، يتم استخدام معرفات CVE للإشارة إلى قابلية الإصابة للحصول على مزيد من المعلومات.

للتعرف على تحديثات الأمان الأخرى، راجع  تحديثات أمان Apple.

Xcode 7.1

  • Swift

    متوفّر لـ: نظام التشغيل OS X Yosemite، الإصدار 10.10.5 أو الإصدارات الأحدث

    التأثير: قد تتلقّى برامج Swift التي تؤدي تحويلات من نوع معين قيمًا غير متوقعة.

    الوصف: وجدت مشكلة في أحد أنواع التحويل، والتي كانت تؤدي إلى الحصول على قيم غير متوقعة لعمليات التحويل. وقد تمّ التصدي لهذه المشكلة عبر الفحص المحسّن للنوع.

    CVE-ID

    CVE-2015-7030 : باحث غير معلوم

يتمّ تقديم المعلومات حول المنتجات التي لم تُصنّعها شركة Apple أو مواقع الويب المستقلة التي لا تخضع للمراقبة أو الاختبار من جانب Apple بدون توصيات أو موافقة. ولا تتحمّل Apple أية مسؤولية فيما يتعلق باختيار مواقع الويب والمنتجات التابعة لجهات خارجية أو أدائها أو استخدامها. ولا تُقدّم شركة Apple أية ضمانات فيما يتعلق بدقة أو موثوقية مواقع الويب التابعة لجهات خارجية. المخاطر ملازمة لاستخدام الإنترنت. للحصول على مزيد من المعلومات، يُمكنك الاتصال بالبائع. قد تكون أسماء الشركات والمنتجات الأخرى علامات تجارية لمالكيها المعنيين.

تاريخ النشر: