關於 iOS 4.3.4 軟體更新的安全性內容

本文說明 iOS 4.3.4 軟體更新的安全性內容。

為保障客戶的安全,在進行完整調查並提供所有必要的修補程式或版本之前,Apple 不會揭露、討論或確認安全性問題。若要瞭解 Apple 產品安全性的更多相關資訊,請參閱 Apple 產品安全性網站。

如需 Apple 產品安全性 PGP 金鑰的相關資訊,請參閱「如何使用 Apple 產品安全性 PGP 金鑰」。

如有可能,CVE ID 會用來參照安全漏洞的進一步資訊。

若要瞭解其他安全性更新,請參閱「Apple 安全性更新」。

iOS 4.3.4 軟體更新

  • CoreGraphics

    適用於:iPhone 3GS 和 iPhone 4(GSM 機型)的 iOS 3.0 至 4.3.3、iPod touch(第 3 代)和後續機型的 iOS 3.1 至 4.3.3、iPad 的 iOS 3.2 至 4.3.3

    影響:檢視惡意製作的 PDF 檔案可能導致應用程式意外終止或執行任意程式碼

    說明:FreeType 處理 TrueType 字體時,出現緩衝區溢位。檢視惡意製作的 PDF 檔案可能導致應用程式意外終止或執行任意程式碼。

    CVE-ID

    CVE-2010-3855

  • CoreGraphics

    適用於:iPhone 3GS 和 iPhone 4(GSM 機型)的 iOS 3.0 至 4.3.3、iPod touch(第 3 代)和後續機型的 iOS 3.1 至 4.3.3、iPad 的 iOS 3.2 至 4.3.3

    影響:檢視惡意製作的 PDF 檔案可能導致應用程式意外終止或執行任意程式碼

    說明:FreeType 處理 Type 1 字體時,出現正負號狀態問題。檢視惡意製作的 PDF 檔案可能導致應用程式意外終止或執行任意程式碼。

    CVE-ID

    CVE-2011-0226:comex

  • IOMobileFrameBuffer

    適用於:iPhone 3GS 和 iPhone 4(GSM 機型)的 iOS 3.0 至 4.3.3、iPod touch(第 3 代)和後續機型的 iOS 3.1 至 4.3.3、iPad 的 iOS 3.2 至 4.3.3

    影響:以使用者身分執行的惡意程式碼可能取得系統權限

    說明:使用 IOMobileFrameBuffer 佇列基元時,出現類型轉換無效問題,可能會允許以使用者身分執行惡意程式碼來取得系統權限。

    CVE-ID

    CVE-2011-0227:comex

對於非 Apple 製造之產品相關資訊,或是非 Apple 控制或測試之獨立網站,不得解釋 Apple 為其推薦或背書。Apple 對於協力廠商網站或產品的選擇、效能或使用,概不負責。Apple 對於協力廠商網站的準確性或可靠性不具有任何立場。使用 Internet 本具風險。如需更多資訊,請聯絡廠商。其他公司及產品名稱可能是其各自擁有者的商標。

發佈日期: