将 Aperture 图库迁移到“照片”App 或 Adobe Lightroom Classic

Aperture 无法在 macOS Mojave 之后的 macOS 版本中运行。以下是将 Aperture 图库移动到“照片”或 Adobe Lightroom Classic 的方法。

2014 年 6 月,Apple 宣布停止开发 Aperture。从那以后,Apple 发布了六个主要的 macOS 升级。由于技术原因,macOS Mojave 成为能够运行 Aperture 的最后一个 macOS 版本。从 macOS Catalina 开始,Aperture 不再与 macOS 兼容。

要继续使用 Aperture 照片图库,您必须将它们迁移到其他照片 App。您可以将它们迁移到“照片”App(macOS Yosemite 或更高版本中包含这个 App),或者将它们迁移到 Adobe Lightroom Classic 或其他 App 中。您应该在升级到 macOS Catalina 之前执行此操作。

 


将图库迁移到“照片”

如果您使用的是 macOS Mojave 或更早版本

如果您使用的是macOS Mojave 或更早版本,请按照以下步骤操作

  1. 打开 Aperture。
  2. 选取“Aperture”>“偏好设置”,点按“Previews”(预览)标签,然后将“Photo Preview”(照片预览)设置更改为“Don't Limit”(不限制)。关闭偏好设置窗口。
  3. 在资源库检查器的项目列表中,选择所有项目。例如,点按列出的第一个项目,然后在按住 Shift 键的同时点按最后一个项目。
  4. 点按工具栏中的浏览器布局按钮,以便所有照片都显示为缩略图。
  5. 选取“编辑”>“全选”以选取所有照片。
  6. 按住 Option 键,然后选取“照片”>“Generate Previews”(生成预览)。
  7. Aperture 现在会为图库中的每张照片生成全尺寸预览。要跟踪其进度,请从菜单栏中选取“窗口”>“显示活动”。完成处理后退出 Aperture。
  8. 打开“照片”App,然后在提示时选取您的 Aperture 图库,如上图所示。如果未提示您选取图库,请在打开“照片”的同时按住 Option 键。如果未列出您的 Aperture 图库,请点按“其他图库”,然后找到并选取您的图库。

当“照片”中显示来自您的 Apterture 图库的照片时,表示迁移已完成。进一步了解“照片”迁移功能的工作原理,以及“照片”如何处理来自 Aperture 的内容、元数据智能相簿

如果您使用的是 macOS Catalina

从 macOS Catalina 开始,Aperture 不再与 macOS 兼容。如果您在将图库迁移至“照片”前已经升级成了 macOS Catalina,请按照以下步骤操作:

  1. 安装最新的 macOS Catalina 更新。您的 Mac 必须使用 macOS Catalina 10.15.1 或更高版本
  2. 如果您在安装了 macOS Catalina 10.15 之后但没有升级到 macOS Catalina 10.15.1 之前将图库迁移到了“照片”,请在继续操作之前完成以下步骤:
    1. 在“访达”中选取您的 Aperture 图库。默认情况下,它位于主文件夹中的“图片”文件夹,名称为 Aperture Library。 
    2. 选取“文件”>“显示简介”。您 Aperture 图库的“简介”窗口将打开。
    3. 在“简介”窗口中的“名称与扩展名”部分,将文件名称末尾的 .migratedphotolibrary 替换为 .aplibrary。然后关闭这个窗口。
  3. 打开“照片”App,然后在提示时选取您的 Aperture 图库,如上图所示。如果未提示您选取图库,请在打开“照片”的同时按住 Option 键。如果未列出您的 Aperture 图库,请点按“其他图库”,然后找到并选取您的图库。

当“照片”中显示来自您的 Apterture 图库的照片时,表示迁移已完成。进一步了解“照片”迁移功能的工作原理,以及“照片”如何处理来自 Aperture 的内容、元数据https://support.apple.com/zh-cn/HT204478智能相簿

 


将您的图库迁移到 Adobe Lightroom Classic

Adobe Lightroom Classic 5.7 版及更高版本附带了一个用于将 Aperture 图库迁移到 Lightroom 目录的内建工具

将 Aperture 图库迁移到 Lightroom 时,图库组织结构、元数据以及图像调整将被保留,但存在以下例外:

  • RAW 文件将被迁移,但 Aperture 的非破坏性调整层不会迁移。Lightroom 的迁移器工具包含一个选项,用于导出和迁移 Aperture 针对已编辑的图像提供的全尺寸 JPEG 预览。如果您想要以另一种格式保留您在 Aperture 中所做的编辑,请先从 Aperture 导出已编辑的图像,然后在迁移图库后将这些图像重新导入 Lightroom。
  • 项目、文件夹和相簿将迁移到 Lightroom 收藏和收藏集中。
  • 面容、颜色标签和堆叠将作为关键词迁移。
  • 被拒绝的图像将迁移到收藏中。
  • 幻灯片作为收藏进行迁移。
  • 智能相簿和自定元数据字段不会迁移。
  • 相簿的组织结构按字母顺序进行排列,因此可能无法保留手动创建的边栏组织结构。
  • 自定元数据字段不会迁移。

 


导出您的 Aperture 图库

您还可以导出 Aperture 图库的内容,以进行备份或将其导入到其他 App。

有关非 Apple 制造的产品或非 Apple 控制或测试的独立网站的信息仅供参考,不代表 Apple 的任何建议或保证。Apple 对于第三方网站或产品的选择、性能或使用不承担任何责任。Apple 对于第三方网站的准确性和可靠性不作任何担保。互联网的使用具有一定风险。请联系供应商以了解其他信息。其他公司和产品名称可能是其各自所有公司的商标。

发布日期: