在 Final Cut Pro X 和 Compressor 中使用字幕

在 Final Cut Pro 10.4.4 和 Compressor 4.4.2 中,创建和交付带有 iTunes 时控文本 (iTT)、CEA-608 和 SRT 格式字幕的视频。

字幕是与视频同步的视觉文本行。字幕主要用于为失聪及听障人士提供的隐藏式字幕。字幕也可用于对白字幕、卡拉 OK、滚动多条新闻和提词机。政府监管部门、广播公司和流媒体服务通常对隐藏式字幕和字幕设有特定的要求。

在 Final Cut Pro X 中,您可以直接在时间线中为项目创建字幕,也可以将字幕导入您的项目中。在添加了字幕后,您可以在时间线中对其进行调整和排列,还可以设置文本格式。使用 Final Cut Pro 或 Compressor,您可以在共享项目时将字幕直接嵌入到视频文件中,或者将字幕导出为单独的文件。

选取字幕格式

在 Final Cut Pro 中为项目创建字幕时,请先选取最适合交付要求的格式,然后再开始制作字幕。

  • 对于广播、网络流媒体、DVD 或 Blu-ray,请使用 CEA-608(也称为 CTA-608 和 EIA0608)。CEA-608 提供有限的文本格式化选项,对非罗马字符语言提供有限的支持。在使用 CEA-608 格式的项目中导出字幕时,您可以它们嵌入在媒体文件中,或者导出为单独的文件。
  • 如果要交付到 iTunes Store、YouTube 和 Vimeo,请使用 iTT。iTT 格式专门用于将带有字幕的媒体交付到 iTunes Store。iTT 支持更多的文本格式化选项和更大范围的语言,因而比 CEA-608 更加适合用于制作字幕。
  • 如果要将视频发布到 Facebook、YouTube 或 Vimeo 等社交网站,请使用 SRT。在 SRT 中,每个字幕带有一个数字、一个开始时间码和一个结束时间码,以及一行或多行含 HTML 标记的文本。SRT 提供有限的文本格式化选项。


创建字幕

在 Final Cut Pro X 中,字幕被分配了特殊的字幕角色。要添加字幕角色,请选取“修改”>“编辑角色”。如果只想添加 Mac 当前所用语言的字幕,请点按“应用”。Final Cut Pro 会将字幕角色添加到您的项目所在的资源库中。

如果要创建其他语言的字幕,请分别为各种语言创建子角色。您可以直接在 Final Cut Pro 中编写其他语言的字幕,或者将翻译好的字幕导入到这些子角色中。

定位您希望显示字幕的播放头,然后选取“编辑”>“字幕”>“添加字幕”(或按 Option–C)。Final Cut Pro 会在字幕主道中放入一个字幕片段,然后字幕编辑器会在时间线中打开。在字幕编辑器中键入文本。

您也可以添加、编辑和浏览字幕:

  • 要添加另一条字幕,请定位播放头,然后按 Option–C。
  • 要编辑现有的字幕,请在时间线中连按两次字幕,然后在字幕编辑器中进行更改。
  • 要浏览字幕,请在字幕编辑器中点按左箭头或右箭头,或者按 Command–左箭头键或 Command–右箭头键。

Final Cut Pro X 和 Compressor 会在您创建字幕的同时自动检查字幕有没有错误。在 Final Cut Pro 中,有错误的字幕会在时间线中显示为红色。字幕检查器中会说明导致错误的原因和可能的解决方案。进一步了解 Final Cut Pro 和 Compressor 中的字幕验证


格式化字幕文本

您可以更改文本的格式和颜色,以及字幕在屏幕上的位置。可用的选项根据您所选的字幕格式而有所不同。

要格式化字幕,请在时间线中选择一个字幕片段。字幕检查器中会出现选项。一条字幕可以有多种文本格式。


排列字幕

在添加字幕后,您可以调整字幕在屏幕上显示的时间长度,以及它在时间线中的位置。 

要调整字幕的持续时间,请拖移字幕片段在时间线上的起点或终点。

要调整字幕片段的位置,请点按字幕片段并将它向左或向右拖移。您还可以调整字幕的位置,方法是使用键盘快捷键来挪动字幕,或输入时间码

请尽量避免字幕重叠。当字幕重叠时,它们会在时间线中变为红色,字幕检查器中也会显示错误信息。要共享您的项目,您需要解决所有字幕重叠问题。选取“编辑”>“字幕”>“解决重叠”。


创建其他语言的字幕

在排列好主要语言的所有字幕后,您可以复制完成的字幕集合。然后,您可以直接在 Final Cut Pro 时间线中翻译复制的字幕集合。

  1. 点按一个字幕片段,然后按 Command–A 来选择所有字幕。 
  2. 选取“编辑”>“字幕”>“将字幕复制到新语言”,然后选择一种语言。时间线中会出现复制的新字幕集合,同时也会为新语言创建一个子角色。
  3. 如果您要以一种需要特殊字符的语言输入字幕文本,请在“语言与地区”系统偏好设置中添加这种语言,然后从菜单栏的“输入”菜单中选取这种语言,并在字幕编辑器中使用这种语言输入文本。

更改检视器中显示的语言:

  1. 选取“显示”>“时间线索引”>“角色”。
  2. 在“索引”中,选择您要在检视器中查看的语言。

进一步了解在时间线索引中管理字幕


共享带字幕的项目

在所有字幕格式中,您都可以针对每种语言子角色共享单独的字幕文件。在 CEA-608 中,您还可以在共享项目时将字幕嵌入到媒体文件中。

在 SRT 中,您可以将 SRT 字幕作为单独的文件导入和导出,但是无法按照处理 CEA-608 字幕的方式将 SRT 字幕嵌入输出媒体文件中。不同于其他格式的字幕,导出的 SRT 字幕可以在纯文本编辑器中读取和编辑。

仅导出字幕

如果您想仅导出字幕,请选取“文件”>“导出字幕”。在窗口中,从“角色”部分选择语言,选取文件的位置,然后点按“导出”。

固定字幕

许多共享目的位置还包含固定字幕选项,因此这些字幕在导出文件中始终处于可见状态。在“共享”窗口的“角色”面板中,点按“字幕”,然后从“刻录”旁的弹出式菜单中选择想要刻录的字幕格式。

通过 Compressor 共享

您可以将项目发送到 Compressor,再用它来进行批处理,以便交付到 YouTube、Vimeo、DVD 和其他目的位置。您可以将项目作为标准的 Compressor 批处理格式发送到 Compressor,其中会包含一个字幕集合。

对于您要在 Compressor 中进行 iTunes Store 准备的项目,请选取“文件”>“将 iTMS 项目包发送到 Compressor”。iTMS 项目包可以包含多种语言和多种格式。


在 Compressor 中处理字幕

使用 Compressor 时,通过将字幕导入到作业中来将字幕添加到媒体文件。当您处理已经包含字幕的项目时,Compressor 会在您添加源文本到批处理时提取字幕。

您可以验证字幕、更正错误、调整字幕文本和属性,也可以单独导出字幕。然后,您可以使用标准的转码设置对视频和字幕进行转码,或者将带字幕的视频直接发布到 YouTube。进一步了解在 Compressor 中处理字幕


进一步了解

有关非 Apple 制造的产品或非 Apple 控制或测试的独立网站的信息仅供参考,不代表 Apple 的任何建议或保证。Apple 对于第三方网站或产品的选择、性能或使用不承担任何责任。Apple 对于第三方网站的准确性和可靠性不作任何担保。互联网的使用具有一定风险。请联系供应商以了解其他信息。其他公司和产品名称可能是其各自所有公司的商标。

发布日期: