在 Logic Pro X 中自动匹配速度

借助 Logic Pro 10.4 中的智能速度功能,不但能在不使用节拍器的情况下进行演奏录制,还能让 Logic Pro 调整项目速度以匹配录制速度,或者保持项目速度并对录制进行 Flex 处理以匹配项目速度。

您可以在录制一个或多个音频、软件乐器或 MIDI 轨道时使用智能速度。“智能速度”包含三种模式,即“保留”、“调整”和“自动”:

  • 使用“保留”模式可以按照项目的速度设置来同步与速度相关的所有素材。
  • 使用“调整”模式可以让 Logic 分析并采用已录制的演奏或音频文件的速度。
  • 使用“自动”模式可以让 Logic Pro 根据您的项目中是不是存在速度参考(如节拍器或其他片段)来选择模式。如果存在速度参考,则会维持项目速度。如果不存在音乐速度参考,则会调整项目速度,以匹配已录制或已导入的音频文件的速度。

要选取某种智能速度模式,请点按 LCD 中的“智能速度”弹出式菜单。

在录制时匹配项目速度

要在录制时将项目速度与您的演奏相匹配,请使用“调整”模式。在录制新项目中的第一首曲目时,请暂时使用“调整”模式。如果在开启“调整”模式的情况下录制后续轨道,速度映射会根据最新的一次录制做出更改。 

  1. 创建一个新项目并添加音轨。
  2. 从 LCD 的“速度”显示中选取“调整”。速度轨道会随即打开,以便您查看项目速度在音频片段的录制、添加或移动过程中的变化情况。
  3. 在开始录制之前,您可以设置一些自动操作,使 Logic Pro 在轨道录制结束后立即实施。例如,Logic Pro 可以将轨道开头自动修剪到第一个强拍。请选取“文件”>“项目设置”>“智能速度”,然后选择“将新录音设为”弹出式菜单旁边的“修剪新片段的开头”。
  4. 开始录制。录制期间,项目速度会进行调整以匹配录制速度。片段中的红线显示的是检测到的速度变化,速度映射则会显示在速度轨道中。
  5. 完成录制后,请按下空格键以停止传输。
  6. 在出现的对话框中,您可以选取相应选项以打开文件速度编辑器。借助智能速度编辑器,您不但可以试听录音,还可以调整强拍、速度和其他速度参数。

在移动或编辑片段时,速度的变化会随着片段转移到相应的新位置。如果您向轨道添加鼓手轨道、其他节奏乐器或 Apple 乐段,所添加的内容会自动采用原始轨道的速度。如果您进行了多轨道录音并在稍后添加了轨道,可以将轨道添加到智能速度用于创建速度图的轨道集中,然后重新分析速度。

如果您导入音频文件,项目速度会发生变化以适应导入的音频文件。

 

利用智能速度功能创建 DJ 混音

您可以使用智能速度功能轻松创建 DJ 风格的无缝混音,这类混音中的所有歌曲都会采用相同的速度。您可以创建混音,使其中所含的所有歌曲都按照预先确定的速度来播放,或按照第一首导入歌曲的速度来播放。

创建会按照预先确定的速度进行播放的混音:

  1. 新建一个空项目。
  2. 将“吸附”弹出式菜单设置为“智能”。 
  3. 在 LCD 中连按速度,然后输入混音要采用的速度。
  4. 选取“文件”>“项目设置”>“智能速度”,然后完成以下操作:
    • 从“项目速度的默认模式”弹出式菜单中选取“保留项目速度”。
    • 从“将导入的音频文件设为”弹出式菜单中选取“开 + 匹配小节和节拍”。这样就会为导入的文件自动开启 Flex 处理,并会运用智能速度功能分析按照当前的项目速度来量化网格的强拍和节拍。
  5. 导入第一个音频文件。Logic Pro 会分析这个文件,并遵循您设置的项目速度。
  6. 要在智能速度编辑器中进行任何调整,请点按“显示”。
  7. 在“轨道”区域中,按需修剪和移动歌曲的开头和结尾。
  8. 导入下一个音频文件。这个新导入的文件会按照项目速度播放。

创建会按照导入的第一首歌曲的速度进行播放的混音:

  1. 新建一个空项目。
  2. 将“吸附”弹出式菜单设置为“智能”。 
  3. 选取“文件”>“项目设置”>“智能速度”,然后完成以下操作:
    • 从“项目速度的默认模式”弹出式菜单中选取“调整项目速度”。
    • 从“将导入的音频文件设为”弹出式菜单中选取“开”。这样就会为导入的文件自动开启 Flex 处理。
  4. 导入第一个音频文件。Logic Pro 会分析这个文件,并创建速度映射。
  5. 要在智能速度编辑器中进行任何调整,请点按对话框中的“显示”。例如,您可能需要在文件的开头设置一个新的强拍。
  6. 在“轨道”区域中,按需修剪和移动歌曲的开头和结尾。
  7. 将“智能速度”设置为“保留”,然后将下一首歌曲导入到同一轨道中。导入的这个文件会按照第一个音频文件的最后一个速度事件来播放。

将智能速度功能用于多轨道录音

对于多轨道录音,智能速度功能会同时分析多轨道音频文件以创建速度图。为此,Logic Pro 会创建一个多轨道集,并且您可以随时进行编辑。Logic Pro 会在后台创建了一个降低混音,智能速度功能会使用它来分析多轨道音频文件。在智能速度编辑器中优化速度分析时,请使用降低混音

您可以通过三种方式将智能速度功能与多轨道录音配合使用:

  • 您可以创建多轨道录音,并使用智能速度功能来在录制时匹配速度
  • 您可以将多个音频文件导入项目,并让智能速度功能在导入时进行同步分析。
  • 您可以在项目的“轨道”区域中选择多个音频片段,并让智能速度功能一起分析。 

在创建多轨道录音时,或者如果要将多个文件导入“轨道”区域,请先设置这些选项。

  1. 选取“文件”>“项目设置”>“智能速度”。
  2. 从“项目速度的默认模式”弹出式菜单中选取“调整项目速度”。
  3. 在导入音频文件时,请在“将导入的音频文件设为”弹出式菜单中选择“开”。这样就会为导入的文件自动打开 Flex。

在“轨道”区域中选择多个音频片段并进行分析

如果在创建多轨道录音时未使用智能速度功能,您可以在完成录制后再分析音频片段。

  1. 在“轨道”区域中选择要分析的音频片段。
  2. 按住 Control 键点按其中一个选定的片段,然后选取“速度”>“创建智能速度多轨道集”。
  3. 在“智能速度多轨道”窗口的“参与分析”列中,取消选择要从智能速度分析中排除的片段。
  4. 点按“分析”。您可以在智能速度编辑器中微调各个片段的速度分析。您还可以在多轨道集中添加和从中移除片段,以及随时进行重新分析。

编辑多轨道集

在完成多个片段的初始分析后,您可以编辑多轨道集以在智能速度分析中添加或从中移除片段,然后更新速度分析。在“轨道”区域中,按住 Control 键点按多轨道集中使用的某个片段,然后选取“速度”>“编辑智能速度多轨道集”。

要重新分析该集,请选择或取消选择要包含在速度分析中的片段,然后点按“更新”。

要创建新的多轨道集,请点按“解散集”。然后,在“轨道”区域中选择要包含的新片段,按住 Control 键点按其中一个选定的片段,然后选取“速度”>“创建智能速度多轨道集”。

将智能速度功能用于软件乐器和 MIDI 轨道

在新建的项目中,创建软件乐器或外部 MIDI 轨道,将智能速度模式设置为“调整”,然后录制您的演奏。Logic Pro 会创建一个速度图,就像在处理音轨时一样。您还可以将智能速度编辑器用于软件乐器和 MIDI 轨道。与处理音频文件时不同的是,Logic Pro 会将智能速度编辑直接存储到 MIDI 片段。

对智能速度分析进行微调并纠正速度检测错误

在完成音频片段录制或使用智能速度导入音频文件后,您可以对速度分析进行微调,并用智能速度编辑器纠正所有速度检测错误。

例如,如果 Logic Pro 在您录制或导入音频文件时无法正确检测这个文件中的强拍,那么您可以对这些强拍进行设置。请在显示音频文件波形的主显示中,将鼠标指针置于您想要设定强拍(橙色线条)的节拍标记(以红色线条标示)上。沿着整条节拍标记会出现一系列圆形控制柄。每个控制柄都会显示一个标签,说明这个控制柄的功能。请将鼠标指针置于节拍标记上,然后点按“设定强拍”控制柄。您也可以使用主窗口中的控制柄来移动和扩展节拍标记。

智能速度编辑器还包括其他功能:

  • 要编辑音频文件中的速度数据,请点按“编辑”弹出式菜单。您可以重新分析音频文件、将片段的速度应用于项目或将项目速度应用于片段、扩展速度更改、移除对文件所做的速度编辑等。
  • 要使文件速度加倍或减半,请点按“速度”显示中的“x2”或“/2”。例如,您可能已经使用“调整”模式录制了一段音轨,但 Logic Pro 检测到的速度是您所期望速度的两倍或一半。
  • 要试听这个文件,请点按
  • 要为试听添加节拍器,请点按
  • 要循环播放这个文件,请点按

对于 MIDI 文件,MIDI 片段的智能速度分析不包括拍号或强拍位置分析。Logic Pro 会将第一个 MIDI 音符事件自动标记为强拍。

编辑多轨道集降低混音

在智能速度编辑器中编辑多轨道集时,请确保编辑的是降低混音,而不是多轨集中包含的各个片段。在智能速度编辑器中,点按“文件名”弹出式菜单,然后选取“降低混音”。然后,您可以设置强拍,并在多轨道集上进行其他操作。

发布日期: