解决 MainStage 3 中的问题

了解如何查明、故障诊断和解决 MainStage 3 中的问题。

请按照以下建议列出的顺序操作,直至您查明或解决问题。在继续操作之前,请务必备份 MainStage 应用程序

1. 确保 MainStage 是最新版本

请确保您使用的是最新版本的 MainStage 3。选取苹果菜单 () > App Store,然后点按工具栏中的“更新”。如果有可用的更新,请点按“更新”按钮以下载并安装更新。

2. 检查设备或软件的兼容性

如果您使用的外部音频接口、MIDI 接口、储存系统或插件并非由 Apple 制造,请确保它与最新版本的 MainStage 3 兼容。请联系制造商以获取支持。如果有可用的更新,请按照制造商的说明来更新设备或软件。 

3. 查看文档

请查看“MainStage 3 帮助”,确保 MainStage 按照预期正常运行。您可以在“帮助”中搜索警告或错误信息中出现的关键词。

4. 使用内建音频进行测试

有时,不兼容或出现故障的外部音频接口会导致 MainStage 出现问题。如果您使用的是外部音频接口,请尝试使用 Mac 上的内建音频,而不是接口。

要将内建音频与 MainStage 配合使用:

  1. 从您的 Mac 上拔下外部音频接口。
  2. 打开 MainStage,然后选取“MainStage”>“偏好设置”>“音频”。
  3. 从“音频输出”弹出式菜单中选取“内建输出”。
  4. 从“音频输入”弹出式菜单中选取“内建麦克风”(或“内建输入”,具体取决于您的电脑)。
  5. 使用出现问题的 Concert、Set 或 Patch 进行测试。

如果使用内建音频可以解决问题,则您可能需要更新或检修音频接口。请联系制造商以获取支持。

5. 创建新的 Concert

有时 Concert 文件可能无法使用,从而导致 MainStage 出现异常行为。

要创建并测试新的项目,请进行以下操作:

  1. 打开 MainStage,然后选取“文件”>“新建”。
  2. 从对话框中的“音频输入”和“音频输出”弹出式菜单中,选取您想要用于音频输入和输出的设备。
  3. 点按左侧的乐器类别,然后选择您想要使用的模板。
  4. 点按“选取”。
  5. 测试看看问题会不会在新 Concert 中出现。如果新的 Concert 中未出现该问题,则表示导致问题出现的 Concert 可能已经损坏。您可以尝试重建 Concert 文件。

重建损坏的 Concert 文件

重建 Concert 时,您需要从您的 Concert 中导出 Layout、Set 和 Patch,然后将它们导入新的 Concert 中。

  1. 打开导致问题出现的 Concert。
  2. 要导出您的 Layout,请点按“Layout”,再点按“Layout”部分顶部的齿轮图标,然后从菜单中选取“导出 Layout”。选取一个存储 Layout 的位置,然后点按“导出”。
  3. 要导出您的 Set 和 Patch,请点按“编辑”,再点按“Patch 列表”,然后按下“Command–A”(或选取“编辑”>“全选”)以选择“Patch 列表”中所有的 Set 和 Patch。将它们拖移到桌面或文件夹中。
  4. 关闭 Concert。
  5. 使用任何模板创建新的 Concert。
  6. 点按“Layout”,按下“Command–A”(或选取“编辑”>“全选”)以选择“Layout”部分中的所有元素,然后按下 Delete 键将它们移除。
  7. 要从原始 Concert 导入 Layout,请点按“Layout”部分顶部的齿轮图标,然后从菜单中选取“导入 Layout”。选择 Layout,然后点按“导入”。
  8. 点按“编辑”,选择“Patch 列表”中的所有 Set 和 Patch,然后按下 Delete 键以移除现有的所有 Patch。
  9. 将原始 Concert 中的 Patch 拖移到“Patch 列表”中。在将 Set 和 Patch 拖移到 Patch 列表中后,您可能需要对它们进行重新排序。
  10. 测试新的 Concert,看看问题是否仍然存在。

6. 尝试使用其他用户帐户

7. 还原偏好设置

还原 MainStage 偏好设置不会影响您的项目文件、预置或 Patch。但是,您会丢失已有的任何自定偏好设置。

还原偏好设置之前,请选取“MainStage”>“偏好设置”,并记录已有的任何特定设置。这样,在还原偏好设置后,您可以返回并重新应用您的自定设置。有关不同偏好设置的信息,请参阅“MainStage 帮助”中的“偏好设置概览”。

要还原您的 MainStage 偏好设置:

  1. 如果 MainStage 已打开,请退出。
  2. 在 Finder 中,按住 Option 键,然后选取“前往”>“资源库”。
  3. 从“偏好设置”文件夹中移除“com.apple.mainstage3.plist”文件。
  4. 重新启动 Mac。

Mac 重新启动后,打开 MainStage,并尝试重现您之前遇到的问题。如果问题不再出现,请打开 MainStage 偏好设置,并重新应用您的自定设置。

8. 重新安装 MainStage

如果问题仍然存在,请移除并重新安装 MainStage。您现有的 MainStage Concert 不会被删除,并且您可以在重新安装后将其打开。

  1. 在 Finder 中,选取“前往”>“应用程序”。
  2. 找到 MainStage 3,并将其拖移到“废纸篓”中。
  3. 从 App Store 中重新安装 MainStage,或从备份中进行恢复。从备份中恢复 MainStage 应用程序的副本时,您可以将它从储存位置拖移到您的“应用程序”文件夹中,或者可以从 Time Machine 备份中进行恢复

有关非 Apple 制造的产品或非 Apple 控制或测试的独立网站的信息仅供参考,不代表 Apple 的任何建议或保证。Apple 对于第三方网站或产品的选择、性能或使用不承担任何责任。Apple 对于第三方网站的准确性和可靠性不作任何担保。互联网的使用具有一定风险。请联系供应商以了解其他信息。其他公司和产品名称可能是其各自所有公司的商标。

发布日期: