Проблеми системи безпеки, які вирішено у Swift 5.1.1 для Ubuntu

Цей документ перелічує проблеми системи безпеки, які вирішено у Swift 5.1.1 для Ubuntu.

Відомості про оновлення системи безпеки Apple

Щоб захистити клієнтів, компанія Apple не розголошує інформацію про проблеми безпеки, не підтверджує її та не бере участь у її обговоренні, доки не завершено вивчення відповідної проблеми та не опубліковано виправлення або нові випуски. Відомості про нещодавні випуски див. в статті Оновлення системи безпеки Apple.

Документи про безпеку Apple класифікують вразливості за кодами CVE-ID, коли це можливо.

Щоб отримати додаткову інформацію про безпеку, див. сторінку безпеки продуктів Apple.

Swift 5.1.1 для Ubuntu

Випущено 11 жовтня 2019 р.

Платформа

Цільові продукти: Ubuntu 14.04, 16.04 та 18.04

Вплив: неправильне керування дескрипторами файлів у URLSession може призводити до випадкового розкриття даних.

Опис: цю проблему вирішено завдяки оновленню неправильної логіки керування дескрипторами файлів URLSession відповідно до версії Swift 5.0.

CVE-2019-8790: фахівці Apple

Інформація про продукти, вироблені не компанією Apple, або про незалежні веб-сайти, які не контролюються та не тестуються компанією Apple, не носить рекомендаційного характеру та не рекламується компанією. Компанія Apple не несе жодної відповідальності за вибір, функціональність і використання веб-сайтів або продукції сторонніх виробників. Компанія Apple також не несе відповідальність за точність або достовірність даних, розміщених на веб-сайтах сторонніх виробників. Зверніться до відповідного постачальника за додатковою інформацією.

Дата опублікування: