Xcode 8.1'in güvenlik içeriği hakkında

Bu belgede Xcode 8.1'in güvenlik içeriği açıklanmaktadır.

Apple güvenlik güncellemeleri hakkında

Apple, müşterilerini korumak amacıyla soruşturma gerçekleştirilene ve yamalar veya sürümler kullanıma sunulana kadar güvenlik sorunlarını açıklamaz, onaylamaz ya da bunlardan bahsetmez. Son sürümler Apple güvenlik güncellemeleri sayfasında listelenmektedir.

Güvenlik hakkında daha fazla bilgi için Apple Ürün Güvenliği sayfasına bakın. Apple Ürün Güvenliği PGP Anahtarı'nı kullanarak Apple ile görüşmelerinizi şifreleyebilirsiniz.

Apple güvenlik belgelerinde güvenlik açıklarından mümkün olduğunda CVE Kimliği'yle bahsedilir.

Xcode 8.1

Yayımlanma tarihi: 27 Ekim 2016

IDE Xcode Server

İlgili sürümler: OS X El Capitan v10.11.5 ve sonraki sürümleri

Etki: Uzaktaki bir saldırgan uygulamanın beklenmedik bir şekilde sonlandırılmasına veya rastgele kod yürütülmesine neden olabilir

Açıklama: Xcode Server'daki Node.js'de birden fazla sorun vardı. Bu sorunlar, Node.js sürümünün 4.5.0'a güncellenmesiyle giderildi.

CVE-2016-1669

CVE-2016-0705

CVE-2016-0797

CVE-2016-0702

CVE-2016-2086

CVE-2016-2216

CVE-2015-8027

CVE-2015-3193

CVE-2015-3194

CVE-2015-6764

Apple tarafından üretilmeyen ürünler veya Apple tarafından denetlenmeyen veya test edilmeyen bağımsız web siteleri hakkındaki bilgiler öneri veya onay alınmadan sağlanır. Apple üçüncü taraf web sitelerinin veya ürünlerinin seçimi, performansı veya kullanımıyla ilgili hiçbir sorumluluk almaz. Apple üçüncü taraf web sitesi doğruluğu veya güvenilirliği ile ilgili hiçbir fikir belirtmez. Riskler Internet kullanımının doğal bir parçasıdır. Ek bilgiler için satıcı ile irtibat kurun. Diğer ürün ve şirket adları ilgili sahiplerinin ticari markaları olabilir.

Yayın Tarihi: