เกี่ยวกับส่วนขยายของระบบรุ่นเก่า

ส่วนขยายของระบบบางอย่างจะไม่สามารถทำงานร่วมกับ macOS เวอร์ชั่นต่อไปได้

ส่วนขยายของระบบเป็นหมวดหมู่ของซอฟต์แวร์ที่ทำงานในพื้นหลังเพื่อขยายฟังก์ชั่นการทำงานของ Mac แอพบางตัวติดตั้งส่วนขยายเคอร์เนล ซึ่งเป็นส่วนขยายของระบบชนิดหนึ่งที่ทำงานโดยใช้วิธีเก่ากว่าที่ไม่ปลอดภัยหรือเชื่อถือได้เหมือนกับทางเลือกใหม่ๆ Mac ของคุณจะระบุรายการเหล่านี้ว่าเป็นส่วนขยายของระบบรุ่นเก่า

ในปี 2019 Apple ได้แจ้งให้นักพัฒนาทราบว่า macOS Catalina จะเป็น macOS รุ่นสุดท้ายที่รองรับส่วนขยายของระบบรุ่นเก่าทั้งหมด และเราได้ทำงานร่วมกับนักพัฒนาเพื่อปรับเปลี่ยนซอฟต์แวร์ของพวกเขา ด้วยการก้าวข้ามส่วนขยายเหล่านี้ นักพัฒนากำลังช่วยปรับปรุง Mac ให้ทันสมัย ปรับปรุงความปลอดภัยและความเสถียร และใช้งานวิธีการกระจายซอฟต์แวร์ที่ใช้งานง่ายขึ้นต่อไป ยังไม่ได้กำหนดวันที่เปลี่ยนแปลงขั้นสุดท้าย

จนกว่าการเปลี่ยนแปลงจะเสร็จสมบูรณ์ Mac ของคุณจะแสดงข้อความในครั้งแรกที่ส่วนขยายระบบรุ่นเก่าโหลดขึ้น และแสดงอีกครั้งเป็นระยะขณะที่ยังคงใช้งานส่วนขยายอยู่ ซึ่งเป็นการแจ้งให้คุณทราบล่วงหน้าว่าซอฟต์แวร์ที่มีอยู่ในระบบของคุณโหลดส่วนขยายของระบบที่จะใช้งานร่วมกับ macOS เวอร์ชั่นในอนาคตไม่ได้

ส่วนขยายของระบบรุ่นเก่าและแอพที่ใช้ส่วนขยายนี้จะยังคงทำงานได้ในปัจจุบัน แต่ตอนนี้เป็นเวลาที่ควรติดต่อนักพัฒนาเพื่อดูว่าซอฟต์แวร์เวอร์ชั่นที่อัพเดทพร้อมใช้งานหรือมีการวางแผนหรือไม่ นอกจากนี้นักพัฒนายังสามารถอธิบายวิธีลบหรือปิดใช้งานส่วนขยาย รวมถึงผลของการดำเนินการนั้นด้วย
 

รายละเอียดทางเทคนิคสำหรับนักพัฒนามีอยู่ที่ ส่วนขยายเคอร์เนลที่เลิกใช้และทางเลือกสำหรับส่วนขยายของระบบ

การให้ข้อมูลเกี่ยวกับผลิตภัณฑ์ที่ไม่ได้ผลิตโดย Apple หรือเว็บไซต์อิสระที่ Apple ไม่ได้ควบคุมหรือทดสอบไม่ถือเป็นการแนะนำหรือการรับรองใดๆ Apple จะไม่รับผิดชอบในส่วนที่เกี่ยวข้องกับการเลือก ประสิทธิภาพการทำงาน หรือการใช้งานเว็บไซต์หรือผลิตภัณฑ์ของบริษัทอื่น Apple ไม่รับรองความถูกต้องหรือความน่าเชื่อถือของเว็บไซต์ของบริษัทอื่น โปรดติดต่อผู้จำหน่ายหากต้องการข้อมูลเพิ่มเติม

วันที่เผยแพร่: