Sobre o conteúdo de segurança do Xcode 8.1

Este documento descreve o conteúdo de segurança do Xcode 8.1.

Sobre as atualizações de segurança da Apple

Para garantir a proteção de nossos clientes, a Apple não divulga, discute nem confirma problemas de segurança até que uma investigação seja conduzida e as correções ou versões estejam disponíveis. As versões recentes estão indicadas na página Atualizações de Segurança da Apple.

Para obter informações sobre segurança, consulte a página Segurança do produto Apple. É possível criptografar comunicações com a Apple usando a Chave PGP de Segurança do Produto Apple.

Os documentos de segurança da Apple mencionam vulnerabilidades por meio do ID de CVE quando possível.

Xcode 8.1

Lançado em 27 de outubro de 2016

IDE Xcode Server

Disponível para: OS X El Capitan 10.11.5 e posteriores

Impacto: um invasor externo pode encerrar aplicativos inesperadamente ou executar código arbitrariamente

Descrição: havia vários problemas no Node.js no Xcode Server. Esses problemas foram resolvidos atualizando o Node.js para a versão 4.5.0.

CVE-2016-1669

CVE-2016-0705

CVE-2016-0797

CVE-2016-0702

CVE-2016-2086

CVE-2016-2216

CVE-2015-8027

CVE-2015-3193

CVE-2015-3194

CVE-2015-6764

As informações sobre produtos não fabricados pela Apple, ou sites independentes não controlados nem testados pela Apple, são fornecidas sem recomendação ou endosso. A Apple não assume responsabilidade alguma com relação à escolha, ao desempenho ou ao uso de sites ou produtos de terceiros. A Apple não garante a precisão nem a confiabilidade de sites de terceiros. Os riscos são inerentes ao uso da internet. Entre em contato com o fornecedor para obter mais informações. Nomes de outras empresas e produtos podem ser marcas registradas de seus respectivos proprietários.

Data da publicação: