Resolver um problema no MainStage 3

Saiba como isolar e solucionar problemas no MainStage 3.

Siga as recomendações abaixo na ordem mostrada até conseguir isolar ou resolver o problema. Antes de continuar, faça backup do aplicativo MainStage.

1. Verificar se o MainStage está atualizado

Veja se o computador está com a versão mais recente do MainStage 3. Selecione o menu Apple () > App Store e clique em Atualizações na barra de ferramentas. Se uma atualização estiver disponível, clique no botão Atualizar para fazer download e instalá-la.

2. Verificar a compatibilidade do software ou do dispositivo

Se você estiver usando uma interface de áudio externa, interface MIDI, sistema de armazenamento ou plug-in não fabricado pela Apple, verifique se são compatíveis com a versão mais recente do MainStage 3. Entre em contato com o fabricante para obter suporte. Se houver uma atualização disponível, siga as instruções do fabricante para atualizar o software ou o dispositivo. 

3. Verificar a documentação

Consulte a Ajuda do MainStage 3 para verificar se o MainStage está funcionando conforme o esperado. Você pode buscar na ajuda os principais termos exibidos nos alertas ou mensagens de erro.

4. Testar usando o áudio integrado

Às vezes, uma interface de áudio externa incompatível ou com defeito pode causar problemas no MainStage. Se você estiver usando uma interface de áudio externa, use o áudio integrado do Mac em vez da interface.

Para usar o áudio integrado com o MainStage:

  1. Desconecte a interface de áudio externa do Mac.
  2. Abra o MainStage e selecione MainStage > Preferences (Preferências) > Audio (Áudio).
  3. Selecione Built-in Output (Saída integrada) no menu pop-up Audio Output (Saída de áudio).
  4. Selecione Built-in Microphone (Microfone integrado) (ou Built-in Input [Entrada integrada], dependendo do computador) no menu pop-up Audio Input (Entrada de áudio).
  5. Teste usando um concerto, ajuste ou patch em que você teve problemas.

Se o problema for resolvido ao usar o áudio integrado, você precisará atualizar ou realizar serviço na interface de áudio. Entre em contato com o fabricante para obter suporte.

5. Criar um concerto

Às vezes, os arquivos de concerto podem se tornar inutilizáveis, causando comportamento inesperado no MainStage.

Para criar e testar um novo projeto:

  1. Abra o MainStage e selecione File (Arquivo) > New (Novo).
  2. Nos menus pop-up de entrada e saída de áudio da caixa de diálogo, escolha os dispositivos que você deseja usar para entrada e saída de áudio.
  3. Clique em uma categoria de instrumento à esquerda e selecione o modelo que deseja usar.
  4. Clique em Choose (Escolher).
  5. Teste para ver se o problema ocorre no novo concerto. Se o problema não ocorrer no novo concerto, isso poderá indicar que há danos no concerto com o qual você está tendo problemas. Você pode tentar reconstruir o arquivo de concerto.

Reconstruir um arquivo de concerto danificado

Ao reconstruir um concerto, você exporta o layout, os ajustes e os patches do concerto e depois os importa para um novo concerto.

  1. Abra o concerto que está com problemas.
  2. Para exportar o layout, clique em Layout, clique no ícone de engrenagem na parte superior da seção Layout e selecione Export Layout (Exportar layout) no menu. Escolha um local para salvar o layout e clique em Export (Exportar).
  3. Para exportar os ajustes e patches, clique em Edit (Editar), clique na lista de patches e pressione as teclas Command + A (ou selecione Edit [Editar] > Select All [Selecionar tudo]) para selecionar todos os ajustes e patches da lista de patches. Arraste-o para a mesa ou uma pasta.
  4. Feche o concerto.
  5. Crie outro concerto usando qualquer modelo.
  6. Clique em Layout, pressione as teclas Command + A (ou selecione Edit [Editar] > Select All [Selecionar tudo]) para selecionar todos os elementos da seção Layout e pressione Delete (Apagar) para removê-los.
  7. Para importar o layout do concerto original, clique no ícone de engrenagem na parte superior da seção Layout e selecione Import Layout (Importar layout) no menu. Selecione o layout e clique em Import (Importar).
  8. Clique em Edit (Editar), selecione todos os ajustes e patches da lista de patches e pressione Delete (Apagar) para remover todos os patches existentes.
  9. Arraste os patches do concerto original para a lista de patches. Você talvez precise reordenar os ajustes e patches depois de arrastá-los para a lista.
  10. Teste o novo concerto para ver se o problema continua.

6. Usar outra conta de usuário

Abra o MainStage em outra conta de usuário no Mac. Iniciar sessão como outro usuário pode ajudar você a descobrir se um comportamento inesperado está relacionado aos ajustes ou arquivos de um usuário específico.

7. Redefinir as preferências

Redefinir as preferências do MainStage não afeta os arquivos, pré-ajustes ou patches do projeto. No entanto, você perderá alguns ajustes de preferência personalizados que foram criados.

Antes de redefinir as preferências, selecione MainStage > Preferências e verifique se foram feitos ajustes específicos. Dessa forma, você poderá aplicar novamente tais ajustes personalizados depois da redefinição. Para obter informações sobre diferentes preferências, consulte Visão geral das preferências na Ajuda do MainStage.

Para redefinir as preferências do MainStage:

  1. Encerre o MainStage, caso esteja aberto.
  2. No Finder, mantenha pressionada a tecla Option e selecione Ir > Biblioteca.
  3. Remova o arquivo com.apple.mainstage3.plist da pasta Preferências.
  4. Reinicie o Mac.

Depois que o Mac reiniciar, abra o MainStage e tente reproduzir o problema que estava ocorrendo. Se o problema não ocorrer mais, abra as preferências do MainStage e aplique novamente os ajustes personalizados.

8. Reinstalar o MainStage

Se o problema persistir, remova e reinstale o MainStage. Os concertos no MainStage não serão apagados e poderão ser abertos após a reinstalação.

  1. No Finder, selecione Ir > Aplicativos.
  2. Localize o MainStage 3 e arraste-o para o Lixo.
  3. Reinstale o MainStage pela App Store ou o restaure usando um backup. Ao restaurar uma cópia do aplicativo MainStage usando um backup, você pode arrastá-la do local de armazenamento para a pasta Aplicativos ou restaurá-la usando um backup do Time Machine.

As informações sobre produtos não fabricados pela Apple, ou sites independentes não controlados nem testados pela Apple, são fornecidas sem recomendação ou endosso. A Apple não assume responsabilidade alguma com relação à escolha, ao desempenho ou ao uso de sites ou produtos de terceiros. A Apple não garante a precisão nem a confiabilidade de sites de terceiros. Entre em contato com o fornecedor para obter mais informações.

Data da publicação: