Over de beveiligingsinhoud van OS X Server v4.0

Lees hier meer over de beveiligingsinhoud van OS X Server v4.0.

Ter bescherming van onze klanten maakt Apple geen beveiligingskwesties openbaar en bespreekt of bevestigt Apple deze niet totdat een volledig onderzoek is uitgevoerd en de benodigde patches of releases beschikbaar zijn. Bezoek de website Apple productbeveiliging voor meer informatie over Apple-productbeveiliging.

Raadpleeg Hoe gebruikt u de Apple Product Security PGP-sleutel? voor meer informatie over het gebruik van de Apple PGP-sleutel voor productbeveiliging.

Waar mogelijk worden CVE-ID’s als referentie voor kwetsbaarheden gebruikt voor verdere informatie.

Raadpleeg Apple-beveiligingsupdates voor meer informatie over andere beveiligingsupdates.

OS X Server v4.0

  • BIND

    Beschikbaar voor: OS X Yosemite v10.10 of hoger

    Impact: er waren meerdere kwetsbaarheden in BIND, waarvan de ernstigste kunnen leiden tot een weigering van service

    Beschrijving: er waren meerdere kwetsbaarheden in BIND. Deze problemen zijn verholpen door BIND bij te werken naar versie 9.9.2-P2.

    CVE-ID

    CVE-2013-3919

    CVE-2013-4854

    CVE-2014-0591

  • CoreCollaboration

    Beschikbaar voor: OS X Yosemite v10.10 of hoger

    Impact: een externe aanvaller kan willekeurige SQL-verzoeken uitvoeren

    Beschrijving: er was een SQL-injectieprobleem in Wiki Server. Dit probleem is verholpen door een extra validatie van SQL-verzoeken.

    CVE-ID

    CVE-2014-4424: Sajjad Pourali (sajjad@securation.com) van CERT of Ferdowsi University of Mashhad

  • CoreCollaboration

    Beschikbaar voor: OS X Yosemite v10.10 of hoger

    Impact: een bezoek aan een kwaadwillig vervaardigde website kan leiden tot een cross-site scripting-aanval

    Beschrijving: er was een cross-site scripting-probleem in Xcode Server. Dit probleem is verholpen door een verbeterde codering van HTML-uitvoer.

    CVE-ID

    CVE-2014-4406: David Hoyt van Hoyt LLC

  • CoreCollaboration

    Beschikbaar voor: OS X Yosemite v10.10 of hoger

    Impact: er waren meerdere kwetsbaarheden in PostgreSQL, waarvan de ernstigste kunnen leiden tot het uitvoeren van willekeurige code

    Beschrijving: er waren meerdere kwetsbaarheden in PostgreSQL. Deze problemen zijn verholpen door PostgreSQL bij te werken naar versie 9.2.7.

    CVE-ID

    CVE-2014-0060

    CVE-2014-0061

    CVE-2014-0062

    CVE-2014-0063

    CVE-2014-0064

    CVE-2014-0065

    CVE-2014-0066

  • Mail-voorziening

    Beschikbaar voor: OS X Yosemite v10.10 of hoger

    Impact: SACL-groepswijzigingen voor Mail worden mogelijk pas toegepast na een herstart van de Mail-voorziening

    Beschrijving: SACL-instellingen voor Mail zijn in de cache bewaard en wijzigingen aan de SACL’s zijn pas toegepast na een herstart van de Mail-voorziening. Dit probleem is verholpen door de cache opnieuw in te stellen bij wijzigingen aan de SACL’s.

    CVE-ID

    CVE-2014-4446: Craig Courtney

  • Profielbeheer

    Beschikbaar voor: OS X Yosemite v10.10 of hoger

    Impact: er waren meerdere kwetsbaarheden in LibYAML, waarvan de ernstigste kunnen leiden tot het uitvoeren van willekeurige code

    Beschrijving: er waren meerdere kwetsbaarheden in LibYAML. Deze problemen zijn verholpen door de interne serialisatiestructuur van Profielbeheer te veranderen van YAML naar JSON.

    CVE-ID

    CVE-2013-4164

    CVE-2013-6393

  • Profielbeheer

    Beschikbaar voor: OS X Yosemite v10.10 of hoger

    Impact: een lokale gebruiker kan na het configureren of bewerken van profielen in Profielbeheer wachtwoorden verkrijgen

    Beschrijving: in bepaalde gevallen kan het configureren of bewerken van profielen in Profielbeheer wachtwoorden registreren in een bestand. Dit probleem is verholpen door een verbeterde verwerking van inloggegevens.

    CVE-ID

    CVE-2014-4447: Mayo Jordanov

  • Server

    Beschikbaar voor: OS X Yosemite v10.10 of hoger

    Impact: een aanvaller kan gegevens decoderen die met SSL zijn beveiligd

    Beschrijving: er zijn bekende aanvallen op de betrouwbaarheid van SSL 3.0 wanneer een coderingssuite een blokcode in CBC-modus gebruikt. Zelfs als de server een betere TLS-versie ondersteunt, kan een aanvaller het gebruik van SSL 3.0 forceren door pogingen tot verbindingen met TLS 1.0 en hoger te blokkeren. Dit probleem is verholpen door SSL 3.0 uit te schakelen in Web-server, server voor Agenda en Contacten en Beheer op afstand.

    CVE-ID

    CVE-2014-3566: Bodo Moeller, Thai Duong en Krzysztof Kotowicz van het Google Security Team

  • ServerRuby

    Beschikbaar voor: OS X Yosemite v10.10 of hoger

    Impact: het uitvoeren van een Ruby-script dat niet-vertrouwde YAML-tags verwerkt, kan leiden tot het onverwacht afsluiten van het programma of het uitvoeren van willekeurige code

    Beschrijving: er was een probleem met een overloop bij gehele getallen bij de verwerking van YAML-tags door LibYAML. Dit probleem is verholpen door een extra validatie van YAML-tags. Dit probleem is niet van invloed op systemen ouder dan OS X Mavericks.

    CVE-ID

    CVE-2013-6393

Informatie over producten die niet door Apple zijn gemaakt of externe websites die niet door Apple worden beheerd of getest, wordt verstrekt zonder aanbeveling of goedkeuring. Apple aanvaardt geen aansprakelijkheid wat betreft de keuze, de prestaties of het gebruik van websites of producten van derden. Apple doet geen enkele toezegging met betrekking tot de juistheid of de betrouwbaarheid van websites van derden. Aan het gebruik van internet zijn risico’s verbonden. Neem contact op met de leverancier voor meer informatie. Andere bedrijfs- en productnamen zijn mogelijk handelsmerken van de respectievelijke eigenaars.

Publicatiedatum: