Over de beveiligingsinhoud van iOS 9.2

In dit document wordt de beveiligingsinhoud van iOS 9.2 beschreven.

Ter bescherming van onze klanten maakt Apple geen beveiligingskwesties openbaar en bespreekt of bevestigt Apple deze niet totdat een volledig onderzoek is uitgevoerd en de benodigde patches of releases beschikbaar zijn. Bezoek de website Apple productbeveiliging voor meer informatie over Apple productbeveiliging.

Raadpleeg Hoe gebruikt u de Apple Product Security PGP-sleutel voor meer informatie over het gebruik van de Apple PGP-sleutel voor productbeveiliging.

Waar mogelijk worden CVE-ID's als referentie voor kwetsbaarheden gebruikt voor verdere informatie.

Raadpleeg Apple beveiligingsupdates voor meer informatie over andere beveiligingsupdates.

iOS 9.2

  • AppleMobileFileIntegrity

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: een kwaadaardig programma kan willekeurige code uitvoeren met systeembevoegdheden

    Beschrijving: een probleem met de toegangsbeheer is verholpen door wijziging van toegangsbeheerstructuren te voorkomen.

    CVE-ID

    CVE-2015-7055: Apple

  • AppSandbox

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: een schadelijk programma kan de toegang tot Contacten behouden nadat de toegang officieel is ingetrokken

    Beschrijving: er was een probleem bij de verwerking van vaste links in de sandbox. Dit probleem is verholpen door een verbeterde versterking voor de sandbox voor apps.

    CVE-ID

    CVE-2015-7001: Razvan Deaconescu en Mihai Bucicoiu van de universiteit POLITEHNICA in Boekarest; Luke Deshotels en William Enck van North Carolina State University; Lucas Vincenzo Davi en Ahmad-Reza Sadeghi van TU Darmstadt

  • CFNetwork HTTP-protocol

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: een aanvaller in een geprivilegieerde netwerkpositie kan mogelijk HSTS omzeilen

    Beschrijving: er was een probleem met invoervalidatie bij de verwerking van URL's. Dit probleem is verholpen door een verbeterde validatie van URL's.

    CVE-ID

    CVE-2015-7094: Tsubasa Iinuma (@llamakko_cafe) van Gehirn Inc. en Muneaki Nishimura (nishimunea)

  • Comprimeren

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: het bezoeken van een kwaadwillig vervaardigde website kan leiden tot het uitvoeren van willekeurige code

    Beschrijving: er was een probleem met niet-geïnitialiseerde geheugentoegang in zlib. Dit probleem is verholpen door een verbeterde geheugeninitialisatie en aanvullende validatie voor zlib-streams.

    CVE-ID

    CVE-2015-7054: j00ru

  • CoreGraphics

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: het verwerken van een kwaadwillig vervaardigd lettertypebestand kan leiden tot het uitvoeren van willekeurige code

    Beschrijving: er was een probleem met geheugenbeschadiging bij de verwerking van lettertypebestanden. Dit probleem is verholpen door een verbeterde invoervalidatie.

    CVE-ID

    CVE-2015-7105: John Villamil (@day6reak), Yahoo Pentest Team

  • CoreMedia afspelen

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: het bezoeken van een kwaadwillig vervaardigde website kan leiden tot het uitvoeren van willekeurige code

    Beschrijving: er waren meerdere problemen met geheugenbeschadiging bij de verwerking van slecht gevormde mediabestanden. Deze problemen zijn verholpen door een verbeterde verwerking van het geheugen.

    CVE-ID

    CVE-2015-7074: Apple

    CVE-2015-7075

  • dyld

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: een kwaadaardig programma kan willekeurige code uitvoeren met systeembevoegdheden

    Beschrijving: er waren meerdere problemen met segmentvalidatie in dyld. Deze zijn verholpen door verbeterde opschoning van de omgeving.

    CVE-ID

    CVE-2015-7072: Apple

    CVE-2015-7079: PanguTeam

  • GPUTools Framework

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: een kwaadaardig programma kan willekeurige code uitvoeren met systeembevoegdheden

    Beschrijving: er waren meerdere problemen met padvalidatie in Mobile Replayer. Deze zijn verholpen door verbeterde opschoning van de omgeving.

    CVE-ID

    CVE-2015-7069: Luca Todesco (@qwertyoruiop)

    CVE-2015-7070: Luca Todesco (@qwertyoruiop)

  • iBooks

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: het parseren van een kwaadwillig vervaardigd iBooks-bestand kan leiden tot het vrijgeven van gebruikersgegevens

    Beschrijving: er was een 'XML External Entity'-referentieprobleem bij het parseren van iBooks-bestanden. Dit probleem is verholpen door een verbeterde parsering.

    CVE-ID

    CVE-2015-7081: Behrouz Sadeghipour (@Nahamsec) en Patrik Fehrenbach (@ITSecurityguard)

  • ImageIO

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: het verwerken van een kwaadwillig vervaardigde afbeelding kan leiden tot het uitvoeren van willekeurige code

    Beschrijving: er was een probleem met geheugenbeschadiging in ImageIO. Dit probleem is verholpen door een verbeterde verwerking van het geheugen.

    CVE-ID

    CVE-2015-7053: Apple

  • IOHIDFamily

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: een kwaadaardig programma kan willekeurige code uitvoeren met systeembevoegdheden

    Beschrijving: er waren meerdere problemen met geheugenbeschadiging in de IOHIDFamily-API. Deze problemen zijn verholpen door een verbeterde verwerking van het geheugen.

    CVE-ID

    CVE-2015-7111: beist en ABH van BoB

    CVE-2015-7112: Ian Beer van Google Project Zero

  • IOKit SCSI

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: een schadelijk programma kan willekeurige code uitvoeren met kernelbevoegdheden

    Beschrijving: er was een null pointer-dereferentie bij de verwerking van een bepaald userclient-type. Dit probleem is verholpen door een verbeterde validatie.

    CVE-ID

    CVE-2015-7068: Ian Beer van Google Project Zero

  • Kernel

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: een lokaal programma kan een denial of service veroorzaken

    Beschrijving: meerdere problemen met betrekking tot denial of service zijn verholpen door een verbeterde verwerking van het geheugen.

    CVE-ID

    CVE-2015-7040: Lufeng Li van het Qihoo 360 Vulcan-team

    CVE-2015-7041: Lufeng Li van het Qihoo 360 Vulcan-team

    CVE-2015-7042: Lufeng Li van het Qihoo 360 Vulcan-team

    CVE-2015-7043: Tarjei Mandt (@kernelpool)

  • Kernel

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: een lokale gebruiker kan willekeurige code uitvoeren met kernelbevoegdheden

    Beschrijving: er waren meerdere problemen met geheugenbeschadiging in de kernel. Deze problemen zijn verholpen door een verbeterde verwerking van het geheugen.

    CVE-ID

    CVE-2015-7083: Ian Beer van Google Project Zero

    CVE-2015-7084: Ian Beer van Google Project Zero

  • Kernel

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: een lokale gebruiker kan willekeurige code uitvoeren met kernelbevoegdheden

    Beschrijving: er was een probleem bij het parseren van Mach-berichten. Dit probleem is verholpen door een verbeterde validatie van Mach-berichten.

    CVE-ID

    CVE-2015-7047: Ian Beer van Google Project Zero

  • LaunchServices

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: een kwaadaardig programma kan willekeurige code uitvoeren met systeembevoegdheden

    Beschrijving: er was een probleem met geheugenbeschadiging tijdens het verwerken van misvormde .plist-bestanden. Dit probleem is verholpen door een verbeterde verwerking van het geheugen.

    CVE-ID

    CVE-2015-7113: Olivier Goguel van de Free Tools Association

  • libarchive

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: het bezoeken van een kwaadwillig vervaardigde website kan leiden tot het uitvoeren van willekeurige code

    Beschrijving: er was een probleem met geheugenbeschadiging tijdens de verwerking van archieven. Dit probleem is verholpen door een verbeterde verwerking van het geheugen.

    CVE-ID

    CVE-2011-2895: @practicalswift

  • libc

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: het verwerken van een kwaadwillig vervaardigd pakket kan leiden tot het uitvoeren van willekeurige code

    Beschrijving: er waren meerdere bufferoverlopen in de Standaard-C-bibliotheek. Deze problemen zijn verholpen door middel van verbeterde controle van de grenzen.

    CVE-ID

    CVE-2015-7038: Brian D. Wells van E. W. Scripps, Narayan Subramanian van Symantec Corporation/Veritas LLC

    CVE-2015-7039: Maksymilian Arciemowicz (CXSECURITY.COM)

    Bijgewerkt op 3 maart 2017

  • libxml2

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: het parseren van een kwaadwillig vervaardigd XML-document kan leiden tot het vrijgeven van gebruikersgegevens

    Beschrijving: er was een probleem met geheugenbeschadiging bij het parseren van XML-bestanden. Dit probleem is verholpen door een verbeterde verwerking van het geheugen.

    CVE-ID

    CVE-2015-7115: Wei Lei and Liu Yang van Nanyang Technological University

    CVE-2015-7116: Wei Lei and Liu Yang van Nanyang Technological University

  • MobileStorageMounter

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: een kwaadaardig programma kan willekeurige code uitvoeren met systeembevoegdheden

    Beschrijving: er was een timingprobleem bij het laden van de vertrouwenscache. Dit probleem is verholpen door de systeemomgeving te valideren voordat de vertrouwenscache wordt geladen.

    CVE-ID

    CVE-2015-7051: PanguTeam

  • OpenGL

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: het bezoeken van een kwaadwillig vervaardigde website kan leiden tot het uitvoeren van willekeurige code

    Beschrijving: er waren meerdere problemen met geheugenbeschadiging in OpenGL. Deze problemen zijn verholpen door een verbeterde verwerking van het geheugen.

    CVE-ID

    CVE-2015-7064: Apple

    CVE-2015-7065: Apple

    CVE-2015-7066: Tongbo Luo en Bo Qu van Palo Alto Networks

  • Foto's

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: een aanvaller kan het reservekopiesysteem gebruiken voor toegang tot beschermde gebieden van het bestandssysteem

    Beschrijving: er was een probleem met de validatie van het pad in Mobile Backup. Dit is verholpen door een verbeterde opschoning van de omgeving.

    CVE-ID

    CVE-2015-7037: PanguTeam

  • QuickLook

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: het openen van een kwaadwillig vervaardigd iWork-bestand kan leiden tot het uitvoeren van willekeurige code

    Beschrijving: er was een probleem met geheugenbeschadiging bij de verwerking van iWork-bestanden. Dit probleem is verholpen door een verbeterde verwerking van het geheugen.

    CVE-ID

    CVE-2015-7107

  • Safari

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: een bezoek aan een kwaadaardige website kan leiden tot vervalsing van de gebruikersinterface

    Beschrijving: een probleem stond mogelijk toe dat een website inhoud met een URL van een andere website weergaf. Dit probleem is verholpen door een verbeterde verwerking van URL's.

    CVE-ID

    CVE-2015-7093: xisigr van Tencent's Xuanwu LAB (www.tencent.com)

  • Sandbox

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: een schadelijk programma met rootbevoegdheden kan de Address Space Layout Randomization van de kernel omzeilen

    Beschrijving: er was een probleem met onvoldoende scheiding van bevoegdheden in xnu. Dit probleem is verholpen door middel van verbeterde identiteitscontroles.

    CVE-ID

    CVE-2015-7046: Apple

  • Beveiliging

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: een externe aanvaller kan het onverwacht beëindigen van het programma of het uitvoeren van willekeurige code veroorzaken

    Beschrijving: er was een probleem met geheugenbeschadiging bij de verwerking van SSL-handshakes. Dit probleem is verholpen door een verbeterde verwerking van het geheugen.

    CVE-ID

    CVE-2015-7073: Benoit Foucher van ZeroC, Inc.

  • Beveiliging

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: een kwaadaardig programma kan mogelijk toegang verkrijgen tot de Sleutelhangeronderdelen van een gebruiker

    Beschrijving: er was een probleem met de validatie van toegangscontrolelijsten voor sleutelhangeronderdelen. Dit probleem is verholpen door verbeterde controles van de toegangscontrolelijsten.

    CVE-ID

    CVE-2015-7058

  • Siri

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: een persoon met fysieke toegang tot een iOS-apparaat kan mogelijk Siri gebruiken om meldingen van inhoud te lezen die zijn ingesteld om niet op het toegangsscherm te worden weergegeven

    Beschrijving: wanneer Siri iets werd gevraagd, werden de beperkingen aan clientzijde niet gecontroleerd door de server. Dit probleem is verholpen door een verbeterde controle van beperkingen.

    CVE-ID

    CVE-2015-7080: Or Safran (www.linkedin.com/profile/view?id=33912591)

  • WebKit

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: het bezoeken van een kwaadwillig vervaardigde website kan leiden tot het uitvoeren van willekeurige code

    Beschrijving: er waren meerdere problemen met geheugenbeschadiging in WebKit. Deze problemen zijn verholpen door een verbeterde verwerking van het geheugen.

    CVE-ID

    CVE-2015-7048: Apple

    CVE-2015-7095: Apple

    CVE-2015-7096: Apple

    CVE-2015-7097: Apple

    CVE-2015-7098: Apple

    CVE-2015-7099: Apple

    CVE-2015-7100: Apple

    CVE-2015-7101: Apple

    CVE-2015-7102: Apple

    CVE-2015-7103: Apple

  • WebKit

    Beschikbaar voor: iPhone 4s en nieuwer, iPod touch (5e generatie) en nieuwer, iPad 2 en nieuwer

    Impact: een bezoek aan een kwaadwillig vervaardigde website kan de browsergeschiedenis van gebruikers openbaar maken

    Beschrijving: er was een probleem met onvoldoende invoervalidatie bij inhoudblokkering. Dit probleem is verholpen door verbeterde parsering van inhoudsuitbreiding.

    CVE-ID

    CVE-2015-7050: Luke Li en Jonathan Metzman

Informatie over producten die niet door Apple zijn gemaakt of externe websites die niet door Apple worden beheerd of getest, wordt verstrekt zonder aanbeveling of goedkeuring. Apple aanvaardt geen aansprakelijkheid wat betreft de keuze, de prestaties of het gebruik van websites of producten van derden. Apple doet geen enkele toezegging met betrekking tot de juistheid of de betrouwbaarheid van websites van derden. Aan het gebruik van internet zijn risico’s verbonden. Neem contact op met de leverancier voor meer informatie. Andere bedrijfs- en productnamen zijn mogelijk handelsmerken van de respectievelijke eigenaars.

Publicatiedatum: