OS X Server v3.0의 보안 콘텐츠에 관하여

OS X Server v3.0의 보안 콘텐츠에 대해 알아봅니다.

이 문서에서는 OS X Server v3.0의 보안 콘텐츠에 대해 설명합니다.

Apple은 고객 보호를 위해 완벽한 조사를 마치고 필요한 패치 또는 출시를 제공할 때까지 보안 문제에 대해 공개하거나, 이야기하거나, 확인하지 않습니다. Apple 제품 보안에 대한 자세한 내용을 알아보려면 Apple 제품 보안 웹 사이트를 참조하십시오.

Apple 제품 보안 PGP 키에 관한 자세한 내용은 Apple 제품 보안 PGP 키 사용 방법을 참조하십시오.

가능한 경우 CVE ID로 취약성에 대한 추가 정보를 참조할 수 있습니다.

다른 보안 업데이트에 대한 자세한 내용은 Apple 보안 업데이트를 참조하십시오.

OS X Server v3.0

  • 프로파일 관리

    대상: OS X Mavericks v10.9 이후

    영향: 원격 공격자가 서비스 거부 공격을 일으킬 수 있습니다.

    설명: JSON Ruby Gem이 입력의 특정 구조를 분석할 때 메모리를 영구적으로 할당합니다. 공격자가 이를 이용해서 서비스 거부 공격을 유발하는 모든 가용 메모리를 사용할 수 있습니다. 이 문제는 JSON 데이터의 추가 검증을 통해 해결되었습니다.

    CVE-ID

    CVE-2013-0269

  • 프로파일 관리

    대상: OS X Mavericks v10.9 이후

    영향: Ruby on Rails에서 여러 문제가 발생합니다.

    설명: Ruby on Rails에서 여러 문제가 발생하며 이 중 가장 심각한 문제로 인해 크로스 사이트 스크립팅가 발생할 수 있습니다. 이러한 문제는 프로파일 관리에서 사용하는 Rails 구현을 버전 2.3.18로 업데이트하여 해결되었습니다.

    CVE-ID

    CVE-2013-1854

    CVE-2013-1855

    CVE-2013-1856

    CVE-2013-1857

  • FreeRADIUS

    대상: OS X Mavericks v10.9 이후

    영향: 원격 공격자가 서비스 거부를 일으키거나 임의 코드를 실행할 수 있습니다.

    설명: TLS 기반 EAP 메서드를 사용 중인 경우 클라이언트 인증서에서 'Not After' 타임스탬프를 분석할 때 FreeRADIUS에 버퍼 오버플로가 있습니다. 이 문제는 FreeRADIUS를 버전 2.2.0으로 업데이트하여 해결되었습니다.

    CVE-ID

    CVE-2012-3547

  • Server App

    대상: OS X Mavericks v10.9 이후

    영향: 서버가 인증 중에 폴백 인증서를 사용할 수 있습니다.

    설명: RADIUS 서비스가 구성된 인증서의 목록에서 잘못된 인증서를 선택하는 로직 문제가 있습니다. 이 문제는 다른 서비스와 동일한 인증서를 사용하여 해결되었습니다.

    CVE-ID

    CVE-2013-5143: Dreyer Network Consultants, Inc.의 Arek Dreyer

Apple이 제조하지 않은 제품에 관한 정보 또는 Apple의 관리 또는 테스트 대상이 아닌 독립적인 웹 사이트는 권장 또는 보증 없이 제공되는 것입니다. Apple은 타사 웹 사이트 또는 제품에 대한 선택, 성능, 사용과 관련하여 발생하는 결과에 대해 책임을 지지 않습니다. Apple은 타사 웹 사이트의 정확성 또는 신뢰도에 대해 어떠한 언급도 하지 않습니다. 인터넷을 사용하는 데는 위험이 따르기 마련입니다. 자세한 내용은 공급업체에 문의하십시오. 기타 회사 및 제품 이름은 각 소유자의 상표일 수 있습니다.

게시일: