iOS 6.1 소프트웨어 업데이트의 보안 내용에 관하여

이 문서에서는 iOS 6.1의 보안 내용에 대해 설명합니다.

Apple은 고객 보호를 위해 완벽한 조사를 마치고 필요한 패치 또는 출시를 제공할 때까지 보안 문제에 대해 공개하거나, 이야기하거나, 확인하지 않습니다. Apple 제품 보안에 대한 자세한 내용을 알아보려면 Apple 제품 보안 웹 사이트를 참조하십시오.

Apple 제품 보안 PGP 키에 대한 자세한 내용은 Apple 제품 보안 PGP 키 사용 방법을 참조하십시오.

가능한 경우 CVE ID로 취약성에 대한 추가 정보를 확인할 수 있습니다.

다른 보안 업데이트에 대해 알아보려면 Apple 보안 업데이트를 참조하십시오.

iOS 6.1

  • ID 서비스

    대상: iPhone 3GS 및 이후 제품, iPod touch (4th generation) 및 이후 제품, iPad 2 및 이후 제품

    영향: 인증서 기반 Apple ID 인증을 사용하는 인증을 건너뛸 수도 있음

    설명: ID 서비스에 있는 문제를 처리하는 중에 오류가 발생했습니다. 사용자의 Apple ID 인증서를 확인하지 못하면 사용자의 Apple ID가 빈 문자열인 것으로 간주됩니다. 여러 사용자가 소유 중인 다중 시스템에서 이 상태로 되는 경우 이 ID 확인을 사용하는 응용 프로그램에서 신뢰를 잘못 확장할 수 있습니다. 이 문제는 빈 문자열 대신에 NULL이 반환되도록 하여 해결되었습니다.

    CVE-ID

    CVE-2013-0963

  • 유니코드용 다국어 구성 요소

    대상: iPhone 3GS 및 이후 제품, iPod touch (4th generation) 및 이후 제품, iPad 2 및 이후 제품

    영향: 악의적으로 제작된 웹 사이트를 방문하는 경우 크로스 사이트 스크립팅 공격을 당할 수 있음

    설명: EUC-JP 인코딩을 처리할 때 정규화 문제가 발생합니다. 이 문제로 인해 EUC-JP가 인코딩된 웹 사이트에서 교차 사이트 스크립팅 공격을 당할 수도 있습니다. 이 문제는 EUC-JP 매핑 테이블을 업데이트하여 해결되었습니다.

    CVE-ID

    CVE-2011-3058: Masato Kinugawa

  • 커널

    대상: iPhone 3GS 및 이후 제품, iPod touch (4th generation) 및 이후 제품, iPad 2 및 이후 제품

    영향: 사용자 모드 과정에서 커널 메모리의 첫 번째 페이지에 접근할 수도 있음

    설명: iOS 커널에는 기능 복사 및 복제를 통과한 길이 및 사용자 모드 포인터가 사용자 모드 과정에서 직접 커널 메모리에 접근하지 못하도록 확인하는 검사 기능이 있습니다. 길이가 한 페이지보다 작은 경우 해당 검사를 사용할 수 없습니다. 이 문제는 복사 및 복제에 대한 인수의 추가 확인을 통해 해결되었습니다.

    CVE-ID

    CVE-2013-0964: Azimuth Security의 Mark Dowd

  • 보안

    대상: iPhone 3GS 및 이후 제품, iPod touch (4th generation) 및 이후 제품, iPad 2 및 이후 제품

    영향: 네트워크에서 특별한 위치에 있는 공격자가 사용자 자격 증명 또는 기타 기밀 정보를 가로챌 수 있음

    설명: 일부 중간 CA 인증서가 TURKTRUST에 의해 잘못 발행되었습니다. 이로 인해 가로채기 공격자가 연결을 재지정하여 사용자 자격 증명 또는 기타 기밀 정보를 가로챌 수 있습니다. 이 문제는 잘못된 SSL 인증서를 허용하지 않아 해결되었습니다.

  • StoreKit

    대상: iPhone 3GS 및 이후 제품, iPod touch (4th generation) 및 이후 제품, iPad 2 및 이후 제품

    영향: 사용자 상호 작용 없이 Mobile Safari에서 JavaScript가 활성화될 수도 있음

    설명: 사용자가 Safari 환경설정에서 JavaScript를 비활성화하면 Smart App Banner가 표시되는 사이트 방문 시 사용자에 대한 경고 없이 JavaScript가 다시 활성화됩니다. 이 문제는 Smart App Banner가 있는 사이트 방문 시 JavaScript를 비활성화하여 해결되었습니다.

    CVE-ID

    CVE-2013-0974: Zarfhome Software Consulting의 Andrew Plotkin, BitCloud의 Ben Madison, Marek Durcek

  • WebKit

    대상: iPhone 3GS 및 이후 제품, iPod touch (4th generation) 및 이후 제품, iPad 2 및 이후 제품

    영향: 악의적으로 제작된 웹 사이트를 방문하면 응용 프로그램이 예기치 않게 종료되거나 임의 코드가 실행될 수 있음

    설명: WebKit에서 여러 가지 메모리 손상 문제가 발생합니다. 이 문제는 향상된 메모리 처리를 통해 해결되었습니다.

    CVE-ID

    CVE-2012-2857: Arthur Gerkis

    CVE-2012-3606: Google Chrome 보안 팀의 Abhishek Arya(Inferno)

    CVE-2012-3607: Google Chrome 보안 팀의 Abhishek Arya(Inferno)

    CVE-2012-3621: Google Chrome 보안 팀의 Skylined

    CVE-2012-3632: Google Chrome 보안 팀의 Abhishek Arya(Inferno)

    CVE-2012-3687: kuzzcc

    CVE-2012-3701: Google Chrome 보안 팀의 Abhishek Arya(Inferno)

    CVE-2013-0948: Google Chrome 보안 팀의 Abhishek Arya(Inferno)

    CVE-2013-0949: Google Chrome 보안 팀의 Abhishek Arya(Inferno)

    CVE-2013-0950: Google Chrome 보안 팀의 Abhishek Arya(Inferno)

    CVE-2013-0951: Apple

    CVE-2013-0952: Google Chrome 보안 팀의 Abhishek Arya(Inferno)

    CVE-2013-0953: Google Chrome 보안 팀의 Abhishek Arya(Inferno)

    CVE-2013-0954: Google의 Dominic Cooney 및 Google Chrome 보안 팀의 Martin Barbella

    CVE-2013-0955: Apple

    CVE-2013-0956: Apple 제품 보안

    CVE-2012-2824: miaubiz

    CVE-2013-0958: Google Chrome 보안 팀의 Abhishek Arya(Inferno)

    CVE-2013-0959: Google Chrome 보안 팀의 Abhishek Arya(Inferno)

    CVE-2013-0968: Aaron Nelson

  • WebKit

    대상: iPhone 3GS 및 이후 제품, iPod touch (4th generation) 및 이후 제품, iPad 2 및 이후 제품

    영향: 악성 웹 사이트에서 콘텐츠를 복사하여 붙여 넣는 경우 교차 사이트 스크립팅 공격을 당할 수도 있음

    설명: 다른 원문에서 붙여 넣은 콘텐츠를 다룰 때 교차 사이트 스크립팅 문제가 발생합니다. 이 문제는 붙여 넣은 콘텐츠의 추가 확인을 통해 해결되었습니다.

    CVE-ID

    CVE-2013-0962: Cure53의 Mario Heiderich

  • WebKit

    대상: iPhone 3GS 및 이후 제품, iPod touch (4th generation) 및 이후 제품, iPad 2 및 이후 제품

    영향: 악의적으로 제작된 웹 사이트를 방문하는 경우 크로스 사이트 스크립팅 공격을 당할 수 있음

    설명: 프레임 요소를 처리할 때 교차 사이트 스크립팅 문제가 발생합니다. 이 문제는 향상된 출처 추적을 통해 해결되었습니다.

    CVE-ID

    CVE-2012-2889: Sergey Glazunov

  • Wi-Fi

    대상: iPhone 3GS, iPhone 4, iPod touch (4th generation), iPad 2

    영향: 동일한 Wi-Fi 네트워크에 있는 원격 공격자가 일시적으로 Wi-Fi를 비활성화할 수도 있음

    설명: Broadcom의 BCM4325와 BCM4329 펌웨어의 802.11i 정보 요소를 처리할 때 범위를 벗어난 읽기 문제가 발생합니다. 이 문제는 802.11i 정보 요소의 추가 확인을 통해 해결되었습니다.

    CVE-ID

    CVE-2012-2619: Core Security의 Andres Blanco 및 Matias Eissler

 

Apple이 제조하지 않은 제품에 관한 정보 또는 Apple의 관리 또는 테스트 대상이 아닌 독립적인 웹 사이트는 권장 또는 보증 없이 제공되는 것입니다. Apple은 타사 웹 사이트 또는 제품에 대한 선택, 성능, 사용과 관련하여 발생하는 결과에 대해 책임을 지지 않습니다. Apple은 타사 웹 사이트의 정확성 또는 신뢰도에 대해 어떠한 언급도 하지 않습니다. 인터넷을 사용하는 데는 위험이 따르기 마련입니다. 자세한 내용은 공급업체에 문의하십시오. 기타 회사 및 제품 이름은 각 소유자의 상표일 수 있습니다.

게시일: