MainStage 3의 문제 해결하기

MainStage 3의 문제를 가려내고 해결하는 방법에 대해 알아봅니다.

문제를 가려내거나 해결할 때까지 아래 권장 사항을 나열된 순서대로 따릅니다. 진행하기 전에 MainStage 응용 프로그램을 백업합니다.

1. MainStage가 최신 버전인지 확인하기

MainStage 3 최신 버전을 사용하고 있는지 확인합니다. Apple 메뉴() > App Store를 선택한 후 도구 막대에서 '업데이트'를 클릭합니다. 업데이트가 있으면 '업데이트' 버튼을 클릭하여 다운로드한 후 설치합니다.

2. 기기 또는 소프트웨어 호환성 확인하기

외부 오디오 인터페이스, MIDI 인터페이스, 저장 장치 시스템 또는 타사 플러그인을 사용 중인 경우 해당 기기 또는 소프트웨어가 MainStage 3 최신 버전과 호환되는지 확인합니다. 지원이 필요한 경우 제조업체에 문의합니다. 업데이트가 있는 경우 제조업체의 지침에 따라 기기 또는 소프트웨어를 업데이트합니다. 

3. 문서 확인하기

MainStage 3 도움말에서 MainStage가 정상적으로 작동하고 있는지 확인합니다. 경고 또는 오류 메시지에 포함된 주요 용어로 도움말을 검색할 수도 있습니다.

4. 내장 오디오를 사용하여 테스트하기

외부 오디오 인터페이스가 호환되지 않거나 오작동하여 MainStage에 문제가 발생하는 경우도 있습니다. 외부 오디오 인터페이스를 사용 중인 경우 해당 인터페이스 대신 Mac의 내장 오디오를 사용해 봅니다.

MainStage에서 내장 오디오를 사용하려면 다음 단계를 따르십시오.

  1. Mac에서 외장 오디오 인터페이스의 플러그를 뽑습니다.
  2. MainStage를 열고 MainStage > Preferences(환경설정) > Audio(오디오)를 선택합니다.
  3. Audio Output(오디오 출력) 팝업 메뉴에서 Built-in Output(내장 출력)을 선택합니다.
  4. Audio Input(오디오 입력) 팝업 메뉴에서 'Built-in Microphone'(내장 마이크) 또는 컴퓨터에 따라 'Built-in Input'(내장 입력)을 선택합니다.
  5. 문제가 있었던 콘서트, 세트, 패치를 사용하여 테스트해 봅니다.

내장 오디오를 사용하여 문제가 해결되었다면 오디오 인터페이스를 업데이트하거나 서비스를 받아야 할 수 있습니다. 지원이 필요한 경우 제조업체에 문의합니다.

5. 새 콘서트 파일 생성하기

콘서트 파일을 사용할 수 없게 되는 경우 MainStage에서 예기치 않은 동작이 발생할 수 있습니다.

새 프로젝트를 생성하고 테스트하려면 다음 단계를 따르십시오.

  1. MainStage를 열고 File(파일) > New(신규)를 선택합니다.
  2. 대화상자의 Audio Input(오디오 입력) 및 Audio Output(오디오 출력) 팝업 메뉴에서 오디오 입력과 출력에 사용할 기기를 선택합니다.
  3. 왼쪽에서 악기 카테고리를 클릭한 후 사용할 템플릿을 선택합니다.
  4. 'Choose'(선택)를 클릭합니다.
  5. 새 콘서트 파일에서 문제가 발생하는지 테스트해 봅니다. 새 콘서트 파일에서 문제가 발생하지 않는다면 문제가 있었던 콘서트 파일이 손상되었을 수 있습니다. 콘서트 파일을 재구성해 볼 수 있습니다.

손상된 콘서트 파일 재구성하기

콘서트 파일을 재구성할 때는 손상된 콘서트 파일에서 레이아웃, 세트, 패치를 내보낸 후 새 콘서트 파일로 가져옵니다.

  1. 문제가 있는 콘서트 파일을 엽니다.
  2. 레이아웃을 내보내려면 'Layout'(레이아웃)을 클릭하고 Layout(레이아웃) 섹션 상단에 있는 기어 아이콘을 클릭한 후 메뉴에서 'Export Layout'(레이아웃 내보내기)을 선택합니다. 레이아웃을 저장할 위치를 선택한 후 'Export'(내보내기)를 클릭합니다.
  3. 세트와 패치를 내보내려면 'Edit'(편집)를 클릭하고 Patch List(패치 목록)를 클릭한 후 command-A 키를 누르거나 Edit(편집) > Select All(전체 선택)을 선택하여 패치 목록의 모든 세트와 패치를 선택합니다. 선택한 세트와 패치를 데스크탑 또는 폴더로 드래그합니다.
  4. 콘서트 파일을 닫습니다.
  5. 아무 템플릿이나 사용하여 새 콘서트 파일을 생성합니다.
  6. 'Layout'(레이아웃)을 클릭하고 command-A 키를 누르거나 Edit(편집) > Select All(전체 선택)을 선택하여 Layout(레이아웃) 섹션의 모든 요소를 선택한 후 delete 키를 눌러서 제거합니다.
  7. 원래 콘서트 파일의 레이아웃을 가져오려면 Layout(레이아웃) 섹션 상단에 있는 기어 아이콘을 클릭한 후 메뉴에서 'Import Layout'(레이아웃 가져오기)을 선택합니다. 레이아웃을 선택한 후 'Import'(가져오기)를 클릭합니다.
  8. 'Edit'(편집)를 클릭하고 Patch List(패치 목록)의 모든 세트와 패치를 선택한 후 delete 키를 눌러서 기존 패치를 모두 제거합니다.
  9. 원래 콘서트 파일의 패치를 Patch List(패치 목록)로 드래그합니다. 세트와 패치를 패치 목록으로 드래그한 후에 순서를 변경해야 할 수도 있습니다.
  10. 새 콘서트 파일에서도 문제가 발생하는지 테스트해 봅니다.

6. 다른 사용자 계정 사용해 보기

7. 환경설정 재설정하기

MainStage 환경설정을 재설정해도 프로젝트 파일, 프리셋, 패치는 영향을 받지 않습니다. 하지만 이전에 적용한 사용자 설정 환경설정은 전부 유실됩니다.

환경설정을 재설정하기 전에 MainStage > Preferences(환경설정)를 선택하고 이전에 적용한 설정을 모두 기록합니다. 이렇게 하면 환경설정을 재설정한 후 환경설정으로 돌아가 사용자 설정을 다시 적용할 수 있습니다. 다양한 환경설정에 대한 자세한 내용은 MainStage 도움말의 Preferences overview(환경설정 개요)를 참조하십시오.

MainStage 환경설정을 재설정하려면 다음 단계를 따르십시오.

  1. MainStage가 열려 있으면 종료합니다.
  2. Finder에서 option 키를 길게 누른 채 이동 > 라이브러리를 선택합니다.
  3. 환경설정 폴더에서 com.apple.mainstage3.plist 파일을 제거합니다.
  4. Mac을 재시동합니다.

Mac이 재시동되면 MainStage를 열고 이전에 겪었던 문제를 재현해 봅니다. 더 이상 문제가 발생하지 않는 경우 MainStage 환경설정을 열고 사용자 설정을 다시 적용합니다.

8. MainStage 다시 설치하기

문제가 계속 발생하는 경우 MainStage를 제거하고 다시 설치합니다. 기존 MainStage 콘서트 파일은 삭제되지 않으며 MainStage를 다시 설치한 후 콘서트 파일을 열 수 있습니다.

  1. Finder에서 이동 > 응용 프로그램을 선택합니다.
  2. MainStage 3를 찾아 휴지통으로 드래그합니다.
  3. App Store에서 MainStage를 다시 설치하거나 백업에서 복원합니다. 백업에서 MainStage 응용 프로그램 사본을 복원할 경우 저장 위치에서 응용 프로그램 폴더로 MainStage를 드래그해도 되고 Time Machine 백업에서 MainStage를 복원해도 됩니다.

Apple이 제조하지 않은 제품에 관한 정보 또는 Apple의 관리 또는 테스트 대상이 아닌 독립적인 웹 사이트는 권장 또는 보증 없이 제공되는 것입니다. Apple은 타사 웹 사이트 또는 제품에 대한 선택, 성능 및 사용과 관련하여 발생하는 결과에 대해 책임을 지지 않습니다. Apple은 타사 웹 사이트의 정확성 또는 신뢰도에 대해 어떠한 언급도 하지 않습니다. 자세한 내용은 해당 업체에 문의하시기 바랍니다.

게시일: