How to remove a project and related media in Final Cut Pro 4

You can remove a Final Cut Pro project, including linked media from the hard drive.

This article has been archived and is no longer updated by Apple.

Warning: This document discusses permanently deleting files from your hard disk. Following these steps will result in the permanent removal of a Final Cut Pro project and related media (even if that media is used in other projects or elsewhere). Only follow these steps once you have finished your work and if you are absolutely certain you want to permanently erase the project and associated media. Read all of the steps involved before performing any of them. These steps will not affect the Final Cut Pro application, other applications, or your Mac OS X system. Apple is not responsible for accidental loss of your media, work, or time.

A typical Final Cut Pro project is a collection of many files, including render files, captured media files, and the project file. Follow these steps to remove them from your hard disk.

Render Files

  1. Open your project in Final Cut Pro.
  2. From the Tools menu, choose Render Manager.
  3. Click to select the checkbox in the Remove column next to the name of the project you wish to remove. Important: Do not select other projects or those projects' render files will be removed as well.
  4. Click OK to delete the render files.



Media Files in the Browser

  1. Click in the Browser window to make it active.
  2. Select everything you want to delete. In many cases you will want to select everything (from the Edit menu, choose Select All).
    Important: If the Browser contains clips, images, audio or anything else that is used in another project, or is used by another application ( a photo that you are also using in a DVD project, for example), do not select those items, as you will not want them to be deleted.
  3. From the Modify menu, choose Make Offline.
  4. Click to select the "Move Them to the Trash" button.
  5. Click OK.
  6. Close your Final Cut Pro project. It is not necessary to save your project at this point, as you will have to recapture all your video anyway if you chose to work on it again in the future.



The Project File
The Final Cut Pro project file is essentially a record of your edits and logging information. This file is typically small and may be archived for future use. If you captured your project's video clips using Log and Capture, you may use the project file to recapture them from tape in the future. If you do not wish to keep your project file, drag it to the Trash after you have quit Final Cut Pro.

Freeing Up Hard Disk Space

  1. After performing the steps above, click the Finder icon in the Dock.
  2. From the Finder menu, choose Empty Trash to delete the items that were moved into the Trash. This will permanently delete the items and will free up the hard disk space they occupied.



For more information about managing Final Cut Pro media, projects and tools, open Final Cut Pro and from the Help menu, choose Final Cut Pro Help. This help is a searchable version of the Final Cut Pro User's Manual.

Published Date: Feb 19, 2012