Mac OS 8.5: Sherlock の特徴

This article has been archived and is no longer updated by Apple.
Sherlock アプリケーションの特徴は?

これまでアップルメニューにありました“ファイル検索”は、Mac OS 8.5 で機能が拡張され、“Sherlock”という名前に変わりました。Sherlock には二つの機能、“内容で検索”と“インターネット検索”が追加されています。加えて、検索条件を設定ファイルに保存することもできるので、それを利用して素早く検索できるようになりました。


ファイル検索 - ファイル検索では、ローカルディスクおよび接続中のファイルサーバのボリュームに対し、ファイル名やその他のファイル属性を用いたファイル検索を行うことができます。

http://til.info.apple.co.jp/050000/058000/til58099j/images/find_file.gif

検索するボリュームを選ぶには“検索範囲”プルダウンメニューを使います。検索するボリュームだけでなく、検索に使うファイル属性の型と検索指定も、それぞれプルダウンメニューを使って選択します。検索オプションを追加するには“条件を詳しく”ボタンをクリックしてください。検索条件を設定後、“検索”ボタンをクリックしてください。検索結果は別のウィンドウに表示されます。検索結果のウィンドウのファイル名をクリックすると、そのファイルのボリューム階層上での位置が、ウィンドウの下側に表示されます。

ファイル名をダブルクリックするとファイルが開きます。ファイルを移動させたりコピーするには、検索結果のウィンドウの中のアイコンをクリック&ドラッグして、ディスクトップ上や、ボリューム、フォルダに移動させてからマウスボタンを放してください。


内容で検索 - Sherlock の“内容で検索”を使うと、ローカルボリュームに置かれたファイルの内容を一つまたは複数のキーワードで検索できます。“内容で検索”は各々のファイルのテキスト内容の語句検索をします。ボリュームの索引を作成してファイルに対する索引づけを行ってしまえば、いちいちファイルを開かなくともファイル内容を検索できるのです。これによって、複数のファイルに対する情報検索が素早く簡単なものになります。

“内容で検索”と“インターネット検索”を利用するには QuickTime 3 が必要です。

“内容で検索”を利用するにはSherlockウィンドウの“内容で検索”タブをクリックします。

http://til.info.apple.co.jp/050000/058000/til58099j/images/find_content.gif

ファイル内容の検索をするには、あらかじめハードディスクボリュームの索引を作成しておかなければいけません。なお、サーバのボリュームに対して索引を作成することはできません。検索ボタンは索引ができるまでの間使えなく(グレー表示)なります。ボリュームに含まれているファイル数によって、索引の作成にはかなりの時間を要する事があります。なお、最適なパフォーマンスとディスクの使用効率を得るために、各ドキュメント内のテキストのうち、先頭から 2000 語だけが索引づけされます。

索引が作成できたら、“内容で検索”ウィンドウ内のファイル内容から検索したい情報のキーワードを入力して、検索ボタンをクリックして下さい。検索結果は適合性の高い順にソートされます。一番上のカラムをクリックして、ファイル名、種類、サイズでソートすることもできます。

検索結果のリストから、内容が似ているファイルを検索するには、はじめにファイルを選択してから“似ているファイルを検索”ボタンをクリックします。あなたが選択したファイルの内容を使って、内容が似ている他のファイルを検索します。

ファイル内容の要約をクリップボードに表示するには、検索結果リストに表示されたファイルの名前を、コントロールキーを押しながらクリックして下さい。表示されたコンテクストメニューから“要約をクリップボードに表示”を選択すると、ファイル内容が要約されて Finder の“クリップボード”ウィンドウに表示されます

注意:クリップボードに要約できるのは、ファイルタイプが TEXT の場合のみです。


インターネット検索 - Sherlock のインターネット検索は、あなたが普段利用している検索エンジン(検索サイト)を使って、素早いインターネット検索を提供します。インターネット検索サイトを追加するには、その(プラグイン)ファイルをシステムフォルダにドロップするだけです。ドロップした検索サイト(プラグイン)ファイルは、自動的に“インターネット検索”フォルダに入ります。

“内容で検索”と“インターネット検索”を利用するには QuickTime 3 が必要です。

この“インターネット検索”機能は、一度に複数の検索サイトに対して検索を行うので、インターネット検索エンジンを使う最も早くて簡単な方法です。 “インターネット検索”を利用するには Sherlock ウィンドウの“インターネット検索”タブをクリックします。

http://til.info.apple.co.jp/050000/058000/til58099j/images/search_internet.gif

インターネット検索を行うには語句フィールドにあなたの知りたい情報のキーワードを入力してください。検索に使うためのインターネット検索エンジン(検索サイト)をチェックボックスで選んで、検索ボタンをクリックします。例えば“PowerBook G3とメモリ”と入力すると、選択されたインターネット検索サイト上でこの語句を検索することになります。検索結果は、適合性の高い順にソートされて表示されます。

検索結果を名前やサイトでソートするには、一番上のカラムをクリックしてください。

リスト表示されたリンク先のページの要約を表示するには名前をクリックします。そのリンク先ページの短い要約が検索結果の下側に表示されます。

ウィンドウの要約表示部でリンク名をクリックすると、お使いの Web ブラウザでリンク先のページを開くことができます。

それぞれの検索サイトで使われている検索エンジンの変更に対処したり、また新しく追加されたサービス機能に追随するために、インターネット検索サイト(プラグイン)ファイルは定期的に更新されています。インターネット検索を行うと、指定した検索サイトに対する検索ファイルが更新されていないかどうかが自動的にチェックされます。更新されている検索ファイルが見つかった場合には、次のようなウィンドウが開かれます。

http://til.info.apple.co.jp/050000/058000/til58099j/images/update_search_site.gif

検索ファイルの更新を行う場合は、“更新”ボタンをクリックします。検索メニューから“検索サイトの更新”を選んで、更新状況を手作業でチェックすることもできます。


検索条件の保存 - “ファイル検索”、“内容で検索”“インターネット検索”で検索条件を設定したら、検索条件をファイルで保存しておけます。このファイルは開かれると自動的に検索をおこないます。検索条件を保存するにはファイルメニューから“検索条件の保存”を選んでください。検索条件を保存するファイル名と場所を入力して“保存”ボタンをクリックします。検索条件はファイルとして保存され、あなたの指定した場所に表示されます。


Sherlock 初期設定 - “初期設定”で Sherlock アプリケーションで使用するオプションを設定できます。編集メニューから“初期設定”を選択してください。

http://til.info.apple.co.jp/050000/058000/til58099j/images/preferences.gif

ファイル検索の状況を表示する - このオプションはファイル検索ウィンドウ内に検索状況を表示します。


索引オプション - “次のラベルの項目を索引対象にしない”を選択すると、そのラベルを使っている全てのフォルダとファイルが、索引づけの対象から除外されます。注意:ハードディスク内の索引づけしたい項目に使っているラベルを、ここで指定しないように十分に確認して下さい。

索引作成中のシステムの応答 - 索引の作成をしている最中にコンピュータをお使いになろうとすると、システムの動作が大変遅くなっていることに気付かれるでしょう。その場合、この設定を“応答を速く”にすれば、システムパフォーマンスが改善されます。

この機能に関するさらに詳しい情報に関しては、Sherlock 上に表示されるヘルプブタンをクリックするかヘルプメニューからヘルプセンターを開いてください。バルーンヘルプも次の項目がどこでサポートされているかという質問に答えられます:ウィンドウに含まれる内容、ウィンドウコントロールとファインダのメニュー項目、コントロールパネルとアプリケーション。
バルーンヘルプに切り替えるには、ヘルプメニューから“バルーン表示”を選択してください。

Published Date: 2008/10/04