AppleShare IP 5.x: Release History

This article contains an historical look at the AppleShare IP 5.x product line and the purpose of each update release.
This article has been archived and is no longer updated by Apple.
AppleShare IP 5.0 - First Retail Release

AppleShare File service over AppleTalk and TCP/IP,

FTP server

Web server

Mail Server for Post Office Protocol (POP) clients over TCP/IP and AppleTalk.

New administration programs for all of the services

Completely rewritten Print Server.

AppleShare Client v3.7

System Requirements for Running AppleShare IP 5.0
  • CPU: Any Apple Power Macintosh computer or Workgroup Server with a PowerPC 601, 604, or 604e microprocessor.
  • RAM: 32 MB of memory with virtual memory turned on; 48 MB with virtual memory turned off.
  • System Software: 7.6 or later with OpenDoc 1.1.2 or later, except for the Workgroup Server 7350 and the Workgroup Server 9650, which require system software 7.6.1
  • Networking Software: Open Transport 1.1.2 or later
System Requirements for Running AppleShare Client 3.7
  • System Software: 7.5.3 or later
  • Networking Software: Open Transport 1.1.2 or later

AppleShare IP 5.0.1

AppleShare IP 5.0.1 provides minor issue fixes which are only applicable to the Japanese language version of the AppleShare IP server software. An updater is not available for an upgrade to 5.0.1. If you are currently using the English version of AppleShare IP 5.0, there is no need to upgrade to AppleShare 5.0.1.

AppleShare IP 5.0.2

Mac OS 8.0 compatibility

AppleShare Client v3.7.2

Web server plug-in support for Web* API 1.1

Ability to configure ARA user information for Web & File User accounts

Full compatibility with At Ease 5.0 and ARA 2 and 3 personal server
software.

AppleShare IP Mail
  • Better behaved with regards to DNS to remove potential delays in mail delivery.
  • Much faster performance for user accounts, deleting large messages, and deleting many small messages.
  • Supports more than one outgoing SMTP connection.
  • There is a new window to check current status of outgoing SMTP connections. Choose the "Show Outgoing SMTP Activity" option from the "Server" menu

Changes to System Requirements for Running AppleShare IP 5.0.2
  • System Software: Mac OS 8.0, which includes Open Transport 1.2 and OpenDoc 1.2.1, is strongly recommended. The minimum requirement is Mac OS 7.6 or later with OpenDoc 1.1.2 or later and Open Transport 1.1.2 or later, except for the Workgroup Server 7350 and the Workgroup Server 9650, which require Mac OS 7.6.1 or later.

Changes to System Requirements for Running AppleShare Client 3.7.2
  • None
*Available as an Updater via AppleShare IP web site. Requires AppleShare IP 5.0 to be currently installed on the computer.

AppleShare IP 5.0.3

Mac OS 8.1 compatibility

Macintosh G3 desktop support

AppleShare IP Web & File
  • A fix for instances where the web server would stop responding when restarting the system under heavy load.
  • A fix for instances where HTTP KeepAlive sessions were not always properly timed-out by the server.

AppleShare IP Mail
  • A fix for an issue where delivery of remote mail was delayed under some circumstances. The length and duration of the delay would depend upon the complexity of your TCP/IP network and the load on the AppleShare IP Mail Server.

AppleShare IP Print
  • A fix for a "network time out" issue. This would cause random print jobs not to print, mostly on non-Apple printers.
  • A fix for an issue where print jobs were sometimes "dropped" on busy servers.
  • Better compatibility with PostScript files generated by applications other than Apple laser printers. This fixes issues with printing from many graphics applications.

Changes to System Requirements for Running AppleShare IP 5.0.3
  • System Software: MacOS 8.0 or later; MacOS 8.1 recommended. Open Transport 1.2.1 or later.

*Requires AppleShare IP 5.0.2 to be currently installed on the computer.
Published Date: Feb 20, 2012