MacのためのKeynote: Keynoteで数学の方程式を追加する

Keynoteで数学の方程式を追加する

数式および方程式をフローティングオブジェクトとしてスライドに追加することができます。方程式を追加するには、Keynoteの方程式ダイアログ内で LaTeX コマンドまたは MathML 要素を使用して方程式を作成してから、その方程式をプレゼンテーションに挿入します。

方程式をテキストボックスや図形に追加して、テキストと一緒にインラインで配置することもできます。

注記:MathType 6.7d」以降(数式を作成するためのアプリケーション)をインストールしている場合は、それを使用できます。MathTypeウインドウで記号をクリックしたり入力したりして方程式を作成します。

LaTeXまたはMathMLで方程式を追加する

  1. 以下のいずれかを実行します:

    • テキストと一緒にインラインで方程式を配置する: テキストボックスまたは図形内に挿入ポイントを置くか、方程式で置き換えるテキストを選択します。

    • 自由に移動できるように方程式を配置する: スライドの外側をクリックして、何も選択されていないことを確認します。

  2. 画面上部の「挿入」メニューで、「挿入」>「方程式」と選択します。

  3. 「MathType」がインストールされている場合は、方程式の作成にKeynoteを使用するかどうかを尋ねるダイアログが表示されます。「Keynoteを使用」をクリックします。

  4. LaTeXコマンドまたはMathML要素を使用してフィールドに方程式を入力します。

    「方程式を編集」ダイアログ。LaTeXを使用して書き込まれた二次方程式の解の公式が「方程式を編集」フィールドに、公式のプレビューがその下に表示されています。

    サポートされるLaTeXコマンドまたはMathML要素および属性については、Appleのサポート記事「PagesおよびiBooks AuthorでのLaTeXとMathMLの対応について」を参照してください。

  5. 「挿入」をクリックします。

  6. 方程式をドラッグして、スライド上での位置を調整します。

「MathType」を使って方程式を追加する

MathType 6.7d以降をインストールしている場合は、方程式をプレゼンテーション内に追加するために使用できます。

ヒント:「MathType」をデフォルトの方程式エディタに設定する場合は、画面上部の「Keynote」メニューで「Keynote」>「環境設定」と選択し、「一般」をクリックしてから、「MathTypeを使って方程式を挿入」を選択します。

  1. 以下のいずれかを実行します:

    • テキストと一緒にインラインで方程式を配置する: テキストボックスまたは図形内に挿入ポイントを置くか、方程式で置き換えるテキストを選択します。

    • 自由に移動できるように方程式を配置する: スライドの外側をクリックして、何も選択されていないことを確認します。

  2. 画面上部の「挿入」メニューで、「挿入」>「方程式」と選択します。

    「MathType」がデフォルトの方程式エディタに設定されている場合、最初に方程式を入力した後は「MathType」が自動的に開きます。そうでない場合は、表示されるダイアログで「MathTypeを使用」をクリックします。

  3. 方程式を入力するには、MathTypeウインドウ内で記号をクリックしたり入力したりします。

    MathTypeツールの使用方法について詳しくは、「MathType」のヘルプを参照してください。

  4. 方程式を保存するには、画面上部の「ファイル」メニューで「ファイル」>「閉じてからKeynoteに戻る」と選択してから、表示されるダイアログで「はい」をクリックします。

  5. 方程式をドラッグして、スライド上での位置を調整します。

方程式を編集するには、方程式をダブルクリックしてMathTypeウインドウを開きます。

LaTeXまたはMathMLで方程式を編集する/削除する/移動する

方程式を追加した後で変更することができます。

  • 方程式を編集する: 方程式をダブルクリックし、変更を加えてから「アップデート」をクリックします。

  • 方程式を移動する: 方程式をクリックし、中央からスライド上またはテキスト内の新しい場所へドラッグします。

  • 方程式のサイズおよびカラーを変更する: 方程式をクリックしてから、右側のサイドバーのコントロールを使用して方程式のフォントサイズ、カラー、または配置を変更します。サイドバーが表示されない場合は、ツールバー「フォーマット」ラジオボタン をクリックします。方程式の周りにある白いハンドルをクリックしてドラッグすることでサイズを変更することもできます。

  • 方程式をコピーする: 方程式をクリックし、画面上部の「編集」メニューで「編集」>「コピー」と選択してから、「編集」>「ペースト」と選択します。コピーをドラッグして、スライド上の新しい位置に移動します。

  • 方程式を削除する: 方程式をクリックしてから、キーボードのDeleteキーを押します。

  • テキストと一緒にインラインでフローティング方程式を移動する: スライド上の方程式をカットして、テキストボックスまたは図形内にペーストします。詳しくは、「テキストボックスまたは図形内にオブジェクトを配置する」を参照してください。

公開日: 2019/07/03
役に立ちましたか?