用于 Mac 的Pages: 在 Pages 文稿中添加数学方程

在 Pages 文稿中添加数学方程

您可以将数学表达式和方程包括在文稿中。若要添加方程,请使用 LaTeX 命令或 MathML 元素在 Pages 文稿的方程对话框中编写方程,然后将其插入到文稿中。

文字处理文稿中添加方程时,您可以选取将其与文本内联放置,这样方程与文本位于同一行,在您键入时随文本移动;或者将其作为浮动对象放在页面上,这样可将其放在任意位置。在页面布局文稿中,新方程始终作为浮动对象添加在页面上。

在文字处理文稿或页面布局文稿中,您可以在文本框或形状内添加与文本内联的方程。

【注】如果安装了 MathType 6.7d 或更高版本(用于编写数学表达式的应用程序),则可用它来创建方程,方法是在 MathType 窗口中点按符号并键入。

使用 LaTeX 或 MathML 添加方程

  1. 执行以下一项操作:

    • 放置与文本内联的方程:将插入点放在某些文本、文本框、形状或表格单元格中,或者选择想要用方程替换的文本。

    • 放置可自由移动的方程:点按文稿外部以确保未选中任何内容。

  2. 点按工具栏中的 “插入”菜单按钮,然后选取“方程”。

    您也可以选取“插入”>“方程”(从屏幕顶部的“插入”菜单中)。

  3. 如果安装了 MathType,则会出现一个对话框,询问您是否要使用 Pages 文稿创建方程。请点按“使用 Pages 文稿”。

  4. 使用 LaTeX 命令或 MathML 元素在栏中输入方程。

    “编辑方程”对话框,显示“编辑方程”栏中使用 LaTeX 所写的二次公式,且下方显示公式的预览。

    有关使用支持的 LaTeX 命令或 MathML 元素和属性的信息,请参阅 Apple 支持文章:关于 LaTeX 和 MathML 支持

  5. 点按“插入”。

    如果添加了内联方程,它显示在文稿中的插入点处,与周围文本的大小和颜色相同。如果更改周围文本的大小和颜色,方程的大小和颜色也会发生更改。

    如果在页面上添加了方程,它显示在屏幕中间,其大小和颜色为默认设置,您可以在“格式” 边栏中进行更改。拖移方程以调整其在页面上的位置。

使用 MathType 添加方程

如果您有 MathType 6.7d 或更高版本,则可用它来将方程添加到文稿中。

【提示】若要将 MathType 设为默认的方程编辑器,请选取“Pages 文稿”>“偏好设置”(从屏幕顶部的“Pages 文稿”菜单中),点按“通用”,然后选择“使用 MathType 插入方程”旁边的复选框。

  1. 执行以下一项操作:

    • 放置与文本内联的方程:将插入点放在某些文本、文本框、形状或表格单元格中,或者选择想要用方程替换的文本。

    • 放置可自由移动的方程:点按文稿外部以确保未选中任何内容。

  2. 点按工具栏中的 “插入”菜单按钮,然后选取“方程”。

    如果将 MathType 设为默认的方程编辑器,则 MathType 会自动打开(在您第一次输入方程后)。否则,请在出现的对话框中点按“使用 MathType”。

  3. 若要输入方程,请在 MathType 窗口中点按符号并键入。

    有关使用 MathType 工具的说明,请参阅“MathType 帮助”。

  4. 若要存储方程,请选取“文件”>“关闭并返回到 Pages 文稿”(从屏幕顶部的“文件”菜单中),然后在出现的对话框中点按“是”。

    如果添加了内联方程,它显示在插入点处,与周围文本的大小和颜色相同。若要编辑方程,请连按方程以打开 MathType 窗口。

    如果在页面上添加了方程,它显示在屏幕中间,可拖移到页面上的新位置。若要更改方程的外观或编辑方程,请连按方程以在 MathType 中打开它,然后连按窗口底部的控制。

  5. 拖移方程以调整其在页面上的位置。

使用 LaTeX 或 MathML 编辑、删除或移动内联方程

添加与文本内联的方程后,您可以修改它。

  • 编辑方程:连按方程,进行更改,然后点按“更新”。

  • 在文本流内移动方程:选择方程,然后将其拖到正文文本、页眉、页脚或脚注中的新位置。您还可以将其拖到其他文本框或形状中。

  • 更改方程的大小、颜色或对齐方式:点按方程,然后使用“格式” 边栏中“文本”标签中的控制来更改方程的字体大小、颜色或对齐方式。

  • 拷贝方程:点按方程,选取“编辑”>“拷贝”(从屏幕顶部的“编辑”菜单中),将插入点放在想要将方程粘贴到的位置(表格单元格或者页眉或页脚中),然后选取“编辑”>“粘贴”。您还可以选择页面上的对象(如形状),然后选取“编辑”>“粘贴”以将方程作为自由浮动对象粘贴到页面上。

  • 删除方程:点按方程,然后按下键盘上的 Delete 键。

  • 将内联方程移到页面上(文本流外部):在文字处理文稿中,选择方程,然后在“排列”边栏中,点按“文本绕排”弹出式菜单并选取一个“内联(带文本)”以外的选项。有关更多信息,请参阅围绕对象绕排文本

    在页面布局文稿中,选择方程,选取“编辑”>“剪切”(或“拷贝),然后选取“编辑”>“粘贴”。将方程拖到页面上想要的位置。

使用 LaTeX 或 MathML 编辑、删除或移动浮动方程

将浮动方程添加到页面后,您可以修改它。

  • 编辑方程:连按方程,进行更改,然后点按“更新”。

  • 移动方程:将方程拖移到页面上的其他位置。

  • 更改方程的大小、颜色或对齐方式:点按方程,然后使用边栏中的控制来更改字体大小和颜色。您还可以拖移方程上的控制柄来更改其字体大小。

  • 拷贝方程:点按方程,选取“编辑”>“拷贝”,滚动到要放置方程的页面,然后选取“编辑”>“粘贴”。您还可以将插入点放在表格单元格或者页眉或页脚中,然后选取“编辑”>“粘贴”以将方程粘贴为内联对象。

  • 删除方程:点按方程,然后按下键盘上的 Delete 键。

  • 移动与文本内联的浮动方程:在文字处理文稿中,选择方程,然后在“排列”边栏中,点按“随文本移动”按钮。点按“文本绕排”弹出式菜单,然后选取“内联(带文本)”。将方程拖移到其最终位置。

    在页面布局文稿中,将浮动方程剪切并粘贴到文本框或形状中。有关更多信息,请参阅在文本框或形状中放置与文本内联的对象

另请参阅
发布日期: 2019年8月16日
有帮助?