Logic Pro X: ピアノ・ロール・エディタの概要

ピアノ・ロール・エディタの概要

ピアノ・ロール・エディタには、MIDIリージョンのノートが色付きの横棒として時間軸上に表示されます。横線は時間位置、縦線はピッチを表します。ピアノ・ロール・エディタの左端に表示されているキーボードは、ノートのピッチを示します。ピアノ・ロール・エディタのメニューバーの情報ディスプレイには、ポインタ位置のノート名と時間位置が表示されます。

キーボードを適応表示に切り替えることができます。選択したMIDIリージョンに基づいて最適なピアノロール表示が自動的に選択されます。表示されているすべてのMIDIリージョンがノート名を提供する音源で再生される場合、キーボードはそれらのノート名を示す表に置き換わります。「折りたたみモード」表示に切り替えることもできます。ピアノ・ロール・エディタのレーンのうち、選択したMIDIリージョンのノートが使用するレーンのみが表示されます。

ピアノ・ロール・エディタでは、フォルダ内のトラック上のMIDIリージョン、またはプロジェクト内の複数のトラック上のMIDIリージョンを表示できます。ピアノ・ロール・エディタで複数のMIDIリージョンを表示するを参照してください。

図。ピアノ・ロール・エディタ。MIDIノートイベントを指しています。

ピアノ・ロール・エディタはメインウインドウの中のパネルとして開くことも、サイズを変更できる別ウインドウとして開くこともできます。

ピアノ・ロール・エディタを開く

以下のいずれかの操作を行います:

  • ソフトウェア音源(または外部MIDI音源)トラックまたはMIDIリージョンを選択し、「エディタ」ボタン をクリックします。

  • ソフトウェア音源(または外部MIDI音源)トラックまたはMIDIリージョンを選択し、「表示」>「エディタを表示」と選択します。

  • MIDIリージョンをダブルクリックします(「Logic Pro」>「環境設定」>「一般」>「編集」>「MIDIリージョンのダブルクリック時の表示対象」ポップアップメニューで「ピアノロール」が選択されている場合)。

    ピアノ・ロール・エディタはトラック領域の下に開きます。左側には、MIDIリージョンのタイミングとピッチのクオンタイズ、ピッチの調整、MIDIノートのベロシティの編集に使用するコントロールが表示されます。ピアノ・ロール・エディタの上部には、時間区分を示すルーラと、ローカルメニュー、ツール、およびその他のコントロールのあるメニューバーがあります。ヘッダには選択したリージョンの名前が表示されます(複数のリージョンが選択されている場合はリージョンの数が表示されます)。

ピアノ・ロール・エディタを適応表示に切り替える

  • ピアノ・ロール・エディタのメニューバーで「表示」>「ドラム名」と選択します。

ピアノ・ロール・エディタを「折りたたみモード」表示に切り替える

  • ピアノ・ロール・エディタのメニューバーで「折りたたみモード」ボタンをクリックします。

    図。ピアノ・ロール・エディタ。「折りたたみモード」ボタンを指しています。

ピアノ・ロール・エディタを別のウインドウで開く

以下のいずれかの操作を行います:

  • 「ウインドウ」>「ピアノロールを開く」と選択します(またはCommand+4キーを押します)。

  • ピアノ・ロール・エディタのタイトルをメインウインドウの外へドラッグします。

ピアノ・ロール・エディタを縦方向にサイズ変更する

  • エディタ上部のバーにポインタを置き、上にドラッグします。

    下にドラッグすると、再びエディタが縮小します。

ピアノ・ロール・エディタのローカルインスペクタを隠す/表示する

  • ピアノ・ロール・エディタのインスペクタを隠すには: ピアノ・ロール・エディタの「表示」メニューで「ローカルインスペクタを隠す」を選択します。

  • ピアノ・ロール・エディタのインスペクタを表示するには: ピアノ・ロール・エディタの「表示」メニューで「ローカルインスペクタを表示」を選択します。

ピアノ・ロール・エディタのリンクモードを設定する

ピアノ・ロール・エディタの「コンテンツ」リンクを有効にすると、選択中のMIDIリージョンのコンテンツが常に表示されます。ピアノ・ロール・エディタでは「同じレベル」リンクモードを利用できません。

  • リンクモードを「コンテンツ」に設定するには: ピアノ・ロール・エディタのメニューバーにある「リンク」ボタンをクリックします。

  • リンクモードを「オフ」に設定するには: ピアノ・ロール・エディタのメニューバーにある「リンク」ボタンを再度クリックします。

リンクモードの使いかたについて詳しくは、リンクモードを使ってウインドウの関係を制御するを参照してください。

ピアノ・ロール・エディタの背景を変更する

デフォルトでは、ピアノ・ロール・エディタは暗い背景の上に音符を表示します。より明るい背景にしたい場合は「表示」環境設定で背景を変更できます。

  1. 「Logic Pro X」>「環境設定」>「表示」と選択します。

  2. 「エディタ」をクリックし、「ピアノロール」を選択してから、「明るい背景」チェックボックスを選択します。

ピアノ・ロール・エディタを閉じる

  • 「エディタ」ボタン をクリックします。

公開日: 2019/09/13
役に立ちましたか?