Logic Pro X: Piano Roll Editor overview

Piano Roll Editor overview

The Piano Roll Editor shows the notes in a MIDI region as colored bars in a time grid. Horizontal lines show the time position, while vertical lines indicate pitch. A keyboard along the left edge of the Piano Roll Editor provides a reference for the pitches of notes. The info display in the Piano Roll Editor menu bar shows the note name and time position under the pointer.

You can switch the keyboard to an adaptive view, which automatically selects the best Piano Roll display based on MIDI region selection. In the case that all displayed MIDI regions are played back by an instrument that provides note names, the keyboard is replaced by a table showing those note names. You can also switch to Collapse Mode view, which only shows those lanes in the Piano Roll Editor that are used by notes in selected MIDI regions.

The Piano Roll Editor can display the MIDI regions on a track, in a folder, or on multiple tracks in the project. See View multiple MIDI regions in the Piano Roll Editor.

Figure. Piano Roll Editor, pointing out MIDI note event.

You can open the Piano Roll Editor as a pane in the main window, or as a separate, resizable window.

Open the Piano Roll Editor

Do one of the following:

  • Select a software instrument (or external MIDI instrument) track or a MIDI region, then click the Editors button .

  • Select a software instrument (or external MIDI instrument) track or a MIDI region, then choose View > Show Editors.

  • Double-click a MIDI region (if Piano Roll is chosen from the Logic Pro > Preferences > General > Editing > Double-Clicking a MIDI Region Opens pop-up menu).

    The Piano Roll Editor opens below the Tracks area. On the left are controls for quantizing the timing and pitch of MIDI regions, adjusting their pitch, and editing the velocity of MIDI notes. Along the top of the Piano Roll Editor is a ruler showing time divisions, and a menu bar with local menus, tools, and other controls. The header shows the name of the selected region (or the number of regions, if more than one is selected).

Switch the Piano Roll Editor to an adaptive view

  • Choose View > Drum Names in the Piano Roll Editor menu bar.

Switch the Piano Roll Editor to Collapse Mode view

  • Click the Collapse Mode button in the Piano Roll Editor menu bar.

    Figure. Piano Roll Editor, pointing out Collapse Mode button.

Open the Piano Roll Editor as a separate window

Do one of the following:

  • Choose Window > Open Piano Roll (or press Command-4).

  • Drag the Piano Roll Editor by its title out of the main window.

Vertically resize the Piano Roll Editor

  • Place the pointer in the bar at the top of the editor, then drag upward.

    Drag downward to make the editor smaller again.

Hide or show the local Piano Roll Editor inspector

  • To hide the Piano Roll Editor inspector: Choose Hide Local Inspector from the Piano Roll Editor View menu.

  • To show the Piano Roll Editor inspector: Choose Show Local inspector from the Piano Roll Editor View menu.

Set the Link mode for the Piano Roll Editor

You can turn on Content Link for the Piano Roll Editor, so that it always displays the contents of the currently selected MIDI region. Same Level Link is not available for the Piano Roll Editor.

  • To set the Link mode to Content: Click the Link button in the Piano Roll Editor menu bar.

  • To set the Link mode to Off: Click the Link button in the Piano Roll Editor menu bar again.

For more information about using Link modes, see Control window relationships using Link mode.

Change the background for the Piano Roll Editor

By default, the Piano Roll Editor shows notes on a dark background. You can change the background in Display preferences if you prefer a lighter background.

  1. Choose Logic Pro X > Preferences > Display.

  2. Click Editors, then select the Piano Roll: Bright background checkbox.

Close the Piano Roll Editor

  • Click the Editors button .

Published Date: Aug 9, 2019
Helpful?