MacのためのPages: Pages で別の言語でテキストを入力する

Pages で別の言語でテキストを入力する

キーボードやその他の入力デバイスを使用して、ほかの言語のテキストを入力できます。書類内で別の言語を使用するには、最初に言語の入力ソース(言語固有のキーボードや文字パレットなど)を設定する必要があります。

「Pages」では双方向テキストもサポートされるため、同じ書類内で左から右(英語や中国語など)および右から左(アラビア語やヘブライ語など)に記述されるテキストを入力および編集できます。段落、図形、および表の中でも双方向テキストを使用できます。

注記:任意の Pages テンプレートを使用して双方向の書類を作成できますが、別の言語用に特別にデザインされたテンプレートを表示するには、コンピュータの主要言語をその言語に設定する必要があります(「システム環境設定」の「言語と地域」をクリックしてから、言語を設定します)。新しい書類を作成するときには、設定された言語でテンプレートが表示されます。

ほかの言語のキーボードやその他の入力ソースを設定する

書類内で別の言語を使用するには、最初に言語の入力ソース(言語固有のキーボードや文字パレットなど)を設定します。

  1. Mac で「システム環境設定」を開いて、「キーボード」をクリックしてから、「入力ソース」をクリックします。

    「システム環境設定」は、画面左上隅のアップルメニューにあります。

  2. 左の列の下部にある 「追加」ボタン をクリックし、使用可能にしたいキーボードを選択してから、「追加」をクリックします。

  3. 「メニューバーに入力メニューを表示」の横のチェックボックスを選択します。

    入力ソースについて詳しくは、画面上部のメニューで「ヘルプ」をクリックしてから、「入力ソース」を検索してください。

  4. 「Pages」が開いている場合は、「Pages」を再起動して、ソースが認識されるようにします。

  5. もう一方のキーボードに切り替えるには、メニューバーの右側にある入力メニューをクリックしてから、キーボードを選択します。

    メニューバーの右上隅にある入力メニュー。

現在の言語とは異なる方向で記述される言語に切り替えると、挿入ポイントは新しい言語で使われる側に移動します。たとえば、入力ソースを英語からヘブライ語に切り替えると、書類の右側に挿入ポイントが移動します。

異なる言語のフォーマットを使用する書類を作成する

ページ番号および表やグラフ内の日付、時刻、および通貨を、特定の言語と地域で使用されている形式に従って表示する書類を作成できます。これは、別の国にいる人が書類を使用する場合にお勧めします。

書類の言語と地域によって、数値内でカンマとピリオドのどちらを小数点として使用するか、どの通貨記号を使用するか、どのように日付を表示するかなどが決定されます。

異なる言語のフォーマットを使用する書類を作成するには、「システム環境設定」で複数の入力ソース(2 つ目のキーボードなど)を追加する必要があります。詳しくは、ほかの言語のキーボードやその他の入力ソースを設定するを参照してください。

注記:この設定は作成中の書類にのみ反映されます。

  1. 「Pages」を開き、Option キーを押したまま、画面上部の「ファイル」メニューで、「ファイル」>「新規」と選択します。

  2. テンプレートセレクタの左下隅にある「言語」ポップアップメニューをクリックしてから、別の言語を選択します。

  3. 使用したいテンプレートをダブルクリックします。

新しい言語を選択すると、テンプレートのタイトル、テキスト、および一部のフォーマットコントロールにその言語が反映されます。

コンピュータと異なる言語およびフォーマットが使用されている書類を表示すると、使用されているフォーマットを示すメッセージが書類の下部近くに表示されます。フォーマットの違いの例を表示するには、そのメッセージで言語をクリックします。

別の言語と地域の設定を示す通知。その言語と地域のフォーマットの例が表示されています。

書類の言語とフォーマットを変更する

書類を作成した後でも、書類が開いているときにその言語設定を変更できます。この設定によって、ページ番号および表やグラフ内の数値がどのように表示されるかが決まります。たとえば、数値内でカンマとピリオドのどちらを小数点として使用するか、どの通貨記号を使用するか、どのように日付を表示するかなどです。これは、設定を変更している書類にのみ反映されます。

注記:共有書類ではこの設定を変更することはできません。

  1. 画面上部の「ファイル」メニューで、「ファイル」>「詳細」>「言語と地域」と選択します。

  2. 表示されるダイアログで、ポップアップメニューをクリックして言語と地域を選択します。

    「言語」ポップアップメニューで最初の項目(システム - <言語>)を選択すると、コンピュータの言語と地域に書類がリセットされます。これ以降にコンピュータの言語設定を変更したり、異なる言語設定のコンピュータで書類を開いたりした場合は、書類の言語と地域はコンピュータに合わせて自動的に変更されます。ただし、その書類を共有する場合は、すべてのユーザがあなたのコンピュータの言語と地域で書類を閲覧します。

  3. 「OK」をクリックします。

書類の言語と地域を変更した後は、表およびグラフに新規に入力するデータに新しい言語が反映されます。既存の表およびグラフのデータでは、日付の言語(月の名前など)は変更されますが、日付の句読点や日、月、年の順序は変更されません。数値の句読点(小数点、3 桁区切りなど)は変更されます。

段落のテキストの方向を変更する

ルーラおよびタブストップは、常に段落の方向と一致します。つまり選択したテキストのテキストの方向を変更すると、ルーラも変化します。

  1. 段落またはリスト内でクリックするか、段落またはリスト内のテキストを選択します。

  2. 「フォーマット」  サイドバーの上部付近にある「スタイル」ボタンをクリックします。

    テキストがテキストボックス、表、または図形内にある場合は、最初にサイドバーの上部にある「テキスト」タブをクリックしてから、「スタイル」ボタンをクリックします。

  3. 「配置」セクションの 「段落の方向」ボタン をクリックします。

    挿入ポイントが反対側に移動し、段落の方向が変更されます。

    「フォーマット」サイドバーの「配置」セクションに表示されている双方向のボタン。
  4. テキストを入力し、段落の最後で Return キーを押します。

    次の段落も引き続き同じ方向になります。方向を変更するには、「段落の方向」ボタン をクリックします。

テキストの方向が異なる複数の段落を選択して 「段落の方向」ボタン をクリックすると、選択対象の最初の段落に合わせてすべての段落がフォーマットされます。

双方向テキストの入力および編集方法については、デスクトップをクリックして Finder に切り替え、画面上部にある「ヘルプ」から「ヘルプ」>「Mac ヘルプ」と選択して、双方向テキストを検索してください。

公開日: 2018/11/22
役に立ちましたか?