iMovie for Mac: Organize media and events

Organize media and events

If you choose to import video footage into your library, iMovie automatically places the clips into events, based on the date and time the video footage was recorded. Events are like folders that contain your clips. Despite their initial time-based grouping, you can use events to group clips any way you like.

When you select an event in the Libraries list, the clips it contains appear in the browser.

If the Libraries list isn’t shown, click the Libraries List button at the top of the browser.

Event selected in Libraries list

Sort events in the Libraries list

You can customize the Libraries list to display events in the order you choose.

  • Sort events by name: Choose View > Sort Events By > Name.

  • Sort events from newest to oldest: Choose View > Sort Events By > Newest to Oldest.

    When you sort events by date, events in each library are grouped by year.

    Libraries list with events sorted and grouped by year
  • Sort events from oldest to newest: Choose View > Sort Events By > Oldest to Newest.

Create and rename events

  1. In the Libraries list, select the library where you want to create an event.

  2. Choose File > New Event.

    The new event appears in the Libraries list, with its name highlighted.

  3. To rename the event, type a new name.

    Event being renamed in Libraries list

Note: To rename an existing event, select it in the Libraries list, press Return, and type the new name.

Copy or move clips between events

  1. In the Libraries list, select the event that contains the clips you want to move or copy.

  2. In the browser, select the clips you want to move or copy.

    Tip: To select multiple clips, hold down the Command key as you click the clips you want to select, or drag a selection rectangle around the clips.

  3. Do one of the following:

    • Move clips between events: Drag the selected clips from one event to the other.

    • Copy clips between events: Option-drag the selected clips from one event to the other by first starting to drag and then holding down the Option key as you drag.

    Note: If you drag clips from the browser with your project selected below Project Media in the sidebar, the clips are copied to the destination event.

    Project selected below Project Media in sidebar

To move or copy clips from one storage device to another, see Work with multiple libraries.

Duplicate clips

You can duplicate a clip to try out effects or other changes without affecting the original version.

  1. In the Libraries list, select the event that contains the clip you want to duplicate.

  2. Double-click the clip you want to duplicate.

    If you select part of a clip, the entire clip will be duplicated.

    Tip: To select multiple clips, hold down the Command key as you click the clips you want to select, or drag a selection rectangle around the clips.

  3. Choose Edit > Duplicate Movie.

Merge or split events

You can merge (combine) two or more events in the Libraries list (for example, if the footage they contain is very closely related). You can also split a single event into multiple events.

In the Libraries list, do one of the following:

  • Merge events: Select an event and drag it to the event you want to merge it with, or select the events you want to merge and choose File > Merge Events.

    Two events being merged with third event in Libraries list
  • Split a single event: Create the new events you need, and then move clips from the original event to the new events.

Delete clips and events

You can delete unwanted clips from an event, and you can delete an entire event to free up storage space.

Note: To free up storage space, you must delete an entire event. Deleting clips from an event does not free up storage space.

  1. In the Libraries list, do one of the following:

    • Delete an event: Select the event you want to delete.

    • Delete clips in an event: Select the event that contains the clips you want to delete, and then select the clips you want to delete in the browser.

    Tip: To select multiple clips in the same library, hold down the Command key as you click the clips you want to select, or drag a selection rectangle around the clips.

  2. Choose File > Move to Trash.

    If a clip you’re trying to delete is being used in a project, a message appears asking you to remove the clip from the project before deleting the clip.

    Note: Selecting a clip and pressing Delete marks it as rejected. For more information, see Mark clips as favorite or rejected.

Published Date: Jun 12, 2019
Helpful?