Logic Pro X: トランジェントマーカーを使って編集する

トランジェントマーカーを使って編集する

オーディオ・ファイル・エディタでトランジェントマーカーを使って、オーディオファイル内の選択範囲またはファイル全体を編集できます。オーディオファイル内でトランジェントマーカーを追加または移動することもできます。これらの作業はすべてトランジェント編集モードで行います。

注記:トランジェント編集モードで作業するときは、Command+クリックツールのデフォルト値が、移動ツールから鉛筆ツールに変わります。

トランジェント編集モードを有効にする

以下のいずれかの操作を行います:

  • オーディオ・ファイル・エディタのメニューバーで「表示」>「トランジェント編集モード」と選択します(または「トランジェント編集モードを切り替える」キーコマンドを使います)。

  • オーディオ・ファイル・エディタの「トランジェント編集モード」ボタンをクリックします。

    図。サンプルエディタの「トランジェント編集モード」ボタン。

トランジェント編集モードを有効にすると、オーディオファイルが分析されてトランジェントイベントが調べられ、検出されたすべてのトランジェントにマークが付けられます。

図。サンプルエディタに表示されたオーディオリージョン。トランジェントが検出されていない状態と検出された状態。

トランジェント検出の信頼度は、トランジェントの明確さによって決まります。オーディオファイルに不明確なトランジェントしか含まれていない場合は、低い信頼度でトランジェントが検出されます。プラス(+)ボタンとマイナス(-)ボタンを使って、表示されるトランジェントの数を調整できます。

図。サンプルエディタのプラスボタンとマイナスボタン。
  • プラス(+)ボタン: オーディオファイル内の選択範囲またはオーディオファイル全体でトランジェントの数を増やします。「トランジェントの数を増やす」キーコマンドを使うこともできます。デフォルトの割り当てはCommand+プラス(+)キーです。

  • マイナス(-)ボタン: オーディオファイル内の選択範囲またはオーディオファイル全体でトランジェントの数を減らします。「トランジェントの数を減らす」キーコマンドを使うこともできます。デフォルトの割り当てはCommand+マイナス(-)キーです。

オーディオファイル内にトランジェントマーカーを作成する

  • 鉛筆ツールで波形ディスプレイをクリックします。

    図。サンプルエディタの波形ディスプレイに表示された鉛筆ツール。

クリック位置の周辺のオーディオ素材に対してトランジェント検出処理が開始され、最もエネルギーの大きいトランジェントが有効になってマークされます。検出範囲内にトランジェントが見つからなかった場合は、クリック位置にトランジェントマーカーが作成されます。

オーディオファイル内でトランジェントマーカーを移動する

  • 既存のトランジェントマーカーを別の位置にドラッグします。

    図。サンプルエディタの波形ディスプレイでトランジェントがドラッグされている。

    注記:「編集」メニューで「編集内容をゼロクロッシングにスナップ」が選択されている場合は、新しい位置がゼロクロッシングにスナップされます。「編集内容をゼロクロッシングにスナップ」は、Controlキーを押しながらクリックして、ショートカットメニューから選択することもできます。

オーディオファイルからトランジェントマーカーを削除する

以下のいずれかの操作を行います:

  • ポインタツールまたは鉛筆ツールで、個々のマーカーをダブルクリックします。

  • 消しゴムツールで、個々のマーカーをクリックします。

  • 消しゴムツールで、複数のマーカーの上をドラッグします。

  • オーディオファイルで範囲を選択し、Deleteキーを押します。

選択範囲内にあるすべてのトランジェントマーカーが削除されます。

注記:トランジェントマーカーは、実際には削除されません。表示のしきい値が最大値に設定されて、無効になるだけです。プラス(+)ボタンを使うことで、トランジェントマーカーを再度有効にできます。

オーディオファイル内のトランジェントマーカーを検出する

  • オーディオ・ファイル・エディタで、「オーディオファイル」>「トランジェントを検出」と選択します(または、「オーディオファイルのトランジェントを検出」キーコマンドを使います)。

オーディオファイル全体でトランジェントが検出され、手動で追加または編集したトランジェントが上書きされます(適用前に確認メッセージが表示されます)。

注記:付属のオーディオApple Loops内でトランジェントを検出することもできます。この場合、ループのコピーがプロジェクトの「Audio Files」フォルダに保存されます。

Published Date: 2019/09/13
Helpful?