Logic Pro X: Use transient markers to edit

Use transient markers to edit

You can use transient markers to edit selected areas of an audio file, or the entire file, in the Audio File Editor. You can also add or move transient markers within audio files. You do all of these tasks in Transient Editing mode.

Note: When you’re working in Transient Editing mode, the Command-click tool changes its default value, from the Hand tool to the Pencil tool.

Turn on Transient Editing mode

Do one of the following:

  • Choose View > Transient Editing Mode from the Audio File Editor menu bar (or use the Toggle Transient Editing Mode key command).

  • Click the Transient Editing Mode button in the Audio File Editor.

    Figure. Transient Editing Mode button in the Sample Editor.

When you turn on Transient Editing mode, the audio file is analyzed for transient events, and all detected transients are marked in the audio file.

Figure. Audio region in Sample Editor, without transients and with transients.

The level of transient detection confidence is based on the clarity of the transients. If an audio file does not have clear, sharp transients, transients will be detected with a lower level of confidence. You can display more or fewer transients by using the Plus and Minus (+/−) buttons.

Figure. Plus and Minus buttons in the Sample Editor.
  • Plus button (+): Increases the number of transients in the selected area of the audio file, or across the entire audio file. You can also use the Increase Number of Transients key command, default assignment: Command-Plus (+).

  • Minus button (−): Decreases the number of transients in the selected area of the audio file, or across the entire audio file. You can also use the Decrease Number of Transients key command, default assignment: Command-Minus (−).

Create a transient marker in an audio file

  • Click the waveform display with the Pencil tool.

    Figure. Sample Editor with Pencil tool over the waveform display.

A transient detection process is started for the audio material around the clicked position, and the transient with the highest energy becomes valid and is marked. If no transient is found in the catch area, a transient marker is created at the clicked position.

Move a transient marker in an audio file

  • Drag an existing transient marker to another position.

    Figure. Sample Editor with transient being dragged in the waveform display.

    Note: The new position may or may not snap to zero crossings, depending on whether or not Snap Edits to Zero Crossings is chosen in the Edit menu. You can also Control-click to open a shortcut menu and choose Snap Edits to Zero Crossings.

Delete transient markers from an audio file

Do one of the following:

  • Double-click individual markers with the Pointer or Pencil tool.

  • Click individual markers with the Eraser tool.

  • Drag over multiple markers with the Eraser tool.

  • Select an area of the audio file and press the Delete key.

All transient markers in the selected area are deleted.

Note: Transient markers are not actually deleted. Instead, their display threshold is set to maximum, making them invalid. You can revalidate a transient marker using the Plus button (+).

Detect transient markers in an audio file

  • In the Audio File Editor, choose Audio File > Detect Transients (or use the Detect Transients of Audio File key command).

Transients are detected across the audio file, overwriting (after you confirm the action) any manually added or edited transients.

Note: You can also detect transients in factory audio Apple Loops. A copy of the loop is saved in the project’s Audio Files folder.

Published Date: Aug 9, 2018
Helpful?