Logic Pro X: 基本的な選択方法を使う

基本的な選択方法を使う

オーディオ・ファイル・エディタでオーディオの編集や処理を行うには、まず、波形ディスプレイで特定の範囲を選択する必要があります。実行する編集または処理は、選択範囲にのみ影響します。

現在の選択範囲の開始位置と長さは、オーバービューの上の情報表示に表示されます。この情報の形式は、「表示」メニューで選択する設定によって決まります。詳しくは、ルーラの表示を変更するを参照してください。

図。サンプルエディタの情報ディスプレイ。

編集や処理を行うためにオーディオファイル全体またはその一部を選択するときは、以下に説明する基本的な選択方法を使います。

効率的な選択方法については、オーディオ・ファイル・エディタでオーディオファイル内を移動するを参照してください。

オーディオファイル全体を選択する

  • 「編集」>「すべてを選択」と選択します(またはCommand+Aキーを押します)。

オーディオファイルの特定の部分を選択する

  • 波形ディスプレイで選択範囲の開始位置または終了位置をクリックしてホールドし、左または右へドラッグします。

    図。サンプルエディタで、選択範囲の右端にポインタを合わせる。

    選択する際に、開始位置と長さが(サンプルワードとして)ヘルプタグに表示されます。

既存の選択範囲を拡張する

以下のいずれかの操作を行います:

  • 「編集」>「前のものすべてを選択」と選択します(または、対応するキーコマンドを使います)。

  • 「編集」>「後のものすべてを選択」と選択します(または、対応するキーコマンドを使います)。

リージョンを使って選択範囲を定義する

  • ブラウザまたはメインウインドウでリージョンを選択し、「編集」>「リージョン->選択範囲」と選択します。

この機能は、編集をたくさん行った後などに、リージョン全体を再選択して繰り返し再生する場合に便利です。

逆の操作も可能です。既存のリージョンの長さを再定義するには、「編集」>「選択範囲->リージョン」と選択します。

選択範囲の開始位置または終了位置を変更したり、選択範囲をそのまま移動したりすることもできます。

注記:「編集」>「編集内容をゼロクロッシングにスナップ」を選択している場合は、オーディオリージョンの開始位置または終了位置を変更して長さを調整するときに、波形の中で最も近くにあるゼロクロッシングポイントにスナップされます。

既存の選択範囲の開始位置または終了位置を調整する

以下のいずれかの操作を行います:

  • 波形ディスプレイでShiftキーを押しながら、開始位置または終了位置にする新しい位置をクリックします。

  • 波形ディスプレイでShiftキーを押しながら、選択範囲の開始位置または終了位置をクリックしてドラッグします。

どちらの方法でも、クリック位置と選択範囲の開始位置または終了位置との距離によって、開始位置と終了位置のどちらの境界位置を調整するかが決まります。近い方の境界が選択されます。

ヒント:Option+Shiftキーを押しながら操作すると、近い境界位置ではなく、クリック位置から遠い方の境界位置を調整できます。

選択範囲を移動する

選択範囲全体を、長さを変更せずに左右に移動できます。

  1. 以下のいずれかの操作を行います:

    • Optionキーを押したま選択範囲をクリックします。

    • 移動ツールで選択範囲をクリックします。

  2. 左右にドラッグします。

選択した領域を移動すると、ポインタまたは移動ツールが両向き矢印に変わります。

図。オーディオ・ファイル・エディタで、選択範囲の中央に両向き矢印が表示されている。
公開日: 2019/09/13
役に立ちましたか?