Logic Pro X: トラック領域でリージョンを分割する

トラック領域でリージョンを分割する

トラック領域でリージョンを分割し、分割したリージョンの各セグメントをトラック領域内の異なる場所で使うことができます。

MIDIリージョンを分割すると、分割ポイントに位置するノートはポイント以降の部分が切り捨てられます。分割したMIDIリージョンで、あるノートが別のノートに16分音符分を超えて重なっている場合、ノートを保持したいか、短くしたいか、または分割したいかを確認するダイアログが表示されます。

ルーラのマーキーストライプを使ってリージョンの該当箇所を選択することでも、リージョンを分割できます。マーキーストライプを使ってリージョンを選択する方法について詳しくは、トラック領域でリージョンの一部を選択するを参照してください。

再生ヘッド位置でリージョンを分割する

  1. トラック領域で、分割する1つまたは複数のリージョンを選択します。

  2. リージョンを分割する位置に再生ヘッドを移動し、「編集」>「分割」>「リージョンを再生ヘッド位置で」と選択します。

    選択したリージョンが再生ヘッドの位置で2つのリージョンに分割されます。ほかのトラックのリージョンが再生ヘッドの下にあったとしても、分割されるのは選択したリージョンのみです。複数のリージョンが選択されて再生ヘッドの下にある場合は、これらのリージョンがすべて分割されます。

    図。選択したリージョンに再生ヘッドを移動して分割する。

    ヒント:一番近い小節でカットするには、「リージョン/イベントをおおよその再生ヘッド位置で分割」キーコマンドを使います。

ハサミツールでリージョンを分割する

  1. 分割するリージョンを選択します。

  2. ハサミツールを選択して、分割するリージョンをクリックし、ボタンを放さずにそのまま待ちます。

    図。ハサミツールを使ったリージョンの分割。ヘルプタグに分割位置が表示される。

    ヘルプタグに現在の分割位置が表示されます。

  3. マウスボタンを放します。

    選択したリージョンすべてがヘルプタグに表示された位置でカットされます。

ハサミツールでカット位置を指定する場合、前後に動かす手順によって1分割できます。グリッドは「スナップ」ポップアップメニューでの設定に基づいています。

ロケータ位置でリージョンを分割する

  1. 左右のロケータをセットします。

  2. 分割したいリージョンをロケータの範囲内で選択します。

    図。ルーラに設定したロケータ位置で選択されたリージョン。
  3. 「編集」>「分割」>「リージョンをロケータ位置で」と選択します(または「リージョン/イベントをロケータまたはマーキーの選択範囲で分割」キーコマンドを使います)。

    図。トラック領域のロケータ位置で分割されたリージョン。

    ロケータ間で選択したリージョンはすべて、全体であっても一部であっても、左右のロケータ位置でカットされます。分割操作の結果として、ロケータ間に作成されたリージョンが自動的に選択されます。

ヒント:Commandキーを押しながらポインタでルーラ上にサイクルを指定しても同じ結果になります。

マーキーの選択範囲の境界でリージョンを分割する

  1. トラック領域のメニューバーで、「表示」>「マーキールーラ」と選択します。

  2. ルーラの細いマーキーストライプ領域でドラッグし、1つまたは複数のリージョンの一部を選択します(選択したトラックにも表示されます)。

  3. Controlキーを押したままマーキーストライプをクリックして、ショートカットメニューから「リージョン/イベントをロケータまたはマーキーの選択範囲で分割」を選択します。

リージョンを同じ長さに分割する

  • Optionキーを押しながらハサミツールでリージョンをカットします。

    プラスの記号がハサミツールの隣に現れます。

    図。Optionキーを押したままハサミツールでリージョンをカットする。

    選択したリージョンが複数に分割され、それぞれの長さは最初のセグメントと同じになります。

    図。トラック領域でリージョンを複数にカットする。

    たとえば、16小節のリージョンを2小節のリージョン8つに分割するには、小節3の開始地点でOptionキーを押しながらリージョンをカットします。

分割したMIDIリージョンで重なったノートを処理する

分割したMIDIリージョンで、あるノートが別のノートに16分音符分を超えて重なっている場合、ノートを保持したいか、短くしたいか、または分割したいかを確認するダイアログが表示されます。

  • ダイアログで、以下のいずれかの操作を行います:

    • 「保持」をクリックすると、すべてのノートが元のままになります。MIDIリージョンは指定通りにカットされますが、左半分(先行のリージョン)のノートがそれらを含むMIDIリージョンより長くなってしまう可能性もあります。そのようなノートは、「クリップの長さ」が有効になっている場合を除いて、通常通り再生されます。(トラック領域でリージョン再生位置をシフトするを参照してください。)

    • 「短くする」をクリックすると、重なったノートがすべて切り捨てられ(短くなり)、オリジナルのMIDIリージョンが分割されたポイントで終わります。

    • 「分割」をクリックすると、2つのMIDIリージョンにまたがって重なっているノートを分割します。オリジナルと同じピッチとベロシティのノートが2つでき、合計の長さはオリジナルのノートの長さと同じです。

リージョンベースオートメーションが含まれるリージョンを分割すると、分割ポイントにオートメーションポイントが追加されます。リージョンベースオートメーションについて詳しくは、リージョンベースオートメーションとトラックベースオートメーションの違いを参照してください。オートメーションポイントの操作については、オートメーションポイントを追加する/調整するを参照してください。

ツールバーにある「オーディオ」>「無音を削除」機能を使うと、振幅レベルに基づいてオーディオ録音をセグメントに分割できます。詳しくは、「無音を削除」ウインドウで無音部分を削除するを参照してください。

公開日: 2019/09/13
役に立ちましたか?