Logic Pro X: スタンダードMIDIファイル

この記事はアーカイブ済みで、これ以上更新されることはありません。
スタンダードMIDIファイル

スタンダードMIDIファイルとは、固有のシーケンサープログラムやハードウェアシーケンサー、あるいはコンピュータの種類に依存しないMIDIファイルのことです。スタンダードMIDIファイルには以下の情報が含まれています:

  • MIDIイベント(時間位置とチャンネル割り当てを含む)

  • 個々のトラックの名前

  • マーカーの名前と位置

  • テンポチェンジ

  • 著作権マーク

「Logic Pro」ではスタンダードMIDIファイルフォーマット0および1を開いたり、読み込みや書き出しを行ったりできます:

  • フォーマット0では、すべてのデータが1つのトラックに記録されます。

  • フォーマット1では、複数のトラックにそれぞれ独立したデータが記録されます。

どちらのフォーマットも、トラック内の分割を認識することはできません(たとえば複数のMIDIリージョンに分割した場合)。

再生ヘッドの位置にMIDIファイルを読み込む

以下のいずれかの操作を行います:

  • 「ファイル」>「読み込む」>「MIDIファイル」と選択し、表示されるダイアログでファイルを選択します。

  • 「すべてのファイル」ブラウザでMIDIファイルを選択し、「読み込む」をクリックします。

再生ヘッドがある小節の先頭にMIDIファイルが読み込まれます。

ポインタの位置にMIDIファイルを読み込む

  • 「すべてのファイル」ブラウザまたはFinderからトラック領域にMIDIファイルをドラッグします。

マウスボタンを放したときのポインタの位置によって、読み込まれたファイルの最初のトラックの位置(最も近い小節の先頭にスナップされます)と方向が決まります。

MIDIファイルを開く

  1. 「ファイル」>「開く」と選択して(または、対応するキーボードショートカットを使って)、表示されるダイアログでMIDIファイルを選択します。

  2. プロジェクトが読み込まれている場合は、新しい環境を作成するのかMIDIファイルの現在の環境をコピーするのかを確認するダイアログが表示されます。以下のいずれかの操作を行います:

    • 既存の環境を複製するには: 「コピー」をクリックします。MIDIファイルのトラックは、自動的に適切な音源に割り当てられます。

    • デフォルトのプロジェクトテンプレートの環境を読み込むには: 「新規」をクリックします。

すべてのMIDIイベント(時間位置とチャンネル割り当て、個々のトラック名、マーカーの名前と位置、テンポチェンジ、著作権記号など)を含む新規のプロジェクトとしてMIDIファイルが読み込まれます。著作権マークはマーカーテキストとして表示されます。デフォルトでは、「Logic Pro」でMIDIファイルを開くと各MIDIトラックに対してソフトウェア音源トラックが動的に作成され、それぞれに適切なGarageBand音源が割り当てられます。各MIDIトラックに外部MIDIトラックを使用したい場合は、Optionキーを押しながらMIDIファイルを開いてください。

すべてのMIDIリージョンをスタンダードMIDIファイルへの書き出し用に準備する

  1. 「編集」>「すべてを選択」と選択する(またはCommand+Aキーを押す)ことで、すべてのMIDIリージョンを選択します。

  2. Controlキーを押しながらMIDIリージョンをクリックしてから、ショートカットメニューから「MIDI」>「リージョンパラメータをノーマライズ」と選択することで、すべての再生パラメータをノーマライズします。

  3. 「機能」>「MIDIリージョンパラメータ」>「クオンタイズを永続的に適用」と選択することで、すべての再生クオンタイズを変換します。

  4. 「機能」>「リージョンエイリアス」>「エイリアスをコピーに変換」と選択することで、すべてのエイリアスをリアルコピーに変換します。

  5. 「編集」>「結合」>「リージョンをトラックごとに」と選択することで、各トラックのすべてのMIDIリージョンを連続したMIDIリージョンに変換します。

    注記:スタンダードMIDIファイルのタイプ0フォーマットにはMIDIリージョンを1つしか保存できないため、フォーマット0のファイルに書き出す場合はすべてのMIDIリージョンを1つに結合する必要があります。これを行うには、「編集」>「結合」>「リージョン」と選択します。

  6. 「機能」>「音源のMIDI設定をイベントとして挿入」と選択することで、すべての音源MIDI設定をイベントとして挿入します。

MIDIリージョンをスタンダードMIDIファイルとして保存する

  1. 保存したいすべてのMIDIリージョンを選択します。

  2. 「ファイル」>「書き出す」>「選択範囲をMIDIファイルとして」と選択します。

  3. 保存先のフォルダを選択し、ファイル名を入力して「保存」をクリックします。選択したMIDIリージョンがフォーマット1のMIDIファイルとして保存されます。

注記:ハードウェアシーケンサーはMS-DOSフォーマットのディスクしか読み出せないものが多いため、ファイル名の文字数は「8.3」形式(「proj0001.MID」など)に収まるようにしてください。

MIDIリージョンをファイルフォーマット0で保存する

  1. 「Logic Pro」>「環境設定」>「一般」>「プロジェクト処理」パネルで「“MIDIファイルを書き出す...”で1つのMIDIリージョンをフォーマット0で保存」チェックボックスを選択します。

  2. MIDIリージョンを選択してから、「ファイル」>「書き出す」>「選択範囲をMIDIファイルとして」と選択します。

公開日: 2019/09/13
役に立ちましたか?