Logic Pro X: Move, copy, and convert audio files

This article has been archived and is no longer updated by Apple.
Move, copy, and convert audio files

You can move selected audio files to another location on your computer. This is useful when you want to move all audio files used in a project to a new folder, for example.

You can also create copies of audio files on a different hard disk, or other storage medium. The source files remain in their original location, unlike the behavior when you move files.

You can also create one or more independent audio files from selected regions in the Project Audio Browser and Tracks area.

Move all used audio files to a new folder

  1. Choose Edit > Select Used from the Project Audio Browser menu bar.

    All audio files that are used in the Tracks area are selected.

  2. Choose Audio File > Move File(s).

  3. Click the Move button.

  4. In the dialog that appears, select a folder (or create a new one), then click Save.

    All audio files used in the Tracks area are saved to the selected folder. The path information for all open projects that use the audio files is also updated. This makes projects easier to manage when moving audio files. After you move files to a new location, save each open project to update all audio file storage references.

Copy or convert audio files

  1. Select one or more audio files.

  2. Choose Audio File > Copy/Convert File(s) from the Project Audio Browser menu bar.

  3. Choose settings in the “Copy/convert file as” dialog.

    You can set the sample rate, bit depth, file format, stereo conversion, and dither type for the destination file.

  4. Choose the target folder for the new audio files. You can also create a new folder, by clicking the New Folder button.

  5. If you’re only copying one file, you can enter a name for the new audio file. When simultaneously copying several audio files, existing filenames are used for the copies derived from them. The Hide Extension checkbox hides or shows file extensions (.wav, .pngf, and so on) in the Save As field.

  6. Select the “Change file reference in Project Audio” checkbox to replace the audio file used in the project with the copied file.

    If unselected, both the copy and original audio file are shown in the Project Audio Browser.

  7. Click Save.

Convert selected regions into independent audio files

  1. Do one of the following:

    • Choose Audio File > Save Region(s) As from the Project Audio Browser menu bar.

    • Choose Edit > Convert > Audio Region to New Audio File from the Tracks area menu bar.

    • Choose File > Export > Region as Audio File from the main menu bar.

  2. Choose settings in the dialog that appears.

  3. Choose the target folder for the new audio files. You can also create a new folder, by clicking the New Folder button.

  4. If you’re only saving one region, you can enter a name for the new audio file. The Hide Extension checkbox hides or shows file extensions (.wav, .pngf, and so on) in the Save As field.

  5. Click Save.

Published Date: Jul 6, 2016
Helpful?

Additional Product Support Information