Logic Pro X: MIDIリージョンをスタンダードMIDIファイルとして書き出す

MIDIリージョンをスタンダードMIDIファイルとして書き出す

1つまたは複数のMIDIリージョンをスタンダードMIDIファイルとして書き出し、ほかの音楽Appで再生することができます。MIDIリージョンのみが含まれるプロジェクトの場合は、リージョンどうしを結合して、プロジェクト全体を1つのMIDIファイルとして書き出します。書き出しの前には、いくつかの手順を踏んでMIDIリージョンを準備する必要があります。

スタンダードMIDIファイルのタイプ0フォーマットにはMIDIリージョンを1つしか保存できないため、フォーマット0のMIDIファイルに書き出す場合はすべてのMIDIリージョンを結合する必要があります。これには、リージョンを選択してから、「編集」>「結合」と選択します(または接着ツールを使います)。

MIDIリージョンを書き出す準備をする

  1. Controlキーを押しながらリージョンをクリックし、ショートカットメニューから「MIDI」>「リージョンパラメータをノーマライズ」と選択します。

  2. Controlキーを押しながらリージョンをクリックし、ショートカットメニューから「MIDI」>「クオンタイズを永続的に適用」と選択します。

  3. トラック領域のメニューバーから「機能」>「リージョンエイリアス」>「エイリアスをコピーに変換」と選択し(または「エイリアスをリージョンのコピーに変換」キーコマンドを使います)、エイリアスをリージョンのコピーに変換します。

  4. ループを選択して、ショートカットメニューから「変換」>「ループをリージョンに変換」と選択し、すべてのループをリージョンに変換します。

  5. 「編集」>「結合」>「リージョンをトラックごとに」と選択し(または「トラックごとにリージョンを結合」キーコマンドを使います)、各トラックのすべてのMIDIリージョンを連続したMIDIリージョンに変換します。

  6. トラック領域のメニューバーで「機能」>「音源のMIDI設定をイベントとして挿入」と選択し、すべての音源MIDI設定をイベントとして挿入します。

1つまたは複数のMIDIリージョンをスタンダードMIDIファイルとして書き出す

  1. 書き出すMIDIリージョンを選択します。

  2. 「ファイル」>「書き出す」>「選択範囲をMIDIファイルとして」と選択します。

  3. 保存先のフォルダを選択し、ファイル名を入力して「保存」をクリックします。選択したMIDIリージョンがフォーマット1のMIDIファイルとして保存されます。

    注記:MIDIファイルを書き出してハードウェアシーケンサーで使う場合は、ファイル名の文字数を「8.3」形式(「proj0001.MID」など)に収まるようにしなければならないこともあります。

1つのMIDIリージョンをフォーマット0のMIDIファイルとして書き出す

  1. 「Logic Pro」>「環境設定」>「一般」と選択し、「プロジェクト処理」をクリックして、「“MIDIファイルを書き出す...”で1つのMIDIリージョンをフォーマット0で保存」チェックボックスを選択します。

  2. 書き出すMIDIリージョンを1つ選択します。

  3. 「ファイル」>「書き出す」>「選択範囲をMIDIファイルとして」と選択します。

  4. 保存先のフォルダを選択し、ファイル名を入力して「保存」をクリックします。選択したMIDIリージョンがフォーマット0のMIDIファイルとして保存されます。

公開日: 2019/09/13
役に立ちましたか?