Final Cut Pro X: 符合帧尺寸和帧速率

符合帧尺寸和帧速率

Final Cut Pro 会自动管理项目设置。这表示您可以处理同一项目中多个具有不同帧尺寸(也称为分辨率)和帧速率的媒体类型。将第一个视频片段添加到项目时,Final Cut Pro 将自动根据第一个片段的属性(或更准确地说,根据片段的源媒体文件的属性),设定整个项目的格式、帧尺寸和帧速率。

您可以随时修改项目的设置,且可以逐个片段控制 Final Cut Pro 让单个片段的帧速率和帧尺寸与项目设置匹配的方式。该部分的所有项目信息均适用于复合片段,可自行进行项目设定。

您可以将隔行扫描片段添加到逐行扫描(非隔行扫描)项目,也可以将逐行扫描片段添加到隔行扫描项目。若要将隔行扫描片段添加到逐行扫描项目,请参阅下面的说明。Final Cut Pro 会自动接受隔行扫描项目中的逐行扫描片段。

在处理多种格式和帧尺寸时,需要注意以下事项:

  • 根据要与观众分享最终影片的方式选取视频和音频项目属性。例如,如果要编辑的项目含混合格式媒体且要将其作为 1080p HD 分享,则应该将项目的视频属性设定为 1080p HD。

  • 如果不确定最终发布格式,您可以在创建项目之前做出的最重要决定是选取项目的帧速率。您可轻松更改项目的格式和帧尺寸,但更改帧速率会导致项目中的所有编辑点随时间推移而移动。

  • 如果片段与要用于分享项目的格式的视频和音频属性匹配,则先将此片段添加到项目。Final Cut Pro 会自动创建匹配的项目设置。这可让您无需稍后再去更改项目设置。

    【提示】如果添加到项目的第一个片段是音频片段或静止图像片段,Final Cut Pro 将提示您选取项目的视频属性。取消编辑,添加源媒体文件具有项目需要的视频属性的视频片段,然后将音频或静止图像片段添加到项目中。

选取符合帧尺寸的方法

您可以选取 Final Cut Pro 将片段的帧尺寸修改为与项目的帧尺寸设置匹配的方法。例如,可以让 Final Cut Pro 将片段的帧尺寸更改为适合项目帧尺寸的最长尺寸,填充项目的整个帧(通常导致裁剪),或保留片段的原始帧尺寸。

  1. 时间线中打开项目,然后添加帧大小(分辨率)与项目的帧大小不同的片段。

    有关将片段添加到时间线的信息,请参阅添加片段概述

  2. 在时间线中选择片段。

  3. 如果检查器尚未显示,请执行以下一项操作:

    • 选取“窗口”>“在工作区中显示”>“检查器”(或按下 Command-4)。

    • 点按工具栏右侧的“检查器”按钮。

      工具栏中的“检查器”按钮
  4. 点按检查器顶部的“视频”按钮。

    “视频”按钮
  5. 在“视频”检查器的“空间符合”部分中,点按“类型”弹出式菜单,然后选取一种帧大小符合方法。

    【注】如果所选片段拥有与项目相同的帧尺寸(分辨率),“空间符合”部分将不会显示。

    “视频”检查器的“空间符合”部分中的“类型”弹出式菜单
    • 适合:默认设置。让片段适合项目的帧尺寸,而不裁剪片段的视频。黑色条将显示在与项目帧尺寸不匹配的帧的边上。如果是高清晰度 (HD) 项目中的标准清晰度 (SD) 片段,Final Cut Pro 将放大 SD 片段,以适合 HD 项目的帧尺寸。如果是 SD 项目中的 HD 片段,Final Cut Pro 将缩小 HD 片段,以适合 SD 项目的帧尺寸。

    • 填充:让片段的视频填充项目的帧尺寸。如果是 HD 项目中的 SD 片段,Final Cut Pro 将放大 SD 片段,以适合 HD 项目的帧尺寸。如果是 SD 项目中的 HD 片段,Final Cut Pro 将缩小 HD 片段,以适合 SD 项目的帧尺寸。在这两种情况下,裁剪将沿片段的较长尺寸进行,以允许较短尺寸填充屏幕。

    • 无:保留片段的帧尺寸不变。如果片段的帧尺寸大于项目的帧尺寸,则片段将显示为已裁剪。如果片段的帧尺寸小于项目的帧尺寸,则片段周围将显示黑色条。

选取符合帧速率的方法

片段的帧速率与项目的帧速率不同时,Final Cut Pro 将采用帧采样方法将片段的帧速率更改为与项目的帧速率匹配。您可以选取 Final Cut Pro 用于修改片段帧速率的帧采样方法。选取的方法取决于消除视觉断断续续和假象的重要程度。

  1. 时间线中打开项目,然后添加帧大小(分辨率)与项目的帧大小不同的片段。

    有关将片段添加到时间线的信息,请参阅添加片段概述

  2. 在时间线中选择片段。

  3. 如果检查器尚未显示,请执行以下一项操作:

    • 选取“窗口”>“在工作区中显示”>“检查器”(或按下 Command-4)。

    • 点按工具栏右侧的“检查器”按钮。

      工具栏中的“检查器”按钮
  4. 点按检查器顶部的“视频”按钮。

    “视频”按钮
  5. 在“视频”检查器的“速率符合”部分中,点按“帧采样”弹出式菜单,然后选取一种帧速率符合方法。

    【注】如果所选片段的帧速率与项目的帧速率相同,“速率符合”部分不会显示在“视频”检查器中。

    “视频”检查器的“速率符合”部分中的“帧采样”弹出式菜单
    • 下限:默认设置。Final Cut Pro 在计算期间四舍五入到最近整数,以将片段的帧速率与项目的帧速率匹配。

    • 近邻:Final Cut Pro 在计算期间四舍五入到最近整数,以将片段的帧速率与项目的帧速率匹配。此设置减少了假象,但可能会造成视觉断断续续。需要渲染。

    • 帧融合:通过融合相邻帧的单个像素创建中间帧。相对于使用“向下取整”或“最近邻”设置创建的慢动作片段,使用“帧融合”创建的慢动作片段似乎播放更平滑。此设置将减少视觉断断续续,但可能会看到一些视觉假象。需要渲染。

    • 光流:一种使用光流算法在帧之间创建新入点的帧融合。Final Cut Pro 将分析片段以确定像素的定向运动,然后根据光流分析绘制新帧部分。此设置通常可最大程度地减少视觉上的断断续续和假象。需要渲染,且与其他帧采样方法相比所需时间更长。

将隔行扫描片段添加到非隔行扫描(逐行扫描)项目

一些视频格式采用隔行扫描方法将一个视频帧分成两个输出场,每个输出场包括在不同时间扫描的交替变化奇数和线条。

如果您要将隔行扫描片段添加到逐行扫描项目,可以用 Final Cut Pro 将片段消除隔行,使其以最高分辨率进行播放,避免出现与逐行扫描项目中的隔行扫描片段相关的交替变化的锯齿状线条。

  1. 执行以下一项操作:

    • 浏览器中,选择您要添加到逐行扫描项目中的隔行扫描片段。

    • 时间线中,选择您已经添加到逐行扫描项目中的隔行扫描片段。

  2. 如果检查器尚未显示,请执行以下一项操作:

    • 选取“窗口”>“在工作区中显示”>“检查器”(或按下 Command-4)。

    • 点按工具栏右侧的“检查器”按钮。

      工具栏中的“检查器”按钮
  3. 点按检查器顶部的“信息”按钮。

    “信息”按钮
  4. 点按“信息”检查器左下角的“元数据视图”弹出式菜单并选取“设置”。

    “信息”检查器中的“元数据视图”弹出式菜单
  5. 选择“消除隔行”复选框。

    【注】选择“消除隔行”设置会导致所选片段的帧速率加倍。例如,如果原始隔行扫描片段的帧速率为 29.97 fps,消除隔行后,片段的帧速率会达到 59.94 fps。当您为项目选取视频和音频设置时,请记住这一点。

    【提示】若要确认不存在交错的片段,您可以按下左箭头和右箭头按键,逐帧扫描时间线中的片段。

  6. 若要在播放过程中显示原分辨率帧,请点按检视器右上角的“显示”弹出式菜单并选取“较好质量”。

片段将进行播放,并发挥逐行扫描片段的功能。根据您电脑的特定配置,可能需要后台渲染

Published Date: 2019-9-17
Helpful?