Download icon

AirPort Extreme Firmware 5.5.1 for Windows

- Hard reset behavior is improved. With this firmware version pressing and holding the reset button for more than 5 seconds will cause the LED to flash rapidly. This visual feedback lets you know you’ve held the button long enough to trigger a hard reset

- Resolves a potential problem with PPPoE configurations when updating from 5.4 or earlier

- Improved reliability of WDS networks when using WPA security. If you had a WDS network secured by WPA and then removed any of the WDS nodes, this could cause a memory leak resulting in the need to reboot your WDS network nodes

- Resolved an issue with inbound passive FTP to a port-mapped computer on the network

- Resolved an issue with certain printers which were no longer recognized by the base station after the 5.5 firmware update was installed. With the 5.5.1 firmware these printers are again recognized by the base station.



The following items were part of the previous 5.5 release and are also included in this firmware:

- AirPort firmware updates are now packaged in a new utility application which simplifies the process of installing firmware updates. This application is available for use on Mac OS X computers (10.3 and later) and on Microsoft Windows 2000 or XP.

- USB printer renaming - USB printers connected to the AirPort Extreme can now be renamed by using the AirPort Admin Utility (version 4.1 or later).

- Multiple printer support for the “Power over Ethernet” model of AirPort Extreme - The “Power over Ethernet” model of AirPort Extreme now allows multiple USB printers to be connected through a USB hub to the AirPort Extreme. Other models of AirPort Extreme still support only one single USB-attached printer. To determine which model of AirPort Extreme you have, check this article.

- WPA security for WDS networks - WDS networks made up of AirPort Extreme and AirPort Express base stations can now be secured with WPA-Personal security. All AirPort Extreme and AirPort Express units must be upgraded to the latest appropriate 5.5 or 6.1 firmware before the network can be secured with WPA.

- Improved reliability for WDS networks - WDS nodes will now check for the presence of other WDS nodes. This results in better WDS network connectivity. All AirPort Extreme and AirPort Express units must be upgraded to the latest appropriate 5.5 or 6.1 firmware.

- In certain situations wireless clients could send certain types of data which could cause the AirPort Extreme to stop transmitting data. This issue is improved in the 5.5 firmware update.

- The 5.5 Firmware Update improves performance and other concerns related to FTP, RTSP, IPSec, TCP, UDP, and other IP protocols.

- Certain DNS traffic could affect AirPort Extreme performance. This issue is improved in the 5.5 firmware.

- Certain PPP or PPPoE connections (commonly used with DSL ISPs) could encounter a situation where the AirPort Extreme could not communicate with the ISP, requiring the base station and/or the ISP’s modem to be rebooted. This is fixed in the 5.5 firmware.

- Improved printing performance when printing to USB printers connected to the AirPort Extreme.

Print this page

File Size: 1.95MB

System Requirements Supported Languages