Lion Server:MySQL は付属していません

Lion Server では、以前のバージョンの Mac OS X Server に付属していた MySQL の代わりに、PostgreSQL が付属しています。前バージョンで MySQL を使っていて、Lion Server にアップグレードした場合は、最新バージョンの MySQL をインストールするか、データベースを PostgreSQL に移行する必要があります。

この記事はアーカイブ済みで、これ以上更新されることはありません。

新しいバージョンの MySQL のインストール

Mac OS X Server v10.5 または v10.6 から Lion Server にアップグレードまたは移行した場合、MySQL 5.0 のバイナリおよびデータベースはインストーラによって保存またはコピーされています。より新しいバージョンの MySQL (5.1 または 5.5) にアップグレードするには、以下のリンクで示す mysql.com サイトに掲載のデータベースアップグレード手順にそってください。

MySQL のマニュアルでは、5.5 にアップグレードする前に 5.0 環境を 5.1 にアップグレードすることを推奨しています。MySQL のダウンロードとインストールの手順は、次の MySQL Community Edition サイトに掲載されています。
http://www-jp.mysql.com/downloads/mysql/


PostgreSQL への移行

お使いのデータベースを OS 付属のバージョンの PostgreSQL に移行するための情報については、以下の Apple と PostgreSQL のドキュメントを参照してください。

重要:他社の Web サイトや製品に関する記述は、情報提供のみを目的としており、支持または推奨を意味するものではありません。Apple は、他社の Web サイトに掲載されている情報または製品の選択、性能、使用については、一切責任を負いません。Apple は、これらの情報を、ユーザの利便性を考慮して提供しているに過ぎません。Apple では、これらのサイトに掲載されている情報の評価を行っておらず、その正確性または信頼性についてはいかなる言及もいたしません。インターネット上のあらゆる情報または製品の使用には本来リスクが伴うものであり、この点について Apple はいかなる責任も負わないものとします。他社のサイトは Apple とは無関係であり、他社の Web サイトの内容を Apple が管理しているわけではないことをご理解ください。詳細については、「ベンダーに関する情報を見つける」を参照してください。

公開日: