Java for Mac OS X 10.5 Update 10 のセキュリティコンテンツについて

Java for Mac OS X 10.5 Update 10 のセキュリティコンテンツについて説明します。

Java for Mac OS X 10.5 Update 10 のセキュリティコンテンツについて説明します。これは、システム環境設定の「ソフトウェア・アップデート」パネル、または サポートダウンロード からダウンロードしてインストールできます。

Apple では、ユーザ保護の観点から、徹底的な調査が完了して必要なパッチやリリースが利用可能になるまでは、セキュリティ上の問題を公開、説明、または是認いたしません。Apple 製品のセキュリティについては「Apple 製品のセキュリティ」Web サイトを参照してください。

Apple Product Security PGP キーについて詳しくは、こちらの記事 を参照してください。

CVE ID でも脆弱性に関する詳細な情報を参照できます。

その他のセキュリティアップデートについては、こちらの記事 を参照してください。

Java for Mac OS X 10.5 Update 10

  • Java

    対象となるバージョン:Mac OS X v10.5.8、Mac OS X Server v10.5.8

    影響:Java 1.6.0_24 に複数の脆弱性がある。

    説明:Java 1.6.0_24 に複数の脆弱性があります。もっとも重大な脆弱性は、信頼されていない Java アプレットによって Java サンドボックス外の任意のコードが実行される可能性があることです。悪意を持って作成された信頼されていない Java アプレットが含まれる Web ページにアクセスすると、現在のユーザの権限を使って任意のコードが実行される可能性があります。この問題は、Java バージョン 1.6.0_26 にアップデートすることによって解消されます。詳しくは、Java Web サイト http://www.oracle.com/technetwork/jp/java/javase/releasenotes-136954.html を参照してください。

    CVE-ID

    CVE-2011-0802

    CVE-2011-0814

    CVE-2011-0862

    CVE-2011-0863

    CVE-2011-0864

    CVE-2011-0865

    CVE-2011-0867

    CVE-2011-0868

    CVE-2011-0869

    CVE-2011-0871

    CVE-2011-0873

  • Java

    対象となるバージョン:Mac OS X v10.5.8、Mac OS X Server v10.5.8

    影響:Java 1.5.0_28 に複数の脆弱性がある。

    説明:Java 1.5.0_28 に複数の脆弱性があります。もっとも重大な脆弱性は、信頼されていない Java アプレットによって Java サンドボックス外の任意のコードが実行される可能性があることです。悪意を持って作成された信頼されていない Java アプレットが含まれる Web ページにアクセスすると、現在のユーザの権限を使って任意のコードが実行される可能性があります。この問題は、Java バージョン 1.5.0_30 にアップデートすることによって解消されます。詳しくは、Java Web サイト http://www.oracle.com/technetwork/jp/java/javase/documentation/overview-137139.html を参照してください。

    CVE-ID

    CVE-2011-0802

    CVE-2011-0814

    CVE-2011-0862

    CVE-2011-0864

    CVE-2011-0865

    CVE-2011-0867

    CVE-2011-0871

    CVE-2011-0873

公開日: