OS X Server 3.1.2 のセキュリティコンテンツについて

この記事では、OS X Server 3.1.2 のセキュリティコンテンツについて説明します。

Apple では、ユーザ保護の観点から、完全な調査が終了して必要なパッチやリリースが利用可能になるまではセキュリティ上の問題を公開、説明、または是認いたしません。Apple 製品のセキュリティについては「Apple 製品のセキュリティ」Web サイトを参照してください。

Apple Product Security PGP キーについては「Apple Product Security PGP キーの使用方法」を参照してください。

CVE ID を使って脆弱性を調べることもできます。

その他のセキュリティアップデートについては、こちらの記事を参照してください。

OS X Server3.1.2

  • Ruby

    対象となるバージョン:OS X Mavericks v10.9.3 以降

    影響:信頼できない入力値を使って Float オブジェクトを作成する Ruby スクリプトを実行すると、アプリケーションがハングしたり、任意のコードが実行される可能性がある。

    説明:Ruby には、文字列を浮動小数点値に変換する際に、ヒープベースのバッファオーバーフローの脆弱性が存在します。攻撃者は、プロファイルマネージャまたは Ruby スクリプトに専用に作成された要求を送信して、アプリケーションをハングさせたり、任意のコードを実行させたりする可能性があります。この問題は、浮動小数点の値の検証を強化することで解決されました。

    CVE-ID

    CVE-2013-4164

Apple 製以外の製品に関する情報や、Apple が管理または検証していない個々の Web サイトは、推奨や承認なしで提供されています。Apple は他社の Web サイトや製品の選定、性能、使用については一切責任を負いません。Apple は他社の Web サイトの正確性や信頼性については一切明言いたしません。インターネットの使用にはリスクがつきものです。詳しくは各社にお問い合わせください。その他の会社名や製品名は、それぞれの所有者の商標である場合があります。

公開日: