MainStage 3 の問題を解決する

MainStage 3 で問題を切り分け、トラブルシューティングを行い、解決する方法をご案内します。

以下の推奨手順を表示されている順序で試していき、問題を切り分け、解決に至るまで続けてください。作業を進める前に、MainStage アプリケーションをバックアップしておいてください。

1. MainStage が最新の状態であることを確認する

必ず最新バージョンの MainStage 3 をお使いください。Apple メニュー () >「App Store」の順に選択し、ツールバーの「アップデート」をクリックします。アップデートが提供されている場合は、「アップデート」ボタンをクリックしてダウンロードし、インストールしてください。

2. デバイスまたはソフトウェアの互換性を確認する

Apple 以外の他社製の外付けのオーディオインターフェイス、MIDI インターフェイス、ストレージシステム、またはプラグインをお使いの場合は、最新バージョンの MainStage 3 との互換性があるか確認してください。詳しいサポートについては、メーカーにお問い合わせください。アップデートが提供されている場合は、メーカーの指示に従い、デバイスまたはソフトウェアをアップデートしてください。 

3. マニュアルを確認する

MainStage 3 ヘルプを参照し、MainStage が正常に動作しているか確かめてください。警告メッセージやエラーメッセージに表示される主な用語を MainStage ヘルプで検索できます。

4. 内蔵オーディオを使ってテストする

場合によっては、外付けのオーディオインターフェイスが互換性を欠いたり誤動作したりしているせいで、MainStage で問題が起きることがあります。外付けのオーディオインターフェイスをお使いの場合は、インターフェイスの代わりに Mac の内蔵オーディオを使ってみてください。

MainStage で内蔵オーディオを使うには、以下の手順を実行してください。

  1. 外付けのオーディオインターフェイスを Mac から取り外します。
  2. MainStage を開き、「MainStage」>「環境設定」>「オーディオ」の順に選択します。
  3. 「オーディオ出力」ポップアップメニューから「内蔵出力」を選択します。
  4. 「オーディオ入力」ポップアップメニューから「内蔵マイク」(または、コンピュータによっては「内蔵入力」) を選択します。
  5. 問題が起きていたコンサート、セット、パッチを使ってテストしてみます。

内蔵オーディオを使えば問題が起きない場合は、オーディオインターフェイスのアップデートや修理が必要だと考えられます。詳しいサポートについては、メーカーにお問い合わせください。

5. 新しいコンサートを作成する

コンサートファイルが予期せぬ動作をして、MainStage で使用できなくなる場合があります。

新しいプロジェクトを作成し、テストするには、以下の手順を実行してください。

  1. MainStage を開いて、「ファイル」>「新規」の順に選択します。
  2. ダイアログの「オーディオ入力」と「オーディオ出力」のポップアップメニューから、オーディオ入力とオーディオ出力に使うデバイスを選択します。
  3. 左側で音源のカテゴリをクリックしてから、使いたいテンプレートを選択します。
  4. 「開く」をクリックします。
  5. 新しいコンサートで問題が解決したかどうかをテストします。新しいコンサートで問題が起きなかった場合は、問題が起きていたコンサートが破損している可能性があります。コンサートファイルを再構築してみてください。

破損したコンサートファイルを再構築する

コンサートを再構築する場合は、レイアウト、セット、パッチをコンサートから書き出して、新しいコンサートに読み込みます。

  1. 問題が起きているコンサートを開きます。
  2. レイアウトを書き出すには、「レイアウト」をクリックし、「レイアウト」セクションの上部にあるギアマークのアイコンをクリックして、メニューから「レイアウトを書き出す」を選択します。レイアウトの保存先を選択してから、「書き出す」をクリックします。
  3. セットやパッチを書き出すには、「編集」をクリックし、パッチリストの中をクリックしてから「command + A」キーを押して (または「編集」>「すべてを選択」を選択して)、パッチリストの中のセットとパッチをすべて選択します。それらをまとめてデスクトップまたはフォルダにドラッグします。
  4. コンサートを閉じます。
  5. 任意のテンプレートから新しいコンサートを作成します。
  6. 「レイアウト」をクリックし、「command + A」キーを押して (または「編集」>「すべてを選択」を選択して)、「レイアウト」セクションの中の要素をすべて選択し、「delete」キーを押してすべて削除します。
  7. 元のコンサートからレイアウトを読み込むには、「レイアウト」セクションの上部にあるギアマークのアイコンをクリックし、メニューから「レイアウトを読み込む」を選択します。レイアウトを選択し、「読み込む」をクリックします。
  8. 「編集」をクリックし、パッチリストの中のセットとパッチをすべて選択してから「delete」キーを押して、既存のパッチをすべて削除します。
  9. 元のコンサートからパッチリストにパッチをドラッグします。パッチリストにドラッグした後で、セットやパッチの順序を入れ替える必要が生じる場合があります。
  10. 新しいコンサートをテストして、問題が起きるかどうかを確かめます。

6. 別のユーザアカウントを試す

Mac 上の別のユーザアカウントで MainStage を開きます。別のユーザとしてログインしてみると、問題の挙動が特定のユーザの設定やファイルに関係しているかどうかを見極める上で参考になります。

7. 環境設定をリセットする

MainStage の環境設定をリセットしても、プロジェクトファイル、プリセット、パッチには影響ありません。しかし、環境設定にカスタム設定を加えていた場合、その設定内容は失われます。

環境設定をリセットする前に、「MainStage」>「環境設定」の順に選択し、具体的な設定内容を書き留めておいてください。そうしておけば、環境設定をリセットした後で、カスタムの設定を元通りに適用できます。各種の環境設定について詳しくは、MainStage ヘルプの「環境設定の概要」を参照してください。

MainStage の環境設定をリセットするには、以下の手順を実行してください。

  1. MainStage が開いている場合は終了します。
  2. Finder で、「option」キーを押しながら「移動」>「ライブラリ」の順に選択します。
  3. 「Preferences」フォルダから「com.apple.mainstage3.plist」ファイルを削除します。
  4. Mac を再起動します。

Mac が再起動されたら、MainStage を開いて、当初起きていた問題を再現してみます。問題が解消した場合は、MainStage の環境設定を開いて、カスタム設定を適用し直してください。

8. MainStage を再インストールする

問題が解決しない場合は、MainStage を削除してから再インストールしてください。既存の MainStage コンサートは削除されないので、再インストールした後で開くことができます。

  1. Finder で、「移動」>「アプリケーション」の順に選択します。
  2. MainStage 3 を探してゴミ箱にドラッグします。
  3. Mac App Store から MainStage を再インストールするか、バックアップから復元します。MainStage をバックアップから復元する場合は、保存されている場所から「アプリケーション」フォルダにドラッグするか、Time Machine バックアップから復元してください。

Apple 製以外の製品に関する情報や、Apple が管理または検証していない個々の Web サイトは、推奨や承認なしで提供されています。Apple は他社の Web サイトや製品の選定、性能、使用については一切責任を負いません。Apple は他社の Web サイトの正確性や信頼性については一切明言いたしません。インターネットの使用にはリスクがつきものです。詳しくは各社にお問い合わせください。その他の会社名や製品名は、それぞれの所有者の商標である場合があります。

公開日: